Results 1 to 3 of 3

Thread: login problems with admin/admin

  1. #1
    Join Date
    Dec 2007
    Location
    Slovenia
    Posts
    2

    Unhappy login problems with admin/admin

    Hello!

    I have problems with login to my router after I updated firmware. I can ping router, when I try http://192.168.1.1 it ask me for username,password and admin/admin doesn't work. I also tried root,user,administrator,password words in all combinations and nothing works. I tried last 2 firmwares
    WL500gp-1.9.2.7-7g.trx and
    WL500gp-1.9.2.7-8.trx

    same problem with both. When I tried DD-WRT - dd-wrt.v23_asus.trx it works with no problem (root/admin). I guess I updated firmwire correctly otherwize it wouldn't even ask me for password.
    Any suggestions?

    regards!

  2. #2
    Join Date
    Dec 2007
    Location
    Slovenia
    Posts
    2
    ok another problem
    I uploaded DD-WRT firmware which works and I changed IP from 192.168.1.1 to 10.1.1.1 . Then I tried on another computer Oleg's firmware and it changed BUT it keeped IP 10.1.1.1. So, now I can't access it with username/password (admin/admin) and I can't even rewrite it to DD-WRT because Firmware restoration program is looking for ip 192.168.1.1
    Emm I red somethink about tftp command to put firmware up to specific IP, but I can't get it work. Any idea? a little help?

    __________________________
    edited:

    it works. If anyone else need help with this: this is how to do it

    You need:
    wl500g-clear-nvram.trx
    wl500g-recover.trx
    dd-wrt.v23_asus.trx

    First you set router into recovery mode, then set your IP in the range of your ruter's ip (usually 192.168.1.x, gateway is 192.168.1.1). In my case I set ip 10.1.1.2 , gateway 10.1.1.1. When router in is recovery mode you should be able to ping it.

    1. recovery mode
    2. tftp -i 192.168.1.1 PUT wl500g-clear-nvram.trx (wait a minute)
    3. recovery mode
    4. tftp -i 192.168.1.1 PUT wl500g-recover.trx (wait a minute) Here I noticed that router changed IP from 10.1.1.1 to 192.168.1.1 so I had to changed my IP.
    5. recovery mode
    6. tftp -i 192.168.1.1 PUT dd-wrt.v23_asus.trx (wait a minute)
    7. reset (power out, power in), wait a minute, login with root/admin

    done. This is how to flash router without Asus firmware restoration tool. I tried to do this with Oleg's firmware but it didn't work. I guess I will stay with DD-WRT firmware until next version.

    regards
    Last edited by primorc1; 30-12-2007 at 12:38.

  3. #3
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    Actually, just a small bit of theory:

    Oleg's fw doesn't contain any passwords. Password for web-IF is stored in nvram (username is always admin). This is true always independently from the following.

    In case if there is no file /etc/passwd, telnet/ssh access is granted to user root with the same password as in web-IF. If there is file /etc/passwd then the user accounts and passwords are stored in it, which can be used for shell logins.

    /etc/passwd is not stored in the firmware, but in the user-writeable area of the flash.

    So, in any case the problem is in corrupted nvram or user-area-of-the-flash

    BTW, have you tried reset button on the back of the router?

Similar Threads

  1. Busybox and thttpd Problems
    By Magnus in forum WL-700g Q&A
    Replies: 4
    Last Post: 10-11-2008, 21:40
  2. SSH login problems after installing 1.0.4.6_kc_02a
    By pvarela in forum WL-700g Firmware Discussion
    Replies: 3
    Last Post: 12-07-2007, 01:02
  3. login as standard user and su
    By mistraller in forum WL-500g Q&A
    Replies: 4
    Last Post: 02-03-2007, 19:45
  4. Login problem HELP ME PLEASE
    By holla in forum WL-500gP Q&A
    Replies: 1
    Last Post: 24-01-2007, 20:30
  5. problems with file handling or file size
    By black_bottom in forum WL-HDD Q&A
    Replies: 1
    Last Post: 28-03-2006, 16:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •