Page 3 of 3 FirstFirst 123
Results 31 to 40 of 40

Thread: Project WL-HDD and Weather Station (WS2300)

  1. #31

    Two or more USB->RS/232 convertors

    Hello, is it possible connect (via USB hub) 2 or more USB convertors? Thx

  2. #32
    yes, you can do that. works like a charm.

  3. #33
    I have first convertor on 1st USB port. In 2nd USB port I have a USB HUB. If I plug 2nd RS232 convertor into USB HUB, WL don't detect this convertor. Any idea? Thx.

  4. #34
    Join Date
    Feb 2007
    Moscow, Russia
    the problem is generally known. Its reason is poor usb support in old 2.4 kernel.

    Possible solutions:
    1) use usb1 hub
    2) disable usb2 support ( rmmod ehci-hcd )
    3) try firmware from here: It has last 2.4 kernel and improved usb support.

    BTW, which device you have?

  5. #35


    Thx, I have profilic chip convertors (one for temper DS, one for LCD).

  6. #36


    Hello tryme

    what is your LCD application and your HW setup? I guess you are using ipkg software. Right? Tnx

  7. #37

    Question Need advice on loading firmware

    Good day all,

    I have a new WL-500gP V2 SN A4IAAC017945, PIN Code 58450550, MAC 485B394AC003, ASUS Firmware 3.0.44

    I am trying to load WL500gpV2- (attached) which is modified to allow me to connect my USB enabled weather station and serve weather data on the web.

    I first tried the web interface and it failed with an error

    (see image)

    I put the unit into recovery mode and tried tftp

    darcypa@darcypa-laptop:~/Documents$ ping
    PING ( 56(84) bytes of data.
    64 bytes from icmp_seq=1 ttl=100 time=4.18 ms
    64 bytes from icmp_seq=2 ttl=100 time=1.79 ms
    64 bytes from icmp_seq=3 ttl=100 time=2.27 ms
    64 bytes from icmp_seq=4 ttl=100 time=5.17 ms
    --- ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3289ms
    rtt min/avg/max/mdev = 1.796/3.356/5.172/1.378 ms
    darcypa@darcypa-laptop:~/Documents$ tftp
    tftp> binary
    tftp> verbose
    Verbose mode on.
    tftp> get ASUSSPACELINKaaaa /dev/null
    getting from to /dev/null [octet]
    Transfer timed out.

    tftp> put WL500gpV2- ASUSSPACELINK
    putting WL500gpV2- to [octet]
    Transfer timed out.

    tftp> quit

    I also tried the ASUS Firmware recovery mode which also failed.

    (see image)

    Can anyone think of anything else? Can this be done via the ZVMODELVZ page?

    I suspect there must be some sort of name check or signature check in place?

    Attached Images Attached Images   
    Attached Files Attached Files

  8. #38
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    when you upload a firmware image via tftp (firmware restoration tool = tftp) the router won't check if the models are the same...

    what exactly is changed in the firmware? if it's just a kernel module which need to load up?

  9. #39
    what exactly is changed in the firmware? if it's just a kernel module which need to load up?
    I suspect that it is the USB funtions that were added. I go the file from here

    I have very basic understanding (insatll, add packages etc...) of Linux but don't know how to make my own kernal. This firmware is exacly what I am looking for thats why I wanted to try it.

    I also found another site that uses OpenWRT that I might try next If I can't get this one working.


  10. #40
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    Quote Originally Posted by waveqam View Post
    I suspect that it is the USB funtions that were added. I go the file from here
    well, I've searched a bit, and found this weatherstation that is supported by the software on that site.
    found this guy writing about it, and using linux:
    all it needs is a library called "libusb" (as I suspected) which runs on pretty much any firmware

    you can keep trying koppel, which is a modified version of oleg firmware ( ), it adds support for usb 3G modems or hsdpa, something like that
    openwrt is also quite nice, in the end, they have all access to the same libraries.

    anyway, the guy also writes about using free software:
    initially spent some time getting the unit to work with wview, for which I received a patch for an old version. I had lots of trouble with wview, and when the power company damaged the unit in November, I started writing my own code.

    The software is written in C (of course!), accesses the USB hardware with libusb, whatever that may be (there appear to be at least 3 different incompatible ones, and it's not the current version described on the libusb project home page). I store readings in a MySQL database, use gnuplot to generate the images, and display it on web pages using PHP and Apache. If it weren't for the fact that it runs on FreeBSD, it would be a typical LAMP application.
    it requires a bit more work probably tho

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Asus WL-500gP V2 & Sony Play Station Portable (PSP)
    By Vertige in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 102
    Last Post: 31-10-2011, 06:41

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts