Page 1 of 4 123 ... LastLast
Results 1 to 15 of 48

Thread: Firmware v1.8.1.7 CR3 [Oleg]

  1. #1
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353

    Firmware v1.8.1.7 CR3 [Oleg]

    New firmware available for
    WL500g
    WL500gx
    WLHDD
    WL500b
    WL500bv2
    WL300g
    Sources and other info available here.

    Changes:
    • Preliminarily WL-HDD support, www pages credits are going to Antiloop (ide partitions does not get mounted automatically, except when USB drive is attached; most of the wl500g functionality is included).Thanks to Antiloop for performing various ide related testing (16 test versions evaluated)
    • Fixed firewall rules with virtual servers enabled
    • Added 802.11g LRS mode
    • Updated samba to 1.9.18p10 (latest from the old 1.9 series)
    • Fixed 1.8.1.7-2a second NTP server field problem
    • Changed makefiles, so firmware could be now recompiled with no root privileges, fixed various things to enable faster compiling and reliable packaging
    • Added nls support for russian codepages 866 and 1251 (use nvram set usb_vfat_options=codepage=866,iocharset=cp1251 for correct filenames handling)
    • Changed pppoe daemon behaviour - it's should now try reconnect as many times as needed
    • Updated dnsmasq to 2.17, probably static leases (manual IP assignment) will work better
    • Updated busybox to 1.00, added 2 new applets: fdisk and wget
    • Added mke2fs and e2fsck programs from the e2fsprogs package
    • Optimized stupid-ftpd performance for both upload and download


    Root fs is no longer available as separate download - instructions for making root fs is updated.

    Samba now supports real users with their passwords, documentation is yet to come.
    My current files are follow (remember to add modified files to flashfs):
    Code:
    [root@wl500g etc]$ cat /etc/passwd
    root:$1$$LMuXuAPfSStW8rhnojbc41:0:0:root:/usr/local/root:/bin/sh
    nobody:x:99:99:nobody:/:/sbin/nologin
    oleg:x:100:100:oleg:/tmp/harddisk:/sbin/nologin
    nk:x:100:100:nk:/tmp/harddisk:/sbin/nologin
     
    [root@wl500g etc]$ cat /etc/smbpasswd
    # Samba SMB password file
    root:0:6F9F65B23B4B48E7613E8293942509F0:7741DF71C7  48ABCC71C6C263B99C2B08:root:/usr/local/root:/bin/sh
    oleg:100:9EE3D0611811EA5C417EAF50CEAC29C3:F3AC46A6  CB04CB32FE1C77A025CF6C53:oleg:/tmp/harddisk:/sbin/nologin
    nk:100:8A5D3EB54FF11B0DB79AE2610DF89D4C:9FDB1AFF30  84809671715D8AE948AA35:nk:/tmp/harddisk:/sbin/nologin
    [root@wl500g etc]$ cat /etc/smbusers
    root = administrator
    [root@wl500g etc]$ cat /etc/smb.conf
    [global]
            workgroup = WORKGROUP
            guest account = nobody
            security = user
            encrypt passwords = yes
            log level = 1
            max log size = 100
            username map = /etc/smbusers
            client code page = 866
            character set = 1251
    [share]
            path = /tmp/harddisk
            writable = yes
    [root$]
            path = /
            writable = yes
    [root@wl500g etc]$
    Last edited by Antiloop; 16-11-2004 at 01:51. Reason: added firmwares for download.

  2. #2
    Changed pppoe daemon behaviour - it's should now try reconnect as many times as needed
    Uh oh, i see a problem with that. Some people (like me) have the AP configured for their ISP (username, password, etc), but use another computer for the connection / routing from time to time.

    If needed, one could hook the modem up to the AP and dial in manually from the web interface and was online without the hassle of searching the login information from the ISP.

    In your last ROM, ppp just died and stated that the "cable was not connected". Is that still true for this release? Doesn't make much sense to have the deamon retry over and over again in this case.

    Ideally, the web interface would have a "Turn off dialing" switch

    BTW: Thanks for your great work on these ROMs!

  3. #3
    Hi Oleg,

    thanx for the great work !

    can you tell me where i can find the Busybox 1.00 final full Version ?
    And pls why is the root fs not longer available ? i'am start the
    firmware from hdd, so i must first flash and the copy the firmware

    best regards

    - Trixam -
    Last edited by trixam; 15-11-2004 at 23:41.

  4. #4
    Join Date
    Nov 2003
    Location
    Eindhoven
    Posts
    2,407
    Quote Originally Posted by trixam
    Hi Oleg,

    thanx for the great work !

    can you tell me where i can find the Busybox 1.00 final full Version ?
    And pls why is the root fs not longer available ? i'am start the
    firmware from hdd, so i must first flash and the copy the firmware

    best regards

    - Trixam -
    please read oleg's post.. you can find there instruction where to find stuff to update rootfs..

    and also I'm not in the mood to mirror 6 rootfs's for all different firmwares
    Last edited by Antiloop; 16-11-2004 at 09:35.

    My little Asus Collection: Too much to fit inhere, my 2 babies:WL500w 1.9.2.7-10(OLEG) VX2SE Yellow Lamborghini notebook



    WL500g Forum Asus Files OpenDir

    Asusforum.NL -- Asusforum.DE -- Asusforum.RU -- Asusforum.PL -- Asusforum.NET -- Asusforum.EU -- Asusforum.BE -- Asusforum.ES -- Asusforum.INFO

  5. #5
    Quote Originally Posted by Antiloop
    please read oleg's post.. you can find there instruction where to find stuff to update rootfs..

    and also I'm not in the mood to mirror 6 rootfs's for all different firmwares
    Hi Antiloop,

    i know how i can bulid a root fs but I would not like flash my wl500g for build
    it.

    Btw thanx to you for all the work and test on the forum.

    best regards

    - Trixam -

  6. #6
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by trixam
    i know how i can bulid a root fs but I would not like flash my wl500g for build
    it.
    Keep in mind, that even with rootfs you need to flash firmware to update the kernel (it's not stored in the root fs).

  7. #7
    A note on rebuilding:

    On my system a make in the cd wl500g-1.8.1.7-3 directory fails. The reason is, that the make utility simply ignors the target www. So the www folder in the gateway-dir is not created, and the copy of www/iBox_title_all_HDD.jpg fails.

    I don't know why make ignors the www target, but as a workaround I added a target www2 to the Makefile:

    Code:
    www2:
            [ ! -d $(SRC)/www ] || [ -d $(TOP)/www ] || \
                    tar -C $(SRC) -cf - www | tar -C $(TOP) -xf -
            [ ! -f www.diff ] || patch -d $(TOP) -p1 < www.diff
    It's exactly the same code as in the % target.

    Btw, my system is Gentoo Linux and the make is GNU make version 3.80...strange

  8. #8
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by lexi
    Btw, my system is Gentoo Linux and the make is GNU make version 3.80...strange
    Well, this is the second strangeness with Gentoo... Previously it failed with mksquashfs, right?
    It would be great if you found the real reason for the problem.

    My thought - your make have seen www directory in the wl500g-1.8.1.7-3 and concluded, that it's up to date. There should be a way to change this behaviour.

  9. #9
    Join Date
    Nov 2004
    Location
    Melbourne, Australia
    Posts
    21
    just a quick note, i couldn't get this firmware to work at all, with bigpond. Has anything changed in this firmware which could possibly affect the heartbeat, because 1.8.1.7-2a works just fine, where as this one shows up as connected but doesn't do anything, everything just times out.

  10. #10
    Join Date
    Apr 2004
    Location
    Netherlands
    Posts
    1,307
    Just a note to anyone using this firmware:

    Virtual server and Webcam are, in contrast to other firmwares, enabled. Turn them off if you don't need them.

    Nice fix on the 2nd NTP server problem, LOL.

    As allways good work Oleg!

  11. #11
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by Wesleyrpg
    just a quick note, i couldn't get this firmware to work at all, with bigpond. Has anything changed in this firmware which could possibly affect the heartbeat, because 1.8.1.7-2a works just fine, where as this one shows up as connected but doesn't do anything, everything just times out.
    Nothing changed in respect to bigpond. Probably your config is messed up by switching between firmwares. Reset to defaults and config again.

  12. #12
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Sources are reuploaded

    There was a typo in makefile, which is preventing kernel compiling. Also, I've probably fixed problems with Gentoo.

    md5sum for new file is
    c629bd834b6214680a99b9328e9fe3c8 wl500g-1.8.1.7-3.tar.bz2

    Updated once again:
    ce4f54eb31c3acd9adc11665ffea60fc wl500g-1.8.1.7-3.tar.bz2
    Last edited by Oleg; 18-11-2004 at 10:51.

  13. #13
    Join Date
    Nov 2004
    Location
    Melbourne, Australia
    Posts
    21
    i thought i'd give this firmware another go, and yes i did reset to defaults last time as well, but this time 1.8.1.7-3 is working just fine with the heartbeat. i'm not sure what happened last time, but yeah this 'custom' firmware is great! Thanks heaps Oleg!

    Quote Originally Posted by Oleg
    Nothing changed in respect to bigpond. Probably your config is messed up by switching between firmwares. Reset to defaults and config again.
    Last edited by Wesleyrpg; 19-11-2004 at 01:51. Reason: Poor grammar and spelling

  14. #14
    Join Date
    Aug 2004
    Location
    Germany
    Posts
    377
    Hi

    It seems i found a bug in the Javascripts that controll the admin page. If you repeatedly switch between two sellections in some of the pulldown menus they get longer and longer (see Screenshot).

    Also, It still dont shows the printer status in the Status page (Blank fields).

    The rest is a great release, now have to test Samba

    A question: Can you embed the NetIO binary in the next release, great for testing and only 25k or less.

    Greets
    Attached Images Attached Images  
    My Stuff: WL-500g, Mapower H31x 10GB HD, Philips Webcam Vesta PRO, TerraTec Webcam PRO, USB Hub

  15. #15
    Oleg,
    Can you still have a look at the WPA-PSK/TKIP and WPA-PSK/TKIP+AES issue, as has been discussed in the 1.8.1.7-2 forum?
    Thanks.

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Firmware v1.9.2.7 CR1 [Oleg]
    By Oleg in forum WL-500g Firmware Releases
    Replies: 53
    Last Post: 14-04-2005, 00:26
  2. Firmware v1.9.2.7 CR2 [Oleg]
    By Oleg in forum WL-500g Firmware Releases
    Replies: 64
    Last Post: 11-01-2005, 19:22
  3. Firmware v1.7.5.9 CR2 [Oleg]
    By Oleg in forum WL-500g Firmware Releases
    Replies: 38
    Last Post: 06-10-2004, 09:12
  4. Firmware v1.7.5.6 CR2.1 [Oleg]
    By Antiloop in forum WL-500g Firmware Releases
    Replies: 18
    Last Post: 03-05-2004, 12:13
  5. Firmware v1.7.5.6 CR1 [Oleg]
    By Antiloop in forum WL-500g Firmware Releases
    Replies: 15
    Last Post: 07-04-2004, 18:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •