Page 1 of 4 123 ... LastLast
Results 1 to 15 of 49

Thread: Transmission - segmentation fault

  1. #1
    Join Date
    May 2007
    Belgrade, Serbia

    Transmission - segmentation fault

    Evey time I wanna see info for some torrent I get the segmentation fault.
    The core file is (from /opt/torrent/.transmission folder):

  2. #2
    Join Date
    Jun 2005
    Quote Originally Posted by marco82 View Post
    Evey time I wanna see info for some torrent I get the segmentation fault.
    The core file is (from /opt/torrent/.transmission folder):
    This is probably bug in transmission lib not providing nonblocking scrape info any more.

  3. #3
    Join Date
    Jun 2005
    Quote Originally Posted by marco82 View Post
    Evey time I wanna see info for some torrent I get the segmentation fault.
    The core file is (from /opt/torrent/.transmission folder):

    I will change this back to libbt.

  4. #4
    Join Date
    May 2007
    Belgrade, Serbia
    OK, let us know when u do that, and also how to fix it.


  5. #5

    Unhappy transmission 1.11 segmentation fault

    When i run transmission-daemon like this:
    cd /tmp/harddisk/torrent && transmission-daemon -f -p /opt/var/run/ -s /etc/transmission.socket

    i get a segmentation fault: (was stable with 1.06)

    [warn] epoll_create: Function not implemented
    [warn] epoll_create: Function not implemented
    Transmission 1.11+ (5576) started
    Queued for verification
    Verifying torrent
    Queued for verification
    Bound socket 14 to port 51413
    Opened port 51413 to listen for incoming peer connections
    Verifying torrent
    Segmentation fault

    I would like to go back to version 1.06.
    Can someone please attach this for me?

  6. #6
    Join Date
    Jun 2005

  7. #7
    Thanks Oleo,

    The 'segment fault' has been resolved!

  8. #8

    Transmission: can't load library ''

    I`ve just did ipkg update& ipkg upgrade and when I want to start transmission I get this message
    "transmissiond: can't load library ''"??

    Is there a solution?

  9. #9
    Join Date
    Feb 2007
    Moscow, Russia
    ipkg install -force-reinstall curl

  10. #10
    Join Date
    Jun 2008
    Södra Vallgrund

    Transmission 1.34+ r6844 compile error

    The last couple of days I get a compile error when trying to cross-compile Transmission trunk. It builds with no problem natively in Debian. Please help!!

    natpmp.c:84: warning: no previous prototype for 'sendpendingrequest'
    natpmp.c:100: warning: no previous prototype for 'sendnatpmprequest'
    natpmp.c:165: warning: no previous prototype for 'readnatpmpresponse'
    natpmp.c: In function `sendnewportmappingrequest':
    natpmp.c:162: internal compiler error: in arm_print_operand, at config/arm/arm.c:11866
    Please submit a full bug report,
    with preprocessed source if appropriate.
    Send email to for instructions.
    {standard input}: Assembler messages:
    {standard input}:302: Warning: partial line at end of file ignored
    make[3]: *** [natpmp.o] Error 1
    make[3]: Leaving directory `/home/andersos/projects/optware/trunk/cs05q3armel/builds/transmission/third-party/libnatpmp'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/andersos/projects/optware/trunk/cs05q3armel/builds/transmission/third-party'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/andersos/projects/optware/trunk/cs05q3armel/builds/transmission'
    make: *** [/home/andersos/projects/optware/trunk/cs05q3armel/builds/transmission/.built] Error 2

  11. #11

    Transmission 1.34 imature

    Hi, there

    I just need to write down my frustrations so I can get over them.
    First of all I would like to shout Transmission 1.34 IS A PIECE OF SHIT!
    Now after this is over I would like to write down my problems.
    First of I was very happy with Transmission 1.22.
    But one day my torrents were downloading really slow. I thought maybe my Internet provider is lowering the priority of my torrents or some other people are sabotaging the torrent uploading by uploading bad chunks.
    So I figured out that maybe I should upgrade because the new version will have encryption and better security and so on.
    I upgraded and remained with my mouth open not from amazement but from being puzzled.
    So I started to try around and play and experiment.
    Thanks to this thread:
    I was able to figure out how it works.
    I'll continue with the negatives on the next post.

  12. #12

    Negatives second part

    First fucking big problem is that I can not add comment to the torrent. Oh this is real fucking big problem because I am a member of many closed torrent portals and by adding comment to the torrents I was able to see who belongs to who and I was able to keep manageable my stuff.
    Second big fucking problem is that transmission 1.22 put the torrents in separate directory's.
    For example it put them in a directory of the name of the torrent file.
    Now this shit puts them in a directory unleashed mode.
    This is bad because the old way I was able to manage the files much better.
    Third fucking big problem is that of putting the files into one directory the files will be open to abuse.
    I do not know what would happen if you have two torrents with one readme.txt in the root.
    Please somebody explain this to me.
    It takes to me quite long time to upgrade because of the directory problems.
    I can not see the syslog, log. (Log button missing)
    I can not get info about the torrent regarding what type
    of files contains. (Info button missing)
    About button also missing.
    There is no fucking Fetch option.
    During download does not shows to how many pears I am uploading.
    Does not show the ratio in this stage.

    In the next post I will write down some tips on how to make a smother upgrade.
    Last edited by Freelancer; 05-10-2008 at 09:50.

  13. #13

    A helpfull post

    This is a quite helpful post regarding how to configure and start the new transmission.
    this post is good on how to write the rc.unslung correctly:

    Now here are some other tips.
    Watch out for the download and the configuration directory's.
    If you decide to start with a new config than do not have this layout:
    "/tmp/hardisk/torrent" -here are going the torrents this is download directory.
    "/tmp/hardisk/torrent/.config" this is the config dir.
    This is bad and pay attention. :-)
    Somebody can create a torrent like this:

    The old 1.22 Transmission had the following default configuration.
    Well he went for the:
    "/tmp/harddisk/torrent" directory as a default.
    From here he had the following standard layout:
    /.config - for the config.
    /source - here you putted your torrents for upload, this was a legacy of the old transmission.
    /target - here were the fully downloaded torrents. This was the seeding place. :-)
    /work - here were the currently active torrents.
    The /.config had the following layout:
    Here were the torrent files that he worked.
    There was no separation between downloaded or working. only working and resume.
    The torrent files were also present in the /target and /work directory's. here was the structure of let's say /target (/work was the same.)
    /Name of the torrent file directory/
    /Name of the torrent file directory/.info
    /Name of the torrent file directory/.status
    /Name of the torrent file directory/Name of the torrent file.torrent.seeding
    /Name of the torrent file directory/* The torrent data *

    This type of directory was more of legacy from the prehistoryk transmission.
    The torrent files were present in many places.
    target/Name of the torrent file directory/
    work/Name of the torrent file directory/
    and they all had different endings.
    or simply torrent.

    Next post the new directory structure of new transmission.
    Last edited by Freelancer; 04-10-2008 at 11:59.

  14. #14

    New directory structure

    Well the new transmission has two main directory's:
    configuration and download.
    configuration by default is around:
    /tmp/local/root/ ...
    This is on the flash so leave it alone and start it as Shouriken said it.
    In the configuration directory you will have the same structure as at Transmission 1.22
    But in the download directory you will have the torrents unleasd so no special directory's for them or info files or whatever.
    This is I think is bad, and what pisses me on that if they correct this in the future I will have to do a lot of work to upgrade and transfer my seeds.

    Now I have a lot of upgrading to do so I'll stop.

  15. #15

    Other fuckups that I've done

    I just realized why the fuck I was not able to reinstall transmission 1.22.
    It is because I installed bash and that fucked the ipkg.
    Now I did all the conversions to my config files. I have the old ones backuped, but I am not going to revert. So I'll stay with this shit. Man I am pissed!

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Segmentation fault ?
    By Needfoul in forum German Discussion - Deutsch (DE)
    Replies: 2
    Last Post: 04-03-2007, 19:24
  2. Segmentation Fault in Samba
    By Galleons in forum WL-500gP Q&A
    Replies: 2
    Last Post: 11-02-2007, 00:15

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts