Page 1 of 2 12 LastLast
Results 1 to 15 of 18

Thread: Use Torrential as web interface for Enhanced-Ctorrent:)

  1. #1

    Use Torrential as web interface for Enhanced-Ctorrent:)

    Found this interesting web interface for enhanced-ctorrent which enables you to manage your Bittorrent downloads.

    Torrential uses Appweb as a webserver and needs enhanced c-torrent latest version dnh3.1-9.

    1st install Enhanced c-torrent:
    ipk-opt update
    ipkg-opt install enhanced-ctorrent

    2nd install Appweb
    ipkg-opt install appweb
    Run appweb: /opt/etc/init.d/S81appweb

    3rd download on link:
    Then unzip file with Winzip or Winrar and put the extracted files in the Appweb web folder /opt/var/appWeb/web/torrential through WINSCP or FTP whatever you prefer. After this use command: chmod 777 /opt/var/appWeb/web/torrential to enable the application to open the subdirectory.

    Now you can configure Torrential by changing the inc_config.php in directory /opt/var/appWeb/web/torrential. Do this with vi or nano editor. If everything works OK you can also do it through the web interface http://ASUSWL700GE-ip:7777/torrential/index.php.

    Most important are the login, password and directories where to put the torrent files and access the enhanced-ctorrent client. Make sure that the directories are accessible by everyone with chmod 777 /directory/subdirectory/

    Finally reboot and start downloading!

    The Torrential webinterface is accessible through your browser. I found out that Firefox works better than IE 7. If somehow your browser cannot access it might help to clear cache through internet options.

    url: http://ASUSWL700GE-ip:7777/torrential/index.php

    Attached Images Attached Images  
    Attached Files Attached Files

  2. #2
    It looks good, but didn't you notice some problems with enhanced torrent dnh3.1-9? Because i have tried few new versions of enhanced-ctorrent few days ago but without success - using of all ones ended with "segmentation fault". Only dnh2-3 works good for me.

  3. #3


    Hey thanks for this ! it worked great for me, but as soon as i close my Telnet session the web stops working for me ??? any clues??

  4. #4

    you have to install man and man-pages. then i think it should work.


  5. #5
    do you have installed also another package that it work? because it won't work for me. thanks


  6. #6
    Be sure you end your download path with a "/".

    That made it work for me.


  7. #7
    Quote Originally Posted by Fullback View Post
    Hey thanks for this ! it worked great for me, but as soon as i close my Telnet session the web stops working for me ??? any clues??
    Hi, first of all thanks for the great idea, it works great after a little working. The Enhanced-Ctorrent 3.2.9 or 3.1.9 (i don't know, the latest in the packages) works fine, with the maximum bandwith in up/download. I buyed this box only for the torrent downloading, and this is the simplest and the first of fully working thing for this function i read in the last one year, so i'm starting to like this box after one year sucking

    Fullback: in the first run, when i closed the telnet session the web interface closed me too, but after a little searching on the appWeb site, i found the right solution. If you install the "screen", you can start the appweb in the second session. After you can detach that screen session and exit from the telnet window, the web interface is still working fine. If you want to, you can write the whole procedure into the rc.local file.

    so, good luck!

    Last edited by Kopaxi; 02-09-2007 at 18:35.

  8. #8
    just add the start rule to rc.local and you are done.


  9. #9


    Hey Thank you all for the Help.... I made a big mistake though In my rc.local file i tired to add appWeb at start up, and i messed up writing the code, now i can't telnet into the router to change my rc.local file ....
    Here is what i wrote ******Hey i tired to add my own function in the rc.local file
    fi [-x /opt/etc/init.d/S8appWeb]; then
    now i am end up with
    i get
    ""telnet> open
    telnet: Unable to connect to remote host: Connection refused
    """ Thank you!!!
    Edit/Delete Message
    ********** THANK you guys for any help!!! thanks for the reply.
    Thank you all for the reply. p.s I should have thought of the screen idea.... Stupid me. haha thank you aging
    ****************************************I FIXED THE PROBLEM 2 DAY'S OF HARD WORKING AND I FIXED IT HAHA THANK YOU ALL AGING!
    Last edited by Fullback; 02-09-2007 at 22:01. Reason: FIXED!!!

  10. #10


    I get the following error when it goes to the home page

    Fatal error: Maximum execution time of 30 seconds exceeded in /opt/var/appWeb/web/torrential/dyn_stopped.php on line 65

    The appWeb looks OK and is obviously accpeting connections. Have I missed anything ? enhanced-torrent looks OK and is in the path. I also noticed

    default:1 pool.0 Error: 404 "Not Found" for "/favicon.ico", file "/opt/var/appWeb/web/favicon.ico": Can't access URL

    in the appWeb error log. Does anyone know what these means ?

  11. #11
    I'm having the exact same problem. I installed Torrential a few days ago and initially it worked well, downloaded a few larger torrents. But started recieving the below error on a few of the last torrents.

    I decided to take a look at the PHP logic and how the insterface works (I've never done any PHP or Linux programming, but it looks pretty straight forward).

    When you start a download, it shells to the enhanced-ctorrent client and outputs the results to a .stat file in the configured BT download directory. It also outputs the PID to the corresponding .pid file.

    So for filename.torrent you'd have and filename.stat.

    The dyn_stopped.php that's causing the issue gets a list of files from the BT download directory. If it ends with .stat/.pid it thinks it's running. It tries to parse the .stat file to determine the status. You can view the .stat file at anytime to see where the download is at.

    The problem with the .stat file is that it grows during the download. Enhanced-ctorrent appends the status to the file.

    It seems that torrents that are having communication issues (can't connect to tracker or download) are causing the problem for me - but I've only downloaded a handful of torrents.

    If you want get the page displaying, kill the process using the id from the corresponding .pid file then delete the .pid and .stat file. Your torrents will appear in stopped status. This obviously doesn't fix the problem, but at least you can start new torrents and maintain the ones that were running.

    I tried changing the KeepAliveTimeout in /opt/var/appWeb/appWeb.conf from 30 to 90, but didn't make any difference, I'm not sure if this the right timer but it's the only one that's 30 in this .conf file.

    Not sure what else, I noticed the code in dyn_stopped.php does a fopen on the .stat file but doesn't have any corresponding fclose, any PHP programmers out there have any thoughts on this?

    Also, could Torrential run under a different PHP web server? Does the lighttpd provide similar functionality?



  12. #12


    Warning: session_start() [function.session-start]: open(/tmp/sess_dc9d58d2b552739b2e11bf058866893b, O_RDWR) failed: Permission denied (13) in /opt/var/appWeb/web/torrential/login.php on line 2

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /opt/var/appWeb/web/torrential/login.php:2) in /opt/var/appWeb/web/torrential/login.php on line 2

    Warning: session_write_close() [function.session-write-close]: open(/tmp/sess_dc9d58d2b552739b2e11bf058866893b, O_RDWR) failed: Permission denied (13) in /opt/var/appWeb/web/torrential/login.php on line 10

    Warning: session_write_close() [function.session-write-close]: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in /opt/var/appWeb/web/torrential/login.php on line 10

    Warning: Cannot modify header information - headers already sent by (output started at /opt/var/appWeb/web/torrential/login.php:2) in /opt/var/appWeb/web/torrential/login.php on line 11

    Anyone come up with a solution for these issues? I have Made nearly the whole root Chmod 777 but nothing works

  13. #13
    Took a stab at the below (timeout issue). What appears to happen if the file hasn't started downloading, so 0% completed, the timeout error occurs. The percentage is calculated by rounding the downloadedamount/downloaded size. If it is 0, then it hangs, I think it's having a problem with the zero character. Can duplicate using this basic PHP script:
    echo "" . @round("0"*100/"242342"). "\n\r";

    Made a change to dyn_progress.php in /opt/var/appWeb/web/torrential to check if downloaded amount is zero. Seems to work for me. I've attached the modified script, make a copy of the existing dyn_progress.php before updating.

    I'm curious if this is a PHP bug or just how it deals with 0 character.

    Attached Files Attached Files

  14. #14
    not working for me on wl500gP

    going to i alwais receive this:

    Warning: session_start() [function.session-start]: open(/tmp/sess_bda5fb9cc080b03b402088d4699a876b, O_RDWR) failed: Permission denied (13) in /opt/var/appWeb/web/torrent/inc_security.php on line 2

    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /opt/var/appWeb/web/torrent/inc_security.php:2) in /opt/var/appWeb/web/torrent/inc_security.php on line 2

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /opt/var/appWeb/web/torrent/inc_security.php:2) in /opt/var/appWeb/web/torrent/inc_security.php on line 2

    Warning: Cannot modify header information - headers already sent by (output started at /opt/var/appWeb/web/torrent/inc_security.php:2) in /opt/var/appWeb/web/torrent/inc_security.php on line 5

    oleg firwmare
    webbrowser firefox
    enhanced-ctorrent dnh 3.2-9

    any ides? Is it not compatible with wl500gP?

  15. #15
    I'm no appweb expert but try this..

    Can you browse this:

    This is the root of the appWeb server and should show the default Mbedthis page.

    Also take a look at /opt/var/appWeb/logs/error.log, it might give you some clues.


Page 1 of 2 12 LastLast

Similar Threads

  1. Изменения в веб-интерфейсе - Custom Web Interface?
    By khorus in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 112
    Last Post: 06-07-2012, 23:32
  2. Web interface
    By Alanjan in forum Dutch Discussion - Nederlands
    Replies: 0
    Last Post: 21-12-2005, 11:41
  3. Replies: 0
    Last Post: 05-05-2005, 20:20
  4. web interface loads only occasionally during boot
    By oferlaor in forum WL-500g Q&A
    Replies: 5
    Last Post: 18-10-2004, 10:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts