Page 3 of 3 FirstFirst 123
Results 31 to 35 of 35

Thread: Trying to get IDE working on Oleg's Firmware

  1. #31
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by hugo
    Hotplug always had problem for me: I usually have to mount my external usb devices by hand when it should be automaticaly monted, even if they are plugged at boot time.

    For the kernel panic, I'm sure there is something changed in the code in wlhdd that does make it work. The fact it does hang at ide probe is probably a hidden patch in the kernel that avoid this in asus firmware.

    I'm trying to file compare both linux subfolders to try to get something, and also to use wl hdd .config file on your version but it doesn't boot up.

    I'm going to wait for your work and maybe help to find the cause of the kernel panic?
    Well, I've already diffed the kernels and there is only one relevant part, that was changed. I've not tried to do exactly like ASUS has done this, probably I will try this tonight.

  2. #32
    Join Date
    Apr 2004
    Location
    Netherlands
    Posts
    1,307
    How do you test IDE on WL-500g if there's no IDE chip/support available?

  3. #33
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by Styno
    How do you test IDE on WL-500g if there's no IDE chip/support available?
    Remotely, using Antiloop as connection.

  4. #34
    Just a though: is modprobe better than insmod to mount a file like ide-probe-mod.o or ide-mod.o?

  5. #35
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by hugo
    Just a though: is modprobe better than insmod to mount a file like ide-probe-mod.o or ide-mod.o?
    modprobe just loads all dependcies (internally it calls insmod)

Page 3 of 3 FirstFirst 123

Similar Threads

  1. oleg's firmware vs openwrt
    By sophana in forum WL-500g Custom Development
    Replies: 5
    Last Post: 15-07-2005, 17:46
  2. Hoe is filestructuur van OLEG's firmware?
    By newbie in forum Dutch Discussion - Nederlands
    Replies: 4
    Last Post: 24-06-2005, 14:23
  3. FTP Connect with Oleg's Firmware?
    By stefan9113 in forum WL-HDD Custom Development
    Replies: 4
    Last Post: 27-02-2005, 00:01
  4. Flashing Oleg's Firmware in WL HDD
    By hugo in forum WL-HDD Custom Development
    Replies: 29
    Last Post: 21-10-2004, 14:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •