Results 1 to 14 of 14

Thread: Telstra Bigpond BP3-USB MAXON modem and WL-500gP

  1. #1

    Thumbs up Telstra Bigpond BP3-USB MAXON modem and WL-500gP


    I want to report success with this combination; after much reading on Quozl ( and a little messing about with the latest stable CDMA firmware ( I have a system that works - you fire up the router, plug in the BP3-USB modem and within seconds you have a WAN hookup.

    This firmware has the options on the USB Modem > Dial-Up page to hard-code the USB settings (vendor ID and product ID) to cause the supplied usbserial driver to recognise the BP3-USB modem.

    Tweaks from stock 1.6.5:

    1. Used USB Modem > Dial Up option
    - Dial Up config options:
    * username: {username}
    * password: duh!
    * number: *99# (I have been given a different dial-up number by Tel$tra to use for this - actually got a Telstra engineer who was interested enough to talk about this - when I am home again, I'll publish this information)
    * alternate number: *99***1# (this according to the Telstra tech was a more appropriate number to use ^.^)

    Vendor ID and Product ID are 0x16d8, 0x6280 respectively

    2. Telnet'ed into the router, edited /tmp/ppp/dialup/update to match this - I found the same as Quozl that it would respond to pppd on /dev/usb/tts/1 but not on the other two.

    Find this line (doing this from memory, so I'm not sure exactly of the regex on the first line - use whatever is there for you):
    sed -e "s/\\\$username\\\$/$USERNAME/g" /tmp/ppp/dialup/dialup > /tmp/ppp/peers/dialup
    Replace with this code:
    sed -e "s/\\\$username\\\$/$USERNAME/g" /tmp/ppp/dialup/dialup > /tmp/ppp/peers/dialup.tmp
    sed -e "s/tts\/0/tts\/1/g" /tmp/ppp/peers/dialup.tmp > /tmp/ppp/peers/dialup
    rm -f /tmp/ppp/peers/dialup.tmp
    3. [Updated after Cowgoesmoo's latest research]: Editing /tmp/ppp/dialup/dial can increase downstream speed in some scenarios (didn't help for me, but ymmv):
    Look for (on line 6)
      insmod usbserial vendor=$(nvram get dialup_vid) product=$(nvram get dialup_pid)
    Replace with:
      insmod usbserial vendor=$(nvram get dialup_vid) product=$(nvram get dialup_pid) maxpacketsize=4096
    4. Edited /tmp/local/.files to ensure that flashfs would pickup my altered code; added this line to the usually otherwise empty file:
    5. Run the following commands to save, commit and enable the new flashfs:
    flashfs save
    flashfs commit
    flashfs enable
    You should then reboot, and you'll be apples

    Improvements to this tutorial;

    1. Detection of which USB port is being used, instead of hardcoding this in /tmp/ppp/dialup/update - my guess is that the one that will respond to /sbin/pppd is the one out of /dev/usb/tts/0, /dev/usb/tts/1 and /dev/usb/tts/2 that has a different file date - ie two of these will have the same file date and one will be different...

    Any other suggestions?

    NOTE: please do not ask for the custom firmware for this, as it's just one file that needs editing out of existing custom firmware...
    Last edited by Natcher00; 03-09-2007 at 12:16. Reason: Incorporating extra tips submitted by cowgoesmoo on 070901

  2. #2

    Questions and Trouble

    Downloaded the firmware from the above linked site. Got the firmware prefixed with the model of my router which is the WL500gp.

    Is the first section of code above ment to be the same as the first line of the second section? Are we just adding a line or are we also changing that first line.

    Followed all the instructions as far as I can tell. However after I run the command : flashfs commit
    I have been running the command : reboot

    After the reboot all the changes made in the files are gone.
    What should I be doing instead? The modem seems to be detected ok however pppd connect script fails.

    Jan 1 10:01:46 pppd[175]: pppd 2.4.2 started by admin, uid 0
    Jan 1 10:02:47 pppd[175]: Connect script failed
    Jan 1 10:02:48 pppd[175]: Exit.
    Is this method using the serial driver not the airprime driver recommended by Quozl?

  3. #3
    At the time I was doing this I didn't have Internet access to the router yet - the purpose of this being to get online again... So I was not able to find or compile a new driver - this is just to get an existing firmware with minimal modification to connect via the modem I mentioned.

    Is the first section of code above ment to be the same as the first line of the second section? Are we just adding a line or are we also changing that first line.
    It's meant to be a find and replace: find the first line and replace it with the two lines I provided.

    Once you have made this change, you will need to edit the /tmp/local/.files file to add the line I indicated.

    Then when you run flashfs save, it should give you a list of files it is going to pickup and save back to the flash; at the top of the list should be the /tmp/ppp/dialup/update file. Once that's ready it should flashfs commit correctly.

    None of this precludes you setting it up correctly - paste in your entire log from boot (after a reboot with the modem plugged in) so I can see what's happening there - it's possible your modem is not being recognised - make sure you are not running the modem via a USB hub into the router as this device will not cope with that...

    Which router do you have? I have the WL-500gP with two USB ports - and I have it plugged into the top one of the two (maybe that's why for me it was /dev/usb/tts/1 instead of tts/0 - I'm not an expert, just a tinkerer - YMMV unless you are replicating these conditions.

  4. #4

    Exclamation Update: content of /tmp/ppp/dialup/update

    Here's the full file mods for your reference:

    USERNAME=$(nvram get dialup_username)
    PASSWORD=$(nvram get dialup_password)
    DIALNO=$(nvram get dialup_dialno)
    echo \"$USERNAME\" \* \"$PASSWORD\" \*>>/tmp/ppp/chap-secrets
    chmod 600 /tmp/ppp/chap-secrets
    sed -e "s/\\\$username\\\$/$USERNAME/g" /tmp/ppp/dialup/dialup>/tmp/ppp/peers/dialup.tmp
    sed -e "s/tts\/0/tts\/1/g" /tmp/ppp/peers/dialup.tmp>/tmp/ppp/peers/dialup
    echo $(nvram get dial_param_$1)>>/tmp/ppp/peers/dialup
    sed -e "s/\\\$dialno\\\$/$DIALNO/g" /tmp/ppp/dialup/>/tmp/ppp/peers/
    # Enter full path of files to be saved via flashfs
    ls -la /dev/usb/tts
    drwxr-xr-x    1 admin    root            0 Jan  1  1970 .
    drwxr-xr-x    1 admin    root            0 Jan  1  1970 ..
    crw-------    1 admin    root     188,   0 Jan  1  1970 0
    crw-------    1 admin    root     188,   1 Aug 10 23:26 1
    crw-------    1 admin    root     188,   2 Jan  1  1970 2
    From the above you'll see what I mean about the different file date for the USB tts object that actually functions in this setup - so if your output from this command is different, adjust the instructions above to reflect the difference...

  5. #5

    Still having trouble commiting the changes....

    I also have the WL-500g Premium and am also connecting it to the top USB port. I have nothing else connected to it on the USB ports. I have two computer plugging into the switch as you will see in the Logs.

    I am using vi to edit the files from telnet so that they look exactly the same as yours. (Had to get out my old text books to remember how to use it. Why don't people put pico or nano in these things??) Saved the changes to the files using :w.

    Went back into the files after I saved them to make sure that it DID save.

    committed using the following.

    [admin@(none) root]$ flashfs save
    tar: Removing leading '/' from member names
    -rw-r--r-- 1 admin root 683 Jan 3 07:06 /tmp/flash.tar.gz
    Check saved image and type "/sbin/flashfs commit" to commit changes
    [admin@(none) root]$ /sbin/flashfs commit
    I then unplugged the power from the router plugged the modem into the top usb port and powered it backup. Here is the system boot up log edited so that it meets the word limits to post in this forum........ in the next post.

    If I then telnet back in and look at the files they are back they way they where before I edited them! Very frustrating.

    Have just thought that I may have to specify specifically which file i want to commit so will try that in a min.
    Attached Files Attached Files
    Last edited by Cowgoesmoo; 11-08-2007 at 09:35. Reason: Attached full log file

  6. #6

    Log file

    I have removed the log file info as I solved the problem and it didn't have anything to do with the log file.

    For whatever reason the flashfs commit command was not committing the file created by flashfs save.
    To get around this problem I plugged in my usbstick and copied the file created by flashfs save (/tmp/flash.tar.gz) to it. I then removed the USB stick plugged it into the computer I am using now and uploaded it using the web interface. System Setup -> Flashfs Managment -> New Flashfs file.

    The system uploaded the file and rebooted. After the reboot as soon as I clicked on the status and log tab on the left menu it was showing my IP address dns servers etc in the right hand window.

    I am now sending this reply using the router instead of directly through the modem.

    Here is the command to copy the file to a USB stick (or any usb storage device) for those who may not know.

    [admin@(none) /bin]$ cp /tmp/flash.tar.gz /tmp/harddisk/
    Last edited by Cowgoesmoo; 11-08-2007 at 10:31. Reason: Info no longer valid.

  7. #7
    Maybe you missed to enable flashfs with
    flashfs enable

  8. #8

    Speed problems solved!

    As engy noted the reason I was having trouble getting my changes to survive a reboot was the missing
    flashfs enable
    From the origional howto part.


    If you had tried the above you would notice that the max speed you would have been getting would have been about 270k down 90 up which is quite small! After lots of reading I now have mine working at 600k down 200k up. Which is faster than under windows by about 100k down.

    Have been looking at ways to fix this since I made the above post. Most suggestions seem to be to use the Airprime driver in 2.6 kernel which you can put on your router using the Openwrt firmware. But there is no Wireless support for the wirless card in the WL500ap.

    I then found this site.
    After reading this and learning a bit about how all this stuff works I approached Engy, one of the developers of the firmware image we are using, with what I had learned and asked him if there was a solution.

    He suggested that the same method could by used in his firmware by editing a line in the file /tmp/ppp/dialup/dial and adding the option
    After editing the file line 6 should look like this.
      insmod usbserial vendor=$(nvram get dialup_vid) product=$(nvram get dialup_pid) maxpacketsize=4096
    Make sure you add this file to /usr/local/.files as above.
    Then run the commands
    flashfs save
    flashfs commit
    flashfs enable
    That should fix everything good!

    Note : Engy suggested that the maxpacketsize should be 1024 however I have set it to 4092 as per the suggestion on the thread I linked above. I did try Engys value and it worked as fast as the 4092 or maybe even faster however because of the reboot and the fact that I get a different ip and traceroute to the speed test host I am using each time Its really hard to say which is better. I stuck with 4092 as from looking at the source for some of the wirless modem drivers it is the value that is used. Also the above linked tread suggests that it is more stable *shrugs*.

  9. #9
    Thanks for the update - I have incorporated this change, and have seen no marked effect, but I've incorporated the changes you have researched into the tutorial as well as clarified the points you made above in the OP - thanks pal.

  10. #10
    Great tutorial, I have a friend who have the same router, have NextG broadband, but he have the desktop USB modem (the one for desktop and have two antennas) instead of the MAXON BP3-USB.
    I think I have heard in some forum that Telstra won't allow you to share your internet if you have the desktop version of the modem, is that true?

  11. #11
    They don't provide any technical support for this config (i.e. running the NextG equipment via Linux or via serial dial-up mechanisms other than the supplied software) - if you want to get Telstra help with this, then you'll need to plug the modem back into your computer directly.

    I don't believe that there is any stipulation on whether you can share it or not - for example if you were to use ICS (egads!) on Windoze you could share it - but then you;d be relying on any MS or installed software firewall...

  12. #12

    Sharing is fine

    Quote Originally Posted by bakablah View Post
    Great tutorial, I have a friend who have the same router, have NextG broadband, but he have the desktop USB modem (the one for desktop and have two antennas) instead of the MAXON BP3-USB.
    I think I have heard in some forum that Telstra won't allow you to share your internet if you have the desktop version of the modem, is that true?
    Sharing is fine. You can actually buy a router from Telstra to do this just that it costs about $900, only has one Ethernet port and no USB. Really with the setup we are doing here the sharing of the net is only the beginning of what you can do. Have a look around the forums to see all the other stuff you can do with this hardware.

  13. #13

    Good speeds being acheived

    Telstra's new firmware has enabled me to get download speeds of nearly 3mb according to I get the same through the ASUS as I get with the modem connected directly to my laptop.

  14. #14

    Talking Help! need WL500GP v2 settings for Sierra USB306

    I recently purchased a Sierra USB306 bigpond modem from Telstra. Although its a bigpond modem, it works with a Telstra sim card in it. I'm on a casual data plan. I flashed the device with Telstra's USB306 firmware and installed Telstra's Turbo Connection software on my computer. The Bigpond connection software can be used too, as long as the APN settings are changed to telstra's apn.

    Anyways, I have a WL500GP V2 and flashed it with Oleg's latest firmware. After I changed the WAP setting to USB connection and entered in the proper APN, dialup number, and other settings, the modem does not connect. The blue light goes on, but the left and right arrow light does not light up. It works on my laptop, just not on my router. I recently had a 3 modem and was able to make it work with the router. The USB306 modem is not connecting. How would I achieve this? What settings would I have to modify? This is a little over my head, but I could probably modify all the settings if I was properly coached.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts