Page 1 of 12 12311 ... LastLast
Results 1 to 15 of 168

Thread: Wl-500gP и WebCam

  1. #1

    WebCam из интернета

    Извините за чайниковский вопрос, но в мануале ничего не нашел, а в топиках на английском не разобрался.
    WL500gx с прошивкой 6b Подключил камеру к роутеру и хотелось бы иметь к ней доступ из интернета. Если я верно понимаю, нужно инициировать виртуальный сервер для того реального ай-пи, что дает мне провайдер. Как это сделать? Что является локальным ай-пи в этом случае, если я подключаюсь в интернету по домовой сети по pptp.
    По какому адресу из интернета нужно обращаться к камере?

  2. #2
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Никаких виртуальных серверов настраивать не надо. Достаточно внимательно прочитать мануал, посмотреть страницу конфигурации USB Application | Web Camera и после этого в Enable Web Camera выбрать LAN and WAN.

  3. #3
    И настройка LAN и WAN выбрана и мануал читан
    Извините, Олег, а как же такие строки в мануале-

    If you want to expose these web camera to Internet, please set up virtual server for each HTTP port and ActiveX port manually.

    И все же, если указанных вами настроек достаточно, что набирать в строке браузера, чтобы мой коллега через интернет получил картинку с моей камеры?

    http://my_IP/Advanced_ShowTime_Widzard.asp
    http://my_IP:7776/Advanced_ShowTime_Widzard.asp
    http://my_IP:7777/Advanced_ShowTime_Widzard.asp

    или что-то еще иное

  4. #4
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Должно работать без виртуальных серверов. Строка в броузере должна быть такой же, как в случае с Lan, только адрес д.б. "внешним".

  5. #5
    К сожалению не работает. Камера Pcvc680k, совместимая, но в ряде потсов на английском вроде были с ней проблемы. Кстати, у меня и почта не отсылается, хотя в логе пишется про отправку. Но почта мне не актуальна.
    Быть может по сообщениям в логе можно понять, отчего камера со стороны интернета не видна? Может мне какие проверочные команды повыполнять ?

  6. #6

    Посоветуйте webcam, пожалуйста!

    Здравствуйте все!
    Возможно я косорукий, но из двух имеющихся в моём распоряжении веб-камер ни одна не прижилась к WL500G Deluxe, прошивка 1.9.2.7-6a. А именно - D-Link DSB-C310 и Logitech QuickCam Express. Пробованы все комбинации ActiveX и Refresh, драйверы PWC8.8 и OV511 2.10... Всё равно ничего ...
    Не подскажет ли кто гарантированно работающую в такой конфигурации камеру? Или на какую прошивку замениться, чтобы заработали?

  7. #7
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353

    Web камеры

    C веб камерами беда. Дешёвые сделаны на дешёвых чипах, которые не поддерживаются. Да собственно у них и качество плохое.
    Не говоря уже о драйверах, которые просто мрак. Logitech QuickCam Pro 4000 точно поддерживается (она идёт в комплекте с wl500g),
    а в розницу стоит каких-то нереальных денег... Правда там и матрица CCD, а не CMOS, как в дешёвых камерах.

    Вот здесь список - http://alpha.dyndns.org/ov511/cameras.html Нужно смотреть на ov511/ov511+/ov51x



    По pwc - google в руки, тоже есть список.
    Last edited by Omega; 15-10-2012 at 02:17. Reason: fixed

  8. #8
    Олег,
    А вот вроде бы мой D-Link DSB-310 указан (правда, с оговорками что, мол, Works with ov51x driver)... А не работает, гад. Может, у меня чип не вот этот OV7648, и поэтому не желает?
    попробую найти что-то из списка, однозначно совпадающего, спасибо!

  9. #9
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Возможно просто драйвер старый. Нужно сделать телнет на роутер и выполнить
    Code:
    cat /proc/bus/usb/devices
    Я хочу посмотреть product id и vendor id.

  10. #10
    T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 4
    B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS= 8 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.04
    S: Manufacturer=Linux 2.4.20 ehci_hcd
    S: Product=PCI device 1106:3104
    S: SerialNumber=01:02.2
    C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
    I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=256ms
    T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 0.00
    S: Product=USB UHCI Root Hub
    S: SerialNumber=120
    C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
    I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms
    T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc=140/900 us (16%), #Int= 0, #Iso= 2
    D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 0.00
    S: Product=USB UHCI Root Hub
    S: SerialNumber=100
    C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
    I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms
    T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 2 Spd=12 MxCh= 0
    D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=05a9 ProdID=8519 Rev= 1.00
    S: Manufacturer=OmniVision Technologies, Inc.
    S: Product=USB Camera
    C:* #Ifs= 3 Cfg#= 1 Atr=80 MxPwr=500mA
    I: If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=ov51x
    E: Ad=81(I) Atr=01(Isoc) MxPS= 0 Ivl=1ms
    I: If#= 0 Alt= 1 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=ov51x
    E: Ad=81(I) Atr=01(Isoc) MxPS= 384 Ivl=1ms
    I: If#= 0 Alt= 2 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=ov51x
    E: Ad=81(I) Atr=01(Isoc) MxPS= 512 Ivl=1ms
    I: If#= 0 Alt= 3 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=ov51x
    E: Ad=81(I) Atr=01(Isoc) MxPS= 768 Ivl=1ms
    I: If#= 0 Alt= 4 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=ov51x
    E: Ad=81(I) Atr=01(Isoc) MxPS= 896 Ivl=1ms
    I: If#= 1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=audio
    I: If#= 2 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=audio
    I: If#= 2 Alt= 1 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
    E: Ad=82(I) Atr=05(Isoc) MxPS= 40 Ivl=1ms

  11. #11
    Join Date
    Nov 2004
    Location
    Москва
    Posts
    380
    Аналогичная проблема. пишет в логах что почта отправлена. но ничего не приходит.
    почтовый сервер указывать в формате mail.msm.ru ?
    у кого нить заработал Security Mode

  12. #12

    У меня та же камера...

    Купил такую же камеру D-Link, прошивка стоит таже, ставил последнюю оффициальную, эффект нулевой. :-(

    ОБИДНО, БЛИН. :-(

  13. #13
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Не расстраивайтесь. Нужный драйвер уже включен в прошивку. Просто его никто не запускает. Я это исправлю, когда появится время.

  14. #14
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    P.S. Вы можете в telnet сказать insmod ov51x и посмотреть после этого system log - камера должна опознаться.

  15. #15
    Quote Originally Posted by Oleg
    P.S. Вы можете в telnet сказать insmod ov51x и посмотреть после этого system log - камера должна опознаться.
    К сожалению не помогло. Сказала что уже загружен. :-(

    А логи переполненны строками EOF witout SOF

Page 1 of 12 12311 ... LastLast

Similar Threads

  1. 500gP behind router (lifebox from Orange)
    By Driek in forum WL-500gP Firmware Discussion
    Replies: 0
    Last Post: 15-03-2007, 21:59
  2. USB HDD connects as Webcam
    By Oldchatterman in forum WL-500g Q&A
    Replies: 12
    Last Post: 19-10-2004, 17:54

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •