PDA

Bekijk de volledige versie : installed packages not found



bowmore
14-07-2007, 16:01
I've encountered the problem that several optware packages appear to install normally but give a "not found" error when executed.
Here is some output:

[root@Irene root]$ ipkg install adduser
Installing adduser (1.5.0-1) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable//adduser_1.5.0-1_mipsel.ipk
Configuring adduser
update-alternatives: Linking //opt/bin/su to /opt/bin/adduser-su
Successfully terminated.

[root@Irene root]$ /opt/bin/adduser
-sh: /opt/bin/adduser: not found

[root@Irene root]$ ls -l /opt/bin/adduser
-rwxr-xr-x 1 root root 131004 Mar 28 08:18 /opt/bin/adduser

I have no clue why the shell doesn't find the installed package.
If anyone could give me a hint how to proceed it would be very helpfull indeed.

I'm using Oleg's 1.9.2.7-7g firmware on an Asus wl-500gP
with the following file system:
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 2880 2880 0 100% /
/dev/discs/disc0/part5 480363760 41388616 414574020 9% /home
/dev/discs/disc0/part1 318893 107925 194502 36% /opt

al37919
17-07-2007, 14:38
Briefly:
the content of /opt/etc/ipkg.conf should be:

src/gz optware http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable
dest /opt/ /

Afterwards reinstall all the packages installed, possibly, with -force-reinstall option. For long explanation search the forum.

bowmore
19-07-2007, 23:44
Yes! After changing the repository, installing ipkg-opt and uclibc-opt everything works just fine.
Thank you so much.