Bekijk de volledige versie : DYNDNS (Static) Not working

Chris Thompson
31-05-2007, 00:35
I cannot get the ddns to work using dyndns STATIC. I have a static dns account with dyndns and am sure I have configered the wl-700 corectly.

I get the following message in the log:

May 23 09:29:47 ddns update: connected to members.dyndns.org ( on port 80.
May 23 09:29:48 ddns update: invalid hostname: homeshare9.dyndns.org

However if I change my dydns account to a dynamic dns account and then select correctly in the wl700 menue it works.

I really need to use the static dns service as my isp dns does not change very often, which causes a dynamic dns account to expire if not accessed for 35 days.

I have tried ASUS Customer Service Center!! But all he tells me to do is set a static address for my router IP??????

I have tried just about every thing, no luck.

31-05-2007, 03:11
I used ddclient on my old FreeBSD box. It's a perl script that requires no additional modules. Since perl is now in the optware repository, running ddclient on the router should be possible. Check it out here:


- K.C.

Chris Thompson
31-05-2007, 10:56
Thanks, I will give it a try.


Chris Thompson
01-06-2007, 11:38
I tried, but no luck :-(

I am for sure not doing it right.

I cannot cp ddclient to /usr/sbin, I get:
# cp ddclient /usr/sbin/
cp: unable to open `/usr/sbin/ddclient': Permission denied

So I copied it to /opt/sbin, which worked but I cannot get it to execute:

# /opt/sbin/ddclient
/opt/sbin/ddclient: cannot execute
# /opt/sbin/ddclient -file path /opt/etc/ddclient/ddclient.conf
/opt/sbin/ddclient: cannot execute.

The configeration file I have modified, I hope corectly.

I am sure I am doing something stupid.

Can you point me in the correct direction.


01-06-2007, 22:34
You can run a custom instance for the ez-ipupdate that has a forced update at an interval you choose. Thus you can then keep the dynamic portion (you should be doing this anyway) and update within the 35 days too...

It's in my older posting on dydns and multihoming found here:


(obviously only use the bits you need)


Chris Thompson
05-06-2007, 14:29
Thanks very much,

That is working now.

Just one question , do I put "ez-ipupdate -c /opt/etc/ddns.conf" in rc.local to make it start on boot? I cannot find "/usr/local/sbin/post-mount" anywhere.


Chris Thompson
09-06-2007, 00:40
Solved it myself.

Putting the command:

/usr/sbin/ez-ipupdate -c /opt/etc/ddns.conf

in rc.local does the trick.


21-11-2008, 13:20
Hi there!
After installing kfurge' custom firmware I tried to set up DynDNS.org service as written in manual. I can connect to my router pointing my browser to DynDNS host (erop.homelinux.org in my case) while on local wireless network and watch standard web page for Picture gallery, Message board and so on. But nobody from WAN can not watch the same. I tried to open my host with OperaMini - Error 408. Please advice are there any "hidden" (not mentioned in manual or I just missed them) settings in web-interface or by ssh I should change to make box working as http server properly?

21-11-2008, 15:42
have you enabled wan access in the router ?

21-11-2008, 16:29
have you enabled wan access in the router ?
Hm-m... I'll check it up in a couple of hours. BTW, I found this manual http://wl700g.homelinux.net/drupal/files/AWLRFBv4_0.pdf . Hope, that'll do a lot to clarify my understanding of The Box! :D

21-11-2008, 22:38
have you enabled wan access in the router ?
Internet Firewall - Basic Config

Enable Firewall - Yes
Enable Web Access from WAN - Yes

22-11-2008, 11:24
Internet Firewall - Basic Config

Enable Firewall - Yes
Enable Web Access from WAN - Yes

the router seem ok

have you set portforwarding from youre modem? you should open port 80 & 8081

22-11-2008, 12:03
the router seem ok

have you set portforwarding from youre modem? you should open port 80 & 8081

You mean settings in "NAT Setting - Virtual Server" section of web-interface of the router? At the moment there are NO any settings under "Virtual Server List". Should I add some strings there?

02-12-2008, 14:42
the router seem ok

have you set portforwarding from youre modem? you should open port 80 & 8081
My ADSL modem D-Link 2640U is in BRIDGE mode. So as I see it forward all the traffic directly to my Asus box. After a short examining of my ISP (www.stream.ru) support site I found out that there is an incoming traffic filtering for ports 80 and 8080. Might it be the reason for DynDNS not working? If so, is there any possibility to avoid filtering?

02-12-2008, 21:51
OK, my Russian brothers from Moscow who use Stream ISP and couldn't reach your web-server due to traffic filtering! To make your web-server available from WAN you should first NAT Settings -> Virtual Server -> Enable Virtual Server and Add it as follows:
Port range - 8081
Local IP -
Local port - 8081
Protocol - TCP
Choose HTTP from Well-known Application from drop-down list to make it a little bit easier to fill the form.
Then, go to IP Config - Miscellaneous and set up your DynDNS profile and hostname.

Mentioned above works good only if you keep Default Port of Web Server as 8081 in Applications - Basic Config.
You may change port number in both sections correspondingly.

18-03-2009, 00:49
If your box is behind NAT you can use the below script. It uses one of the websites to get your external IP, extracts it and updates the results using ez-ipupdate. It works for me.

ipa=$(wget -q -O - checkip.dyndns.org | sed -e 's/.*.Current IP Address: //' -e 's/<.*$//')
/usr/sbin/ez-ipupdate --address=$ipa --retrys=5 --service-type=dyndns --user=username:xxxx --host=yourhostname