PDA

Bekijk de volledige versie : Проблема с WL-500gP (PPPoE + uTorrent).



rayovac
16-05-2007, 21:49
Что имеем:
Оптика подключенная в медиаконвертер, от него идет витая пара метров 30 до роутера. К роутеру подключен 1 ПК по Ethernet на расстоянии 3 метра, а также ноутбук по Wi-fi.
Подключение к интернет с помощью PPPoE.
Версия прошивки роутера 1.9.7.2 (установлена производителем).

Описание проблемы:
Сегодня подключил и настроил роутер.
Первые 40 минут роутер работал хорошо.
Потом я запустил на ПК uTorrent, спустя 15 минут интернет пропал на ПК и на НБ. А вебинтерфейс роутера был доступен только на НБ. Отключил uTorrent и спустя пару минут соединение восстановилось само. Ситуация повторяется каждый раз при запуске uTorrent, но уже не через 15 минут, а практически сразу.

Какая ошибка выдается при разъединении я не знаю, но вот что я вижу в логе роутера после того как запустил uTorrent и интернет оборвался (открываю вебинтерфейс роутера через НБ, т.к. на ПК не открывается в это время):
Jan 1 02:00:07 pppd[90]: Plugin rp-pppoe.so loaded.
Jan 1 02:00:07 pppd[90]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2
Jan 1 02:00:07 pppd[91]: pppd 2.4.2 started by (unknown), uid 0
Jan 1 02:00:07 pppd[91]: Using interface ppp0
Jan 1 02:00:07 pppd[91]: local IP address 10.64.64.64
Jan 1 02:00:07 pppd[91]: remote IP address 10.112.112.112
Jan 1 02:00:07 pppd[91]: Starting link
^Жду, но соединение не восстанавливется.

Jan 1 02:01:38 wan: connected manually
^Пытаюсь подключиться спомощью функции Connect в меню статуса роутера. Рузультата нет.

Jan 1 02:02:22 wan: connected manually
^Отключаю юТоррент на ПК и робую подключиться к интернет ещё раз. На этот раз успешно, но ошибки есть. Лог представлен ниже.

Jan 1 02:02:23 pppd[91]: Timeout waiting for PADO packets
Jan 1 02:02:23 pppd[91]: Unable to complete PPPoE Discovery
Jan 1 02:02:53 pppd[91]: Starting link
Jan 1 02:02:53 pppd[91]: PPP session is 1135
Jan 1 02:02:53 pppd[91]: Connect: ppp0 -> eth0
Jan 1 02:02:57 pppd[91]: PAP authentication succeeded
Jan 1 02:02:57 pppd[91]: peer from calling number 00:0A:42:7D:D4:1B authorized
Jan 1 02:02:57 pppd[91]: Local IP address changed to 89.209.81.ххх
Jan 1 02:02:57 pppd[91]: Remote IP address changed to 87.236.224.163
May 16 21:24:07 ntp client: time is synchronized to utcnist.colorado.edu
May 16 21:24:19 PPPoE: connect to ISP


Темы на форуме где описываются проблемы чем-то схожие с моей, но решения там к сожалению нет:
http://wl500g.info/showthread.php?t=7511
http://wl500g.info/showthread.php?p=54770
http://wl500g.info/showthread.php?t=3967
http://wl500g.info/showthread.php?t=8413

Возможно проблема проявляется не только с uTorrent. Роутер новый. Думаю менять или нет.

Подскажите пожалуйста как решить проблему.

Oleg
16-05-2007, 22:04
Ограничьте своему торренту макс. количество соединений. Думаю, что дело в этом.

rayovac
16-05-2007, 22:16
Ограничьте своему торренту макс. количество соединений. Думаю, что дело в этом.

Спасибо за совет.
Но возможно есть иной способ решения проблемы?
Перепрошивка может это решить?
Кстати подключений не так уж много идет, ещё и потому что у меня в винде ограничения стоят (на 10 в секунду, но они и на половину не забиты).

И с Timeout waiting for PADO packets это проблемы не решает, хотя может это сообщение в логе ничего не значит.

Возможно проблема схожая с Linksys WRT54G?:
http://en.wikipedia.org/wiki/WRT54G

As shipped, the Linksys firmware on pre-v5 routers crashes under heavy peer-to-peer network traffic, such as BitTorrent, eMule or other P2P software. The reason for this crash is that Linux's connection tracking (http://en.wikipedia.org/wiki/Netfilter) by default keeps track of old connections for five days. This five day limit quickly overwhelms the router's internal memory when there are a high number of network connections, and can only be resolved by power cycling the router. For a detailed tutorial on how to permanently fix this issue, see the uTorrent FAQ (http://www.utorrent.com/faq.php#Special_note_for_users_with_Linksys_WRT54G _GL_GS_routers). Briefly, it involves installing a 3rd party firmware that allows setting the timeout to lower levels, which drops inactive connections and prevents the crashes.

rayovac
16-05-2007, 22:44
Пробовал ограничивать соединения ещё больше, чем они ограничены по умолчанию, единственный результат это то что длительность работы интернета до разрыва соединения при работающих торрентах меряется не секундами уже, а минутами, но и 10 минут не держит, даже если совсем мало соединений разрешать.

Без торрентов тоже обрывы идут. подключение держалось около часа, а потом произошел обрыв.
Лог после обрыва:

Jan 1 02:00:07 pppd[90]: Plugin rp-pppoe.so loaded.
Jan 1 02:00:07 pppd[90]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2
Jan 1 02:00:07 pppd[91]: pppd 2.4.2 started by (unknown), uid 0
Jan 1 02:00:07 pppd[91]: Using interface ppp0
Jan 1 02:00:07 pppd[91]: local IP address 10.64.64.64
Jan 1 02:00:07 pppd[91]: remote IP address 10.112.112.112
Jan 1 02:00:07 pppd[91]: Starting link
Jan 1 02:01:12 pppd[91]: Timeout waiting for PADO packets
Jan 1 02:01:12 pppd[91]: Unable to complete PPPoE Discovery
Jan 1 02:01:43 pppd[91]: Starting link
Jan 1 02:01:43 pppd[91]: PPP session is 1945
Jan 1 02:01:43 pppd[91]: Connect: ppp0 -> eth0
Jan 1 02:01:43 pppd[91]: PAP authentication succeeded
Jan 1 02:01:43 pppd[91]: peer from calling number 00:0A:42:7D:D4:1B authorized
Jan 1 02:01:43 pppd[91]: Local IP address changed to 89.209.81.xxx
Jan 1 02:01:43 pppd[91]: Remote IP address changed to 87.236.224.163
May 17 00:11:12 ntp client: time is synchronized to utcnist.colorado.edu
May 17 00:11:20 PPPoE: connect to ISP

UPD.
Перезапустил полностью роутер и спустя 7 минут опять обрыв соединения (торренты не запускал).

Jan 1 02:00:07 pppd[90]: Plugin rp-pppoe.so loaded.
Jan 1 02:00:07 pppd[90]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2
Jan 1 02:00:07 pppd[91]: pppd 2.4.2 started by (unknown), uid 0
Jan 1 02:00:07 pppd[91]: Using interface ppp0
Jan 1 02:00:07 pppd[91]: local IP address 10.64.64.64
Jan 1 02:00:07 pppd[91]: remote IP address 10.112.112.112
Jan 1 02:00:08 pppd[91]: Starting link

Всегда время показывает 02:00:07, это уже на глюк какой-то похоже.
Когда соединение обрывает без торрентов, то веб-интерфейс роутера доступен с ПК.

dimitar
17-05-2007, 11:52
Всегда время показывает 02:00:07, это уже на глюк какой-то похоже.

http://my.router/Advanced_DDNS_Content.asp
указать ntp сервер, тот же time.windows.com


Но возможно есть иной способ решения проблемы?
Перепрошивка может это решить?

вы же сами цитируете:
"Briefly, it involves installing a 3rd party firmware that allows setting the timeout to lower levels, which drops inactive connections and prevents the crashes."
Попробуйте прошивку Oleg'а.


И с Timeout waiting for PADO packets это проблемы не решает, хотя может это сообщение в логе ничего не значит.
вы настройки просто применили (Apply) или еще и сохранили с последующей перезагрузкой (finish => save&reboot)?

Unable to complete PPPoE Discovery в логе - это уже скорей прикол со стороны провайдера, который всплывал и у меня, когда падал сервер или "рвалась" линия.

rayovac
17-05-2007, 12:21
вы же сами цитируете:
"Briefly, it involves installing a 3rd party firmware that allows setting the timeout to lower levels, which drops inactive connections and prevents the crashes."
Попробуйте прошивку Oleg'а.
Я понимаю что там написано. Поэтому и задал вопрос Олегу, возможно он видел подобный случай.
Но к сожалению эта проблема встречается не только на стандартной прошивке.
http://forum.asus.ru/viewtopic.php?p=136654
Так что не вижу смысла менять прошивку. Наверно буду менять роутер.


вы настройки просто применили (Apply) или еще и сохранили с последующей перезагрузкой (finish => save&reboot)?
С перезагрузкой конечно. Иначе настройки не применяются.


Unable to complete PPPoE Discovery в логе - это уже скорей прикол со стороны провайдера, который всплывал и у меня, когда падал сервер или "рвалась" линия.

Я описал выше когда возникает эта проблема у меня. С провайдером это не связано.

Alekgol
08-03-2009, 12:30
Аналогичная проблема при соединении PPTP. Логи:

Mar 8 13:06:11 pppd[123]: Starting link
Mar 8 13:06:11 pppd[123]: Serial connection established.
Mar 8 13:06:11 pppd[123]: Connect: ppp0 <--> /dev/pts/1
Mar 8 13:06:21 pptp[644]: route_add: not adding existing route
Mar 8 13:06:25 pppd[123]: PAP authentication succeeded
Mar 8 13:06:25 pppd[123]: Local IP address changed to 94.27.111.167
Mar 8 13:06:25 dnsmasq[74]: read /etc/hosts - 12 addresses
Mar 8 13:06:25 dnsmasq[74]: read /etc/ethers - 1 addresses
Mar 8 13:06:25 dnsmasq[74]: reading /tmp/resolv.conf
Mar 8 13:06:25 dnsmasq[74]: using nameserver 212.109.32.9#53
Mar 8 13:06:25 dnsmasq[74]: using nameserver 212.109.32.5#53
Mar 8 13:06:26 PPTP: connect to ISP
Mar 8 13:06:36 ddns update: connected to members.dyndns.org (63.208.196.95) on port 80.
Mar 8 13:06:36 ddns update: request successful
Mar 8 13:06:37 ddns: ddns update ok
Mar 8 13:07:25 dropbear[568]: exit after auth (admin): Exited normally
Mar 8 13:10:21 pppd[123]: Modem hangup
Mar 8 13:10:21 pppd[123]: Connection terminated.
Mar 8 13:10:21 pppd[123]: Connect time 4.2 minutes.
Mar 8 13:10:21 pppd[123]: Sent 2434980995 bytes, received 2148341842 bytes.
Mar 8 13:10:21 dnsmasq[74]: read /etc/hosts - 12 addresses
Mar 8 13:10:21 dnsmasq[74]: read /etc/ethers - 1 addresses
Mar 8 13:10:21 dnsmasq[74]: reading /tmp/resolv.conf
Mar 8 13:10:21 dnsmasq[74]: using nameserver 10.10.10.2#53
Mar 8 13:10:21 dnsmasq[74]: using nameserver 212.109.32.5#53
Mar 8 13:10:21 PPTP: Disconnected
Mar 8 13:10:51 pppd[123]: Starting link
Mar 8 13:10:51 pppd[123]: Serial connection established.
Mar 8 13:10:51 pppd[123]: Connect: ppp0 <--> /dev/pts/0
Mar 8 13:11:01 pptp[670]: route_add: not adding existing route
Mar 8 13:11:05 pppd[123]: PAP authentication succeeded
Mar 8 13:11:05 pppd[123]: Local IP address changed to 94.27.86.114
Mar 8 13:11:05 dnsmasq[74]: read /etc/hosts - 12 addresses
Mar 8 13:11:05 dnsmasq[74]: read /etc/ethers - 1 addresses
Mar 8 13:11:05 dnsmasq[74]: reading /tmp/resolv.conf
Mar 8 13:11:05 dnsmasq[74]: using nameserver 212.109.32.9#53
Mar 8 13:11:05 dnsmasq[74]: using nameserver 212.109.32.5#53
Mar 8 13:11:06 PPTP: connect to ISP
Mar 8 13:11:16 ddns update: connected to members.dyndns.org (63.208.196.95) on port 80.
Mar 8 13:11:16 ddns update: request successful
Mar 8 13:11:18 ddns: ddns update ok
Mar 8 13:12:08 pppd[123]: Modem hangup
Mar 8 13:12:08 pppd[123]: Connection terminated.
Mar 8 13:12:08 pppd[123]: Connect time 1.3 minutes.
Mar 8 13:12:08 pppd[123]: Sent 2435834994 bytes, received 2173246980 bytes.
Mar 8 13:12:08 dnsmasq[74]: read /etc/hosts - 12 addresses
Mar 8 13:12:08 dnsmasq[74]: read /etc/ethers - 1 addresses
Mar 8 13:12:08 dnsmasq[74]: reading /tmp/resolv.conf
Mar 8 13:12:08 dnsmasq[74]: using nameserver 10.10.10.2#53
Mar 8 13:12:08 dnsmasq[74]: using nameserver 212.109.32.5#53
Mar 8 13:12:08 PPTP: Disconnected
Mar 8 13:12:38 pppd[123]: Starting link
Mar 8 13:12:38 pppd[123]: Serial connection established.
Mar 8 13:12:38 pppd[123]: Connect: ppp0 <--> /dev/pts/0
Mar 8 13:12:48 pptp[696]: route_add: not adding existing route
Mar 8 13:12:51 pppd[123]: PAP authentication succeeded
Mar 8 13:12:51 pppd[123]: Local IP address changed to 94.27.110.163
Mar 8 13:12:51 pppd[123]: Remote IP address changed to 94.27.125.8
Mar 8 13:12:52 dnsmasq[74]: read /etc/hosts - 12 addresses
Mar 8 13:12:52 dnsmasq[74]: read /etc/ethers - 1 addresses
Mar 8 13:12:52 dnsmasq[74]: reading /tmp/resolv.conf
Mar 8 13:12:52 dnsmasq[74]: using nameserver 212.109.32.9#53
Mar 8 13:12:52 dnsmasq[74]: using nameserver 212.109.32.5#53
Mar 8 13:12:52 PPTP: connect to ISP
Mar 8 13:13:02 ddns update: connected to members.dyndns.org (63.208.196.95) on port 80.
Mar 8 13:13:03 ddns update: request successful
Mar 8 13:13:03 kernel: printer.c: usblp0 Device ID string [158/max 1552]='MFG:Hewlett-Packard;CMD:PJL,MLC,BIDI-ECP,PCL,POSTSCRIPT,PCLXL;MDL:hp LaserJet 1300;CLS:PRINTER;DES:Hewlett-Packard LaserJet 1300;MEM:8MB;COMMENT:RES=1200x1;'
Mar 8 13:13:03 kernel: printer.c: Parsing USBLPID...
Mar 8 13:13:04 ddns: ddns update ok
Mar 8 13:18:20 pppd[123]: Modem hangup
Mar 8 13:18:20 pppd[123]: Connection terminated.
Mar 8 13:18:20 pppd[123]: Connect time 5.7 minutes.
Mar 8 13:18:20 pppd[123]: Sent 2440955526 bytes, received 2259786418 bytes.
Mar 8 13:18:20 dnsmasq[74]: read /etc/hosts - 12 addresses
Mar 8 13:18:20 dnsmasq[74]: read /etc/ethers - 1 addresses
Mar 8 13:18:20 dnsmasq[74]: reading /tmp/resolv.conf
Mar 8 13:18:20 dnsmasq[74]: using nameserver 10.10.10.2#53
Mar 8 13:18:20 dnsmasq[74]: using nameserver 212.109.32.5#53
Mar 8 13:18:20 PPTP: Disconnected


Причем раньше (еще вчера) такого не было. Ни роутер, ни порт не перестраивал. Роутер WL500gpv2, прошивка от Олега 1.9.2.7-10.
Имеется субъективное ощущение, что началось это вчера, когда я обрубил какого-то товарища, который мне из WAN в шел наяривать пытался - я всю подсеть его заблокировал в файере и включил анти-DoS, после чего пошли обрывы. Сначала при обрыве выдавало в логи "код 11" от pppd. Закрыл доступ на 22 порт в post-firewall, сохранился, перегрузил рутер. Все равно обрывы идут.
Понимаю что сам лопухнулся, но по шелу я с работы в свободное время роутер настраивал (взял себе этот роутер полторы недели назад).

Какие будут идеи и возможно, предложения по разруливанию сложившейся ситуации?

P.S. Огромное спасибо и за прошивку, и за великолепный форум. В линуксе раньше не работал, но используя приведенные материалы в качестве стартовой платформы эту систему приятно и интересно изучать. Спасибо!