PDA

Bekijk de volledige versie : Help to compile amule please



QMax
14-05-2007, 19:21
:eek: Finished my adventure with toolchain, now it's time to compile amule to run on WL-500gP.
As I wrote in another thread, I successfully compiled aMule for Linux/Kubuntu, but I'm in trouble cross-compiling for WL-500:


jars@jars-Kubuntu-7:/opt/slug/optware$ sudo make amule
make wxbase-stage libstdc++-stage libcurl-stage zlib-stage libpng-stage libgd-stage readline-stage
make[1]: Entering directory `/opt/slug/optware'
make[1]: Nothing to be done for `wxbase-stage'.
make[1]: Nothing to be done for `libstdc++-stage'.
make[1]: Nothing to be done for `libcurl-stage'.
make[1]: Nothing to be done for `zlib-stage'.
make[1]: Nothing to be done for `libpng-stage'.
make libpng-stage libjpeg-stage freetype-stage fontconfig-stage
make[2]: Entering directory `/opt/slug/optware'
make[2]: Nothing to be done for `libpng-stage'.
make[2]: Nothing to be done for `libjpeg-stage'.
make[2]: Nothing to be done for `freetype-stage'.
make freetype-stage
make[3]: Entering directory `/opt/slug/optware'
make[3]: Nothing to be done for `freetype-stage'.
make[3]: Leaving directory `/opt/slug/optware'
make expat-stage
make[3]: Entering directory `/opt/slug/optware'
make[3]: Nothing to be done for `expat-stage'.
make[3]: Leaving directory `/opt/slug/optware'
rm -rf /opt/slug/optware/builds/fontconfig /opt/slug/optware/builds/fontconfig
tar -C /opt/slug/optware/builds -xzf /opt/slug/optware/downloads/fontconfig-2.3.2.tar.gz
if test -n "" ; \
then cat | \
patch -d /opt/slug/optware/builds/fontconfig -p1 ; \
fi
if test "/opt/slug/optware/builds/fontconfig" != "/opt/slug/optware/builds/fontconfig" ; \
then mv /opt/slug/optware/builds/fontconfig /opt/slug/optware/builds/fontconfig ; \
fi
(cd /opt/slug/optware/builds/fontconfig; \
AR=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-ar AS=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-as LD=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-ld NM=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-nm CC=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-gcc CPP="/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-gcc -E" GCC=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-gcc CXX=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-g++ RANLIB=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-ranlib STRIP=/opt/slug/optware/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-strip \
CPPFLAGS="-O2 -pipe -I/opt/slug/optware/staging/opt/include -I/opt/slug/optware/staging/opt/include/freetype2" \
LDFLAGS=" -L/opt/slug/optware/staging/opt/lib -Wl,-rpath,/opt/lib -Wl,-rpath-link,/opt/slug/optware/staging/opt/lib " \
PKG_CONFIG_PATH="/opt/slug/optware/staging/opt/lib/pkgconfig" \
PKG_CONFIG_LIBDIR="/opt/slug/optware/staging/opt/lib/pkgconfig" \
AUTOMAKE=automake-1.9 ACLOCAL=aclocal-1.9 \
ac_cv_prog_HASDOCBOOK=no \
./autogen.sh \
--build=i386-pc-linux-gnu \
--host=mipsel-linux \
--target=mipsel-linux \
--prefix=/opt \
--with-default-fonts=/opt/share/fonts \
--without-add-fonts \
--with-freetype-config=/opt/slug/optware/staging/opt/bin/freetype-config \
--disable-docs \
--disable-static \
)

You must have automake 1.4-p1 installed to compile Fontconfig.
Get ftp://ftp.gnu.org/pub/gnu/automake/automake-1.4-p1.tar.gz
(or a newer version if it is available)
make[2]: *** [/opt/slug/optware/builds/fontconfig/.configured] Error 1
make[2]: Leaving directory `/opt/slug/optware'
make[1]: *** [/opt/slug/optware/builds/libgd/.configured] Error 2
make[1]: Leaving directory `/opt/slug/optware'
make: *** [/opt/slug/optware/builds/amule/.configured] Error 2
jars@jars-Kubuntu-7:/opt/slug/o

Automake is correctly installed in Kubuntu, and it's reported as the latest version.
Any help ?

Thanks, Max

QMax
14-05-2007, 20:57
Problem solved replacing automake1.10 with automake 1.9.
Amule correctly compiled.

Max