PDA

Bekijk de volledige versie : irssi won't run, same problem discussed on forum yet, but in ureadbale language



lbox
01-05-2007, 12:36
hi, i made some steps to - as i hope - right direction to success :-) installed oleg's the latest FW and right managed hdd, ext3 fs and right mounted

i installed via ipkg irss and typed irssi and nothing happen, respective happen just this:

-sh: irssi: not found

i fellow these steps:

a/ installed and upgraded ipkg

mkdir /opt/tmp
mkdir /opt/tmp/ipkg
ipkg.sh update
ipkg.sh install ipkg
ipkg update

group of this commands ended with:

[admin@(none) root]$ ipkg update
Downloading http://wl500g.dyndns.org/ipkg/Packages
Updated list of available packages in /opt/lib/ipkg/lists/wl500g
Downloading http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/Packages
Updated list of available packages in /opt/lib/ipkg/lists/unslung


but these 2 links don't containt irssi i decided to next step

b/ added next repository link to ipkg.conf

[admin@(none) root]$ vi /opt/etc/ipkg.conf
src wl500g http://wl500g.dyndns.org/ipkg
src unslung http://ipkg.nslu2-linux.org/feeds/unslung/wl500g
src optware http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable
dest root /


then :wq

and upgraded list of avaiables packages:

[admin@(none) root]$ ipkg update
Downloading http://wl500g.dyndns.org/ipkg/Packages
Updated list of available packages in /opt/lib/ipkg/lists/wl500g
Downloading http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/Packages
Updated list of available packages in /opt/lib/ipkg/lists/unslung
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages
Updated list of available packages in /opt/lib/ipkg/lists/optware
Successfully terminated.


then continued with attempt to install irssi

[admin@(none) root]$ ipkg install irssi
Installing irssi (0.8.11-2) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/irssi_0. 8.11-2_mipsel.ipk
package irssi suggests installing perl
Installing glib (2.6.6-6) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/glib_2.6 .6-6_mipsel.ipk
Installing ncurses (5.6-1) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/ncurses_ 5.6-1_mipsel.ipk
Installing gconv-modules (2.2.5-6) to root...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/gconv-mo dules_2.2.5-6_mipsel.ipk
Configuring gconv-modules
Configuring glib
Configuring irssi
Configuring ncurses
Successfully terminated.


seems as everything happen ok, but...

when i typed

irssi this line occured:

[admin@(none) root]$ irss
-sh: irss: not found

does anybody know what i made wrong?

well i found someone discussed similar problem here, but i won;t read it

http://wl500g.info/showthread.php?t=8970&highlight=irssi

thank you

al37919
01-05-2007, 14:10
[admin@(none) root]$ vi /opt/etc/ipkg.conf
src wl500g http://wl500g.dyndns.org/ipkg
src unslung http://ipkg.nslu2-linux.org/feeds/unslung/wl500g
src optware http://ipkg.nslu2-linux.org/feeds/op...g/cross/stable
dest root /

You should not mix packages from unslung and optware together. /opt/etc/ipkg.conf has to contain only:

src/gz optware http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable
dest /opt/ /

lbox
01-05-2007, 14:27
i did you recomended me and i recieved the same thing, before all this happen i removed all modules installed over ipkg

here is result:

[root@(none) /]$ ipkg update
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages .gz
Inflating http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages.g z
Updated list of available packages in /opt/lib/ipkg/lists/optware
Successfully terminated.
[root@(none) /]$ ipkg install irssi
Installing irssi (0.8.11-2) to /opt/...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/irssi_0. 8.11-2_mipsel.ipk
package irssi suggests installing perl
Installing glib (2.6.6-6) to /opt/...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/glib_2.6.6-6_mipsel.ipk
Installing ncurses (5.6-1) to /opt/...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/ncurses_5.6-1_mipsel.ipk
Installing gconv-modules (2.2.5-6) to /opt/...
Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/gconv-modules_2.2.5-6_mipsel.ipk
Configuring gconv-modules
Configuring glib
Configuring irssi
Configuring ncurses
Successfully terminated.
[root@(none) /]$ irssi
-sh: irssi: not found
[root@(none) /]$

the same thing happen with nano and screen ,both not found

but when i removed all modules, upgraded ipkg over ipkg.sh and again installed nano and screen both modules run, it seems like Optware http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages is not compatibel with current ipkg, i checked the same modules in both repository, they have same version but different sizes

Package: abook
Version: 0.5.6-1
Depends: ncurses, readline
Section: misc
Architecture: mipsel
Maintainer: Brian Zhou <bzhou@users.sf.net>
MD5Sum: d928e8c420e7e61167965ab5d80d2eaf
Size: 40506
Filename: abook_0.5.6-1_mipsel.ipk
Source: http://easynews.dl.sf.net/sourceforge/abook/abook-0.5.6.tar.gz
Description: Abook is a text-based addressbook program designed to use with mutt mail client

Package: abook
Version: 0.5.6-1
Depends: ncurses, readline
Section: misc
Architecture: mipsel
Maintainer: Brian Zhou <bzhou@users.sf.net>
MD5Sum: 46431e6716e1d932b203ec10bf9d307b
Size: 41014
Filename: abook_0.5.6-1_mipsel.ipk
Source: http://easynews.dl.sf.net/sourceforge/abook/abook-0.5.6.tar.gz
Description: Abook is a text-based addressbook program designed to use with mutt mail client.

I know different size, it can points to nothing, but it is not for sure, who knows, I hope oleg will tell us more..

Thank you

al37919
01-05-2007, 14:42
make sure that uclibc-opt and ipkg-opt are installed
Oleg recommended this topic to study:
http://wl500g.info/showthread.php?t=2036

lbox
01-05-2007, 16:36
thank you, works, I moved up again, irssi started but

Can't locate Symbol.pm in @INC (@INC contains: /opt/lib/perl5/5.8.8/mipsel-linux /opt/lib/perl5/5.8.8 /opt/lib/perl5/site_perl/5.8.8/mipsel-linux /opt/lib/perl5/site_perl/5.8.8 /opt/lib/perl5/site_perl .) at (eval 9) line 9. the bottom always
BEGIN failed--compilation aborted at (eval 9) line 9.

and this mess is maybe me fault..

al37919
01-05-2007, 17:21
well, I've no idea where this error comes from. However, taking into account your previous double-repository set up. I suggest to reinstall everything from optware. The earlier you do this the better. Otherwise you will probably continue getting weird messages in the future. It was also my experience...