Bekijk de volledige versie : USB Drive won't mount

29-04-2007, 20:18
I've got a problem: When I try to mount an USB HDD by just turning it on, it is not recognized. The disk is formatted with the EXT3 Filesystem and has 160GB of space. It has only got one partition that is primary. When I issue the command "df" only the root filesystem shows up. Tried the same with an 128MB usb stick but then the same problem occurs. Whats wrong?

29-04-2007, 20:48
try to mount it manually with
mount /dev/discs/disc0/part1 /opt
Check, if /dev/discs is empty, issue:
insmod scsi_mod && insmod sd_mod && insmod usb-storage

BTW, which firmware do you use? asus orignal AFAIK doesn't support ext3, only ext2

29-04-2007, 21:57
As you can read in my signature: THE LATEST VERSION OF OLEG'S FIRMWARE

I'll try it tomorrow.


29-04-2007, 22:13
Have you got any swap memory?

check this: fdisk -l
(listing your storages and partitions, if you look ~160GB partition on list, you
not enough memory to mount this storage)

Check this: free
if you look:
total used free shared buffers
Mem: 13932 12016 1916 0 1132
Swap: 0 0 0
Total: 770892 15232 755660
you not have enough memory (router ram and swap)

if you have Swap: 0, create swap partition (fdisk, mkswap, swapon) or create swap file (dd, mkswap, swapon)

change partition: your data lost

or create swap file on other mounted storage. (on 128MB stick. if you use for swap, required to mount 160GB hdd!)

bye, György

sorry my english...

30-04-2007, 11:10
When I try something, I only get errors. fdisk -l doesn't do something. My 128MB USB stick won't even mount. Do I have to re-install the firmware?

30-04-2007, 13:06
Please write to forum somesting system response:

cat /usr/local/sbin/post-boot



ls -l /dev/discs (connected both usb drives)

fdisk -l

No, I think the re-install firmware no solving the problem.

30-04-2007, 13:15
Do you've samba, ftp or nfs enabled?

You've to provide system log too.

01-05-2007, 10:07
I think there was an ERROR in my samba config. I resetted everything and now it works!

Thanks Oleg for making this great firmware!