PDA

Bekijk de volledige versie : install packeges



lbox
29-04-2007, 18:17
Hi, sorry for next noob's question, I guess this thread is the right place to put it in. I would like to know how to exact and effective install irssi irc client

here are links for packages need install to run it:
http://downloads.openwrt.org/backports/0.9/irssi_0.8.10-1_mipsel.ipk
http://downloads.openwrt.org/whiterussian/packages/glib1_1.2.10-1_mipsel.ipk
http://downloads.openwrt.org/whiterussian/packages/libpthread_0.9.27-1_mipsel.ipk
http://download2.berlios.de/pub/xwrt/packages/libncurses_5.2-8_mipsel.ipk

and let say i am logged in as admin.

Please, good people, understand me, I am not linux guru, I use this router for needs of my small bussines that is connected with puters but different cathegory.

well, good to say, oleg's FW 7g here and I know how to access router via putty
Thank you a lot

Oleg
29-04-2007, 18:33
Install openwrt to use openwrt packages.

lbox
29-04-2007, 18:40
Install openwrt to use openwrt packages.

i guessed it no matter, is it just "personal fight"? or is it uncompatibility of both systems? where could i find repository for your system?

is possible my attempt to install failed couse i found one and only installable place on fat32 usb device i had mounted? and is trouble i was logged as admin and no root?

Thank you for next round of answers/questions :-)

al37919
29-04-2007, 19:58
root@wl500g,~> ipkg list | grep irssi
irssi - 0.8.11-1 - A terminal based IRC client for UNIX systems.
So, irssi is available as optware package for the Oleg's firmware.
To set right repository, do:

cat > /opt/etc/ipkg.conf << EOF
src/gz optware http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable
dest /opt/ /
EOF

Afterwards reinstall all packages

lbox
29-04-2007, 20:32
thank you it works better and better from steb by step, but I am getting this error: ipkg: Cannot create symlink from ./opt/lib/libglib-2.0.so.0 to 'libglib-2.0.so.0.600.6': Operation not permitted

well, i found i will need to buy some linux book :-)

al37919
29-04-2007, 21:42
well, i found i will need to buy some linux book :-)

seems to be a really good idea


is possible my attempt to install failed couse i found one and only installable place on fat32 usb device i had mounted?

not very clear. However, for the installation of the packages it's not good idea to use fat32 partition. Use ext3 instead. (fat32 doesn't support symlinks at all)