PDA

Bekijk de volledige versie : Bluetooth precompiled: problems with newest modified firmware



Mzuri
23-09-2004, 20:26
Hi there,
My router runs the newest Oleg firmware. As directed by the WIKI page regarding Affix bluetooth (http://wiki.wl500g.info/index.php/PackageAffix), I installed and started the drivers. So far, so good, but the problems start when running applications.
It seems like there is a version conflict. Is there an easy solution, or should I start learning to compile the firmware and so forth?
Cheers,
Mark


Starting up goes well: :D
/mnt/usbfs/affix-release/bin # ./start_bt
Using /mnt/usbfs/affix-release/bin/kernel/net/affix/affix.o
Using /mnt/usbfs/affix-release/bin/kernel/drivers/affix/affix_usb.o
Using /mnt/usbfs/affix-release/bin/kernel/net/affix/affix_rfcomm.o
Using /mnt/usbfs/affix-release/bin/kernel/net/affix/affix_pan.o
/mnt/usbfs/affix-release/bin # btsrv: main: btsrv started [Affix 2.1.2].
btsrv: start_service: Bound service Dialup Networking to port 1
btsrv: start_service: Bound service LAN Access to port 2
btsrv: start_service: Bound service OBEX File Transfer to port 3
btsrv: start_service: Bound service OBEX Object Push to port 4

But the apps give me lip: :(
/mnt/usbfs/affix-release/bin # ./btsrv
./btsrv: error while loading shared libraries: ./btsrv: symbol tmpfile, version GLIBC_2.2 not defined in file libc.so.6 with link time reference
/mnt/usbfs/affix-release/bin # ./btctl
./btctl: error while loading shared libraries: ./btctl: symbol __xpg_basename, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
/mnt/usbfs/affix-release/bin # ./btftp
./btftp: 1: /usr/src/WRT54G/modules_2.1.2//bin/btctl: not found

bramfm
24-09-2004, 14:14
Hi there,
My router runs the newest Oleg firmware. As directed by the WIKI page regarding Affix bluetooth (http://wiki.wl500g.info/index.php/PackageAffix), I installed and started the drivers. So far, so good, but the problems start when running applications.
It seems like there is a version conflict. Is there an easy solution, or should I start learning to compile the firmware and so forth?
Cheers,
Mark


Starting up goes well: :D
/mnt/usbfs/affix-release/bin # ./start_bt
Using /mnt/usbfs/affix-release/bin/kernel/net/affix/affix.o
Using /mnt/usbfs/affix-release/bin/kernel/drivers/affix/affix_usb.o
Using /mnt/usbfs/affix-release/bin/kernel/net/affix/affix_rfcomm.o
Using /mnt/usbfs/affix-release/bin/kernel/net/affix/affix_pan.o
/mnt/usbfs/affix-release/bin # btsrv: main: btsrv started [Affix 2.1.2].
btsrv: start_service: Bound service Dialup Networking to port 1
btsrv: start_service: Bound service LAN Access to port 2
btsrv: start_service: Bound service OBEX File Transfer to port 3
btsrv: start_service: Bound service OBEX Object Push to port 4

But the apps give me lip: :(
/mnt/usbfs/affix-release/bin # ./btsrv
./btsrv: error while loading shared libraries: ./btsrv: symbol tmpfile, version GLIBC_2.2 not defined in file libc.so.6 with link time reference
/mnt/usbfs/affix-release/bin # ./btctl
./btctl: error while loading shared libraries: ./btctl: symbol __xpg_basename, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
/mnt/usbfs/affix-release/bin # ./btftp
./btftp: 1: /usr/src/WRT54G/modules_2.1.2//bin/btctl: not found


The libc.so.6 file that can be found in the current firmware cannot be used in combination with the affix stack. Therefore in the precompiled archive you can find an alternative file libc.so.6 (ucLibc) in the lib directory. Make sure you have set the LD_LIBRARY_PATH to this lib directory.

Or just start start_bt as:

. ./start_bt

The space is important (so it says "point" "space" "point" "slash"), this way the systems variables are set when running this script.


MK

Mzuri
24-09-2004, 15:35
Thanks! Never even considered to try that...




Or just start start_bt as:
. ./start_bt
The space is important (so it says "point" "space" "point" "slash"), this way the systems variables are set when running this script.