PDA

Bekijk de volledige versie : Wireless connection lost after certain time on a WL500g



pdenessen
12-04-2007, 21:24
I have installed the latest Oleg Firmware 1.9.2.7-7f on a WL500g
The installation went well. However now the wireless connections to several PC's with wifi connection is getting lost after some time (a few hours) Only powercycle of the router will reactivate this.

The PCs detects the wireless network but are not able to connect to the router.

Melsoft
23-04-2007, 12:19
Hi,
I encountered same symptoms on my WL-500g after installing the -7f version. My first suspicion was the temperature of some of the chips. I installed passive heatsinks on CPU, switch chip and of course on the miniPCI card's chip. It seems to work flawless. In the last two weeks I haven't observed any problems more. Maybe somebody of experts here can tell us, if the load of the router is higher with new version than with older FW versions (I would expect it).

BTW: for the cooling I used copper heatsinks with thermalconductive sticker originaly used for BGA memory chips on video cards.(14x14x8mm - for the CPU 20x20mm would be better )

Jan

Sketchup
25-04-2007, 16:57
Same problem here, but with a wl500g deluxe. :(
I just removed the casing... The cpu already had a heatsink... I'll check the temp of the broadcom chip, no mini-pci card btw.

If running without the casing fixes the troubles, I'll add more heatsinks.

Yours,

Tom

mistraller
25-04-2007, 20:22
And how about the -7g firmware?

harakiri576
27-04-2007, 14:27
And how about the -7g firmware?

I also had the same problem (although for me, wlan worked for a few days before the need of a powercycle). Installing -7g seemingly solved the problem, uptime is 5 days now, with lots of load (scp + enhanced-ctorrent).

harakiri576
28-04-2007, 17:20
I also had the same problem (although for me, wlan worked for a few days before the need of a powercycle). Installing -7g seemingly solved the problem, uptime is 5 days now, with lots of load (scp + enhanced-ctorrent).

I was wrong - wlan stops working after a couple of days just as well.
What helped was a suggestion on the above link: executing 'wl radio off' and then 'wl radio on'. I doesn't hurt to put this in some sort of crontab and execute it daily. :)

Melsoft
04-07-2007, 06:53
I consulted this problem in Czech CDMA forum and user "vf" gave me very good advice. Folowing his recomendation I used instead of setting "Wireless-Channel" to "AUTO" the setting with permanent channel number. (I scanned my enviroment with "AP-Scan" and used one of the free channels).
Since this moment I have no problem (4 days) with connecting to WiFi.
Probably this is a problem of the wifi driver (no source available ???) so this is probably the easyest possibility to workaround this problem at the moment.
Try it and don't forget to report if it helps.

melsoft

griefff
10-07-2007, 16:02
>instead of setting "Wireless-Channel" to "AUTO" the setting with permanent channel number. (I scanned my enviroment with "AP-Scan" and used one of the free channels).

yes, I have done the same. after having updated to oleg 7g, I found that
it would change channel from 1 to 11, and my computer and a dd-wrt
equipped linksys in client-bridge mode would then no longer connect.
having changed setting from auto to a fixed channel seems to have
resolved the problem.

cheers

pirecrompir
04-08-2007, 08:40
Hi,

I'm experiencing the same problem and would like to try the solution with the fixed channel setting. I have 2 questions:

- do I have to change the channel number on my router only ("Wireless -> Interface" - which I did) or is there a similar setting on my Win XP somewhere that I have to change to the same number?

- does it matter which channel number I choose (I chose one on random)? How do I "scan my environment for free channels" as somebody mentioned previously?

Thank you for your answers!

avberk
13-08-2007, 13:31
Change it on your router only.
Just try it out. I got mine running stable on channel 6