PDA

Bekijk de volledige versie : HDD - гадость какя-то. не монтируется и т.д.



lexass
12-04-2007, 00:42
идем путем: http://www.macsat.com/macsat/content/view/22/29/

все хорошо до п.8,
далее:


[admin@WL-500g root]$ mount /dev/discs/disc0/part1 /opt
mount: Mounting /dev/discs/disc0/part1 on /opt failed: Invalid argument
[admin@WL-500g root]$ mkswap /dev/discs/disc0/part2
Setting up swapspace version 1, size = 222076928 bytes
[admin@WL-500g root]$ mount /dev/discs/disc0/part1 /opt
mount: Mounting /dev/discs/disc0/part1 on /opt failed: Invalid argument
[admin@WL-500g root]$


чего делать???


[admin@WL-500g root]$ df
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 2880 2880 0 100% /
[admin@WL-500g root]$


[admin@WL-500g root]$ free
total used free shared buffers
Mem: 30116 12820 17296 0 1504
Swap: 0 0 0
Total: 30116 12820 17296


[admin@WL-500g root]$ top
Mem: 12860K used, 17256K free, 0K shrd, 1504K buff, 5104K cached
Load average: 0.01, 0.03, 0.00 (State: S=sleeping R=running, W=waiting)

PID USER STATUS RSS PPID %CPU %MEM COMMAND
149 admin R 432 139 2.8 1.4 top
110 admin S 416 109 0.9 1.3 pptp
104 admin S 748 1 0.0 2.4 pppd
1 admin S 684 0 0.0 2.2 init
139 admin S 556 60 0.0 1.8 sh
68 admin S 532 1 0.0 1.7 nas
137 admin S 492 1 0.0 1.6 upnp
107 admin S 464 1 0.0 1.5 watchdog
74 nobody S 464 1 0.0 1.5 dnsmasq
109 admin S 460 104 0.0 1.5 sh
119 admin S 428 1 0.0 1.4 pptp
71 admin S 400 1 0.0 1.3 syslogd
65 admin S 388 1 0.0 1.2 httpd
72 admin S 368 1 0.0 1.2 klogd
102 admin S 356 1 0.0 1.1 igmpproxy
91 admin S 344 1 0.0 1.1 rcamdmain
89 admin S 340 1 0.0 1.1 waveservermain
112 admin S 340 107 0.0 1.1 ntp
60 admin S 328 1 0.0 1.0 telnetd
106 admin S 320 1 0.0 1.0 infosvr

незнаю чего еще сказать весь форум перерыл...

ЗЫ
вроде все должно было быть просто!


ЗЗЫ
[admin@WL-500g root]$ mount
/dev/root on / type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
ramfs on /tmp type ramfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)


это тоже не катит
[admin@WL-500g root]$ killall stupid-ftpd nmbd smbd
killall: stupid-ftpd: no process killed
killall: nmbd: no process killed
killall: smbd: no process killed
[admin@WL-500g root]$ umount /tmp/harddisk
umount: Couldn't umount /tmp/harddisk: Invalid argument


===========================================

зато ПИНГ ща:

84 bytes from 192.168.1.1: icmp_seq=14 ttl=64 time=0.4

ранее был 17 ms

Oleg
12-04-2007, 09:16
Ещё раз запустить mke2fs -j ...
И вывод сюда.

VOVA_iS
12-04-2007, 09:22
это тоже не катит
[admin@WL-500g root]$ killall stupid-ftpd nmbd smbd
killall: stupid-ftpd: no process killed
killall: nmbd: no process killed
killall: smbd: no process killed
[admin@WL-500g root]$ umount /tmp/harddisk
umount: Couldn't umount /tmp/harddisk: Invalid argument


Сам пойми как могут быть убиты процессы которые не запущены...

Команда top показывает запущенные процессы

[admin@WL-500g root]$ top
Mem: 12860K used, 17256K free, 0K shrd, 1504K buff, 5104K cached
Load average: 0.01, 0.03, 0.00 (State: S=sleeping R=running, W=waiting)

PID USER STATUS RSS PPID %CPU %MEM COMMAND
149 admin R 432 139 2.8 1.4 top
110 admin S 416 109 0.9 1.3 pptp
104 admin S 748 1 0.0 2.4 pppd
1 admin S 684 0 0.0 2.2 init
139 admin S 556 60 0.0 1.8 sh
68 admin S 532 1 0.0 1.7 nas
137 admin S 492 1 0.0 1.6 upnp
107 admin S 464 1 0.0 1.5 watchdog
74 nobody S 464 1 0.0 1.5 dnsmasq
109 admin S 460 104 0.0 1.5 sh
119 admin S 428 1 0.0 1.4 pptp
71 admin S 400 1 0.0 1.3 syslogd
65 admin S 388 1 0.0 1.2 httpd
72 admin S 368 1 0.0 1.2 klogd
102 admin S 356 1 0.0 1.1 igmpproxy
91 admin S 344 1 0.0 1.1 rcamdmain
89 admin S 340 1 0.0 1.1 waveservermain
112 admin S 340 107 0.0 1.1 ntp
60 admin S 328 1 0.0 1.0 telnetd
106 admin S 320 1 0.0 1.0 infosvr

Данных процессов тут нет...

lexass
12-04-2007, 17:13
Ещё раз запустить mke2fs -j ...
И вывод сюда.

да запускал, все проходит без вопросов...
а дальше фиг.... :mad:

ЗЫ

у кого есть время, аська 71414253


ЗЗЫ
я не линуксоЕд, но кнопки нажимаю...



Сам пойми как могут быть убиты процессы которые не запущены...
это до кучи было, т.к. такое писалось, линк кидать не буду...

lexass
12-04-2007, 17:31
[admin@WL-500g harddisk]$ df
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 2880 2880 0 100% /
[admin@WL-500g harddisk]$ umount /tmp/harddisk
umount: Couldn't umount /tmp/harddisk: Invalid argument
[admin@WL-500g harddisk]$ mount /dev/discs/disc0/part1 /opt
mount: Mounting /dev/discs/disc0/part1 on /opt failed: Invalid argument

exxon
12-04-2007, 18:28
рискуя показаться невежливым... а можно посмотреть на результат выполнения
ls -la /dev/discs/disc0/
? :)

lexass
12-04-2007, 19:19
не вопрос


[admin@WL-500g harddisk]$ ls -la /dev/discs/disc0/
drwxr-xr-x 1 admin root 0 Jan 1 1970 .
drwxr-xr-x 1 admin root 0 Jan 1 1970 ..
brw------- 1 admin root 8, 0 Jan 1 1970 disc
brw------- 1 admin root 8, 1 Jan 1 1970 part1
brw------- 1 admin root 8, 2 Jan 1 1970 part2


--------------------------

не все понимаю, но пытаюсь разобраться!!!

lexass
12-04-2007, 21:58
не поверите....
ничего не трогал, не менял, после очередного ребута:


[admin@WL-500g root]$ df
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 2880 2880 0 100% /
/dev/discs/disc0/part1 153622084 131240 145687272 0% /tmp/harddisk




танцЫ с бубнами

ЗЫ
дайте рекомендациЙ