PDA

Bekijk de volledige versie : Oleg firmware and PPTP not working



madsun
26-03-2007, 14:09
Trying to get up and running with custom firmware, however after flashing with Oleg's latest my PPTP connection refuses to work.

My chain of units is a Thompson speedtouch 516i -> Asus wl-500gp ->wireless

The speedtouch is running as a bridge, using the pptp to fake a pppoe connection

N'y ideas out there?

Madsun :-)




Jan 1 01:00:03 syslogd started: BusyBox v1.1.3
Jan 1 01:00:03 kernel: Journalled Block Device driver loaded
Jan 1 01:00:03 kernel: devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
Jan 1 01:00:03 kernel: devfs: boot_options: 0x1
Jan 1 01:00:03 kernel: NTFS driver v1.1.22 [Flags: R/O]
Jan 1 01:00:03 kernel: pty: 256 Unix98 ptys configured
Jan 1 01:00:03 kernel: Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
Jan 1 01:00:03 kernel: ttyS00 at 0xb8000300 (irq = 3) is a 16550A
Jan 1 01:00:03 kernel: ttyS01 at 0xb8000400 (irq = 3) is a 16550A
Jan 1 01:00:03 kernel: HDLC line discipline: version $Revision$, maxframe=4096
Jan 1 01:00:03 kernel: N_HDLC line discipline registered.
Jan 1 01:00:03 kernel: loop: loaded (max 8 devices)
Jan 1 01:00:03 kernel: PPP generic driver version 2.4.2
Jan 1 01:00:03 kernel: PPP Deflate Compression module registered
Jan 1 01:00:03 kernel: PPP BSD Compression module registered
Jan 1 01:00:03 kernel: MPPE/MPPC encryption/compression module registered
Jan 1 01:00:03 kernel: Amd/Fujitsu Extended Query Table v1.3 at 0x0040
Jan 1 01:00:03 kernel: number of CFI chips: 1
Jan 1 01:00:03 kernel: Flash device: 0x800000 at 0x1c000000
Jan 1 01:00:03 kernel: Physically mapped flash: squashfs filesystem found at block 945
Jan 1 01:00:03 kernel: Creating 5 MTD partitions on "Physically mapped flash":
Jan 1 01:00:03 kernel: 0x00000000-0x00040000 : "pmon"
Jan 1 01:00:03 kernel: 0x00040000-0x007f0000 : "linux"
Jan 1 01:00:03 kernel: 0x000ec4e4-0x007f0000 : "rootfs"
Jan 1 01:00:03 kernel: 0x007f0000-0x00800000 : "nvram"
Jan 1 01:00:03 kernel: 0x003e0000-0x007f0000 : "flashfs"
Jan 1 01:00:03 kernel: sflash: found no supported devices
Jan 1 01:00:03 kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Jan 1 01:00:03 kernel: IP Protocols: ICMP, UDP, TCP
Jan 1 01:00:03 kernel: IP: routing cache hash table of 512 buckets, 4Kbytes
Jan 1 01:00:03 kernel: TCP: Hash tables configured (established 2048 bind 4096)
Jan 1 01:00:03 kernel: ip_conntrack version 2.1 (256 buckets, 2048 max) - 344 bytes per conntrack
Jan 1 01:00:03 kernel: ip_conntrack_pptp version 1.9 loaded
Jan 1 01:00:03 kernel: ip_nat_pptp version 1.5 loaded
Jan 1 01:00:03 kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jan 1 01:00:03 kernel: ipt_time loading
Jan 1 01:00:03 kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Jan 1 01:00:03 kernel: IPv6 v0.8 for NET4.0
Jan 1 01:00:03 kernel: IPv6 over IPv4 tunneling driver
Jan 1 01:00:03 kernel: NET4: Ethernet Bridge 008 for NET4.0
Jan 1 01:00:03 kernel: 802.1Q VLAN Support v1.7 Ben Greear <greearb@candelatech.com>
Jan 1 01:00:03 kernel: All bugs added by David S. Miller <davem@redhat.com>
Jan 1 01:00:03 kernel: FAT: bogus logical sector size 2816
Jan 1 01:00:03 kernel: FAT: bogus logical sector size 2816
Jan 1 01:00:03 kernel: NTFS: Unable to set blocksize 512.
Jan 1 01:00:03 kernel: VFS: Mounted root (squashfs filesystem) readonly.
Jan 1 01:00:03 kernel: Mounted devfs on /dev
Jan 1 01:00:03 kernel: Freeing unused kernel memory: 72k freed
Jan 1 01:00:03 kernel: Algorithmics/MIPS FPU Emulator v1.5
Jan 1 01:00:03 kernel: eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.37.0
Jan 1 01:00:03 kernel: PCI: Enabling device 01:02.0 (0004 -> 0006)
Jan 1 01:00:03 kernel: eth1: Broadcom BCM4318 802.11 Wireless Controller 3.90.37.0
Jan 1 01:00:03 kernel: vlan0: add 33:33:00:00:00:01 mcast address to master interface
Jan 1 01:00:03 kernel: aster interface
Jan 1 01:00:03 kernel: vlan0: dev_set_promiscuity(master, 1)
Jan 1 01:00:03 kernel: device eth0 entered promiscuous mode
Jan 1 01:00:03 kernel: device vlan0 entered promiscuous mode
Jan 1 01:00:03 kernel: device eth1 entered promiscuous mode
Jan 1 01:00:03 kernel: br0: port 2(eth1) entering listening state
Jan 1 01:00:03 kernel: br0: port 1(vlan0) entering listening state
Jan 1 01:00:03 kernel: br0: port 2(eth1) entering learning state
Jan 1 01:00:03 kernel: br0: port 1(vlan0) entering learning state
Jan 1 01:00:03 kernel: br0: port 2(eth1) entering forwarding state
Jan 1 01:00:03 kernel: br0: topology change detected, propagating
Jan 1 01:00:03 kernel: br0: port 1(vlan0) entering forwarding state
Jan 1 01:00:03 kernel: br0: topology change detected, propagating
Jan 1 01:00:03 dnsmasq[71]: started, version 2.22 cachesize 150
Jan 1 01:00:03 dnsmasq[71]: DHCP, IP range 192.168.1.2 -- 192.168.1.254, lease time 24h
Jan 1 01:00:03 dnsmasq[71]: DHCP, /tmp/dnsmasq.log will be written every 8h
Jan 1 01:00:03 dnsmasq[71]: read /etc/hosts - 4 addresses
Jan 1 01:00:03 dnsmasq[71]: reading /tmp/resolv.conf
Jan 1 01:00:04 kernel: usb.c: registered new driver usbdevfs
Jan 1 01:00:04 kernel: usb.c: registered new driver hub
Jan 1 01:00:04 kernel: usb-uhci.c: $Revision: 1.275 $ time 10:25:12 Jun 17 2006
Jan 1 01:00:04 kernel: usb-uhci.c: High bandwidth mode enabled
Jan 1 01:00:04 kernel: PCI: Enabling device 01:03.0 (0000 -> 0001)
Jan 1 01:00:04 kernel: ECHI PCI device 30381106 found.
Jan 1 01:00:04 kernel: UCHI reg 0x41 = 10
Jan 1 01:00:04 kernel: UCHI reg 0x41 changed to = 0
Jan 1 01:00:04 kernel: usb-uhci.c: USB UHCI at I/O 0x100, IRQ 2
Jan 1 01:00:04 kernel: usb-uhci.c: Detected 2 ports
Jan 1 01:00:04 kernel: usb.c: new USB bus registered, assigned bus number 1
Jan 1 01:00:04 kernel: hub.c: USB hub found
Jan 1 01:00:04 kernel: hub.c: 2 ports detected
Jan 1 01:00:04 kernel: PCI: Enabling device 01:03.1 (0000 -> 0001)
Jan 1 01:00:04 kernel: ECHI PCI device 30381106 found.
Jan 1 01:00:04 kernel: UCHI reg 0x41 = 10
Jan 1 01:00:04 kernel: UCHI reg 0x41 changed to = 0
Jan 1 01:00:04 kernel: usb-uhci.c: USB UHCI at I/O 0x120, IRQ 2
Jan 1 01:00:04 kernel: usb-uhci.c: Detected 2 ports
Jan 1 01:00:04 kernel: usb.c: new USB bus registered, assigned bus number 2
Jan 1 01:00:04 kernel: hub.c: USB hub found
Jan 1 01:00:04 kernel: hub.c: 2 ports detected
Jan 1 01:00:04 kernel: usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
Jan 1 01:00:04 kernel: PCI: Enabling device 01:03.2 (0000 -> 0002)
Jan 1 01:00:04 kernel: ehci_hcd 01:03.2: PCI device 1106:3104
Jan 1 01:00:04 kernel: ehci_hcd 01:03.2: irq 2, pci mem c00a7000
Jan 1 01:00:04 kernel: usb.c: new USB bus registered, assigned bus number 3
Jan 1 01:00:04 kernel: ECHI PCI device 31041106 found.
Jan 1 01:00:04 kernel: ECHI reg 0x49 = 80010f20
Jan 1 01:00:04 kernel: ECHI reg 0x49 changed to = 80010f00
Jan 1 01:00:04 kernel: ECHI reg 0x4b = 80010f09
Jan 1 01:00:04 kernel: ECHI reg 0x4b changed to = 80010f29
Jan 1 01:00:04 kernel: PCI: 01:03.2 PCI cache line size set incorrectly (0 bytes) by BIOS/FW, correcting to 32
Jan 1 01:00:04 kernel: ehci_hcd 01:03.2: USB 2.0 enabled, EHCI 1.00, driver 2003-Dec-29/2.4
Jan 1 01:00:04 kernel: hub.c: USB hub found
Jan 1 01:00:04 kernel: hub.c: 4 ports detected
Jan 1 01:00:04 kernel: usb.c: registered new driver usblp
Jan 1 01:00:04 kernel: printer.c: v0.13: USB Printer Device Class driver
Jan 1 01:00:06 kernel: usb.c: registered new driver audio
Jan 1 01:00:06 kernel: audio.c: v1.0.0:USB Audio Class driver
Jan 1 01:00:06 kernel: Linux video capture interface: v1.00
Jan 1 01:00:06 kernel: SCSI subsystem driver Revision: 1.00
Jan 1 01:00:06 kernel: Initializing USB Mass Storage driver...
Jan 1 01:00:06 kernel: usb.c: registered new driver usb-storage
Jan 1 01:00:06 kernel: USB Mass Storage support registered.
Jan 1 01:00:06 kernel: vlan1: Setting MAC address to 00 18 f3 59 d6 df.
Jan 1 01:00:06 kernel: VLAN (vlan1): Underlying device (eth0) has same MAC, not checking promiscious mode.
Jan 1 01:00:06 kernel: vlan1: add 33:33:00:00:00:01 mcast address to master interface
Jan 1 01:00:06 kernel: vlan1: add 33:33:ff:59:d6:df mcast address to master interface
Jan 1 01:00:07 kernel: vlan1: add 01:00:5e:00:00:01 mcast address to master interface
Jan 1 01:00:07 pppd[99]: pppd 2.4.2 started by admin, uid 0
Jan 1 01:00:07 pppd[99]: Serial connection established.
Jan 1 01:00:08 pppd[99]: Using interface ppp0
Jan 1 01:00:08 pppd[99]: Connect: ppp0 <--> /dev/pts/0
Jan 1 01:00:08 pptp[107]: anon log[usage:pptp.c:94]: /usr/sbin/pptp called with wrong arguments, program not started.
Jan 1 01:00:08 pppd[99]: Modem hangup
Jan 1 01:00:08 pppd[99]: Connection terminated.

Oleg
26-03-2007, 14:14
You've not specified PPTP server address.

madsun
26-03-2007, 14:41
Hmm..isnt that specified in the web setup part?

Btw, great firmware you've made :-)

madsun
27-03-2007, 08:29
works great now :-)