PDA

Bekijk de volledige versie : chmod drive partitions



never
13-09-2004, 11:16
I have an out of the box wl-500g with a usb hard drive enclosure attached - a 250 gb hardrive partitioned with 3 fat32 partitions at 32 gb each and the rest of the drive ntfs.

Is there a way to change file permissions?

The last partition has been set to "read only" and as it is the largest partition I would like to make better use of it .

I am running firmware version 1.8.1.9 from asus

I'm running win xp

Styno
13-09-2004, 11:26
The chmod command can be used to change file permissions
NTFS filesystem is not writable using Linux. Convert it to ext2 or FAT32 if you want to write to it.

never
13-09-2004, 12:00
thanks for the help

I have converted to fat32 - partition size is 142 gb isn't this unstable?

I have tried to chmod using ws_ftp ftp client.

I get the message "503 command not understood. chmod failed It may not be supported on remote site"

got the same message when it was ntfs.

Antiloop
13-09-2004, 12:26
thanks for the help

I have converted to fat32 - partition size is 142 gb isn't this unstable?

I have tried to chmod using ws_ftp ftp client.

I get the message "503 command not understood. chmod failed It may not be supported on remote site"

got the same message when it was ntfs.
chmod is probably not fully(?) supported by StupidFTPd (name says enough i think)

regarding your harddrive

i'm using 160gb harddrive partitioned as 1 160gb fat32 partition

windows xp will not do this so you have to use alternate partition program (Partition Magic for example)

Styno
13-09-2004, 12:46
thanks for the help

I have converted to fat32 - partition size is 142 gb isn't this unstable?

I have tried to chmod using ws_ftp ftp client.

I get the message "503 command not understood. chmod failed It may not be supported on remote site"

got the same message when it was ntfs.
A 142 Gb FAT32 should be no problem for the router. The size is unusual thats all.

Stupid-ftp is a Stupid FTP server. It knows only the most basic FTP commands. Therefore chmod or site commands are not available. The filesystem has nothing to do with the options available in stupid-ftp.

You have to telnet or SSH to your router in order to do a Linux chmod command.

never
13-09-2004, 13:05
I though windows struggled with fat32 partitions larger than 32gb that data could become corrupted or lost, thats why I partitioned the 3 smaller fat32 partitions to 32gb originally. And then ntfs for the remainder. and because the asus documentation recommended fat32 primary partitions.

If there is not a problem with large partitions then I will re-partition the drive to 2 large partitions of fat32

I'm not familiar with linux. I struggle enough with windows. but i will see what I can find out about telnet etc. Thanks for your time and help.

Styno
13-09-2004, 13:55
Its not Windows thats having problems with > 32Gb partition but old pc hardware. Newer pc hardware does not have problems with partitions <= 160 Gb.

Your linux router will probably have no problems with FAT32 partions of 300 Gb, so there is no need to create lots of small partitions.

sup
17-06-2005, 16:39
Hi, I am trying to set up a vsftpd server and it is running already pretty well (others can see and download files and they do not get where I do not want them to get into), but I have not been succesful in granting users write permissions. I can upload files when logged in as a root, but not as a anonymous user. Since it is impossible to use adduser command to add users, I set the anonymous user to be the user nobody in my vsftpd config file (I did not managed to get it running any other way):

ftp_username=nobody
I also set permissions for anonymous users to upload files:

anon_upload_enable=YES
write_enable=YES
I created a folder in my harddisk that I wanted to enable for writing

mkdir /tmp/harddisk/uploads
and listed it permissions values:

ls -al /tmp/harddisk/
and got this:

drwxr-xr-x 2 admin root 32768 Jun 17 17:28 uploads
then I tried to modify this values by this(I think it should work, at least as far as I am understanding this: http://www.8ung.at/spblinux/doc/chmod.html):

chmod o+w /tmp/harddisk/uploads
but nothing happened

Any idea what I am doing wrong (or a suggestion about enabling others to upload files?)? (hope I gave you enaugh info)

sup
14-07-2005, 01:07
well, I learned it is impossible to change ownership (ergo use chmod or chown or similar commands) of fat32 partition - format to ext3 instead and it is working fine