PDA

Bekijk de volledige versie : Принтер Brother и роутер Asus



Plimouthrock
06-01-2007, 20:32
Принтер Brother HL-2030 Можно ли его заставить заработать с Asus WL-500gP?

Вроде бы, это WinPrinter, однако на сайте Brother есть страница с драйверами под Linux, в том числе и для этой модели (http://solutions.brother.com/linux/en_us/index.html). Можно ли их использовать? Что нужно сделать?

Олег! Можете ли кинуть взгляд?

mxch
20-03-2009, 17:46
dir 320 (прошивка Oleg-a 10я) +hub 4 + yota + flash 2GB + brother hl2030r!
В статусе принтер виден а в логах :


Mar 20 19:06:31 p9100d[85]: Connection from 192.168.1.196 port 2566 accepted
Mar 20 19:06:31 p9100d[85]: /dev/usb/lp0: No such file or directory
Mar 20 19:06:32 p9100d[85]: Finished job: 36094 bytes received
Mar 20 19:16:00 p9100d[85]: Connection from 192.168.1.196 port 2699 accepted
Mar 20 19:16:00 p9100d[85]: /dev/usb/lp0: No such file or directory
Mar 20 19:16:00 p9100d[85]: Finished job: 36094 bytes received
Mar 20 19:25:20 login[159]: root login on `pts/0'
Mar 20 19:27:49 p9100d[85]: Connection from 192.168.1.196 port 2780 accepted
Mar 20 19:27:49 p9100d[85]: /dev/usb/lp0: No such file or directory
Mar 20 19:27:50 p9100d[85]: Finished job: 199930 bytes received
Mar 20 19:28:21 p9100d[85]: Connection from 192.168.1.196 port 2785 accepted
Mar 20 19:28:21 p9100d[85]: /dev/usb/lp0: No such file or directory
Mar 20 19:28:21 p9100d[85]: Finished job: 200055 bytes received
Mar 20 19:28:42 kernel: hub.c: new USB device 00:03.1-1.1, assigned address 11
Mar 20 19:28:42 kernel: usb.c: not enough configurations
Mar 20 19:28:42 kernel: usb.c: unable to get device 11 configuration (error=-22)
Mar 20 19:28:42 kernel: hub.c: new USB device 00:03.1-1.1, assigned address 12
Mar 20 19:28:42 kernel: usb.c: not enough configurations
Mar 20 19:28:42 kernel: usb.c: unable to get device 12 configuration (error=-22)
Mar 20 19:38:28 p9100d[85]: Connection from 192.168.1.196 port 2944 accepted
Mar 20 19:38:28 p9100d[85]: /dev/usb/lp0: No such file or directory
Mar 20 19:38:29 p9100d[85]: Finished job: 36095 bytes received

не печатает! Помогите прикрутить !? (с линуксом дужу на ВЫ пока )

может от сюда дрова залить ?http://solutions.brother.com/linux/sol/printer/linux/lpr_drivers.html

Удалось ли подружить роутер с Brother 7010? Дело в том, что у меня похожая модель 7030, сканировать
по сети хочется, а куда копать не знаю. Если решение у вас есть, поделитесь пожалуйста информацией.

al37919
20-03-2009, 18:45
насчет brother hl2030 могу только обнадежить, здесь: http://wl500g.info/showthread.php?t=4374&highlight=2030 указано, что он работает ОК через RAW (вероятно речь о 500gPv1) Отсюда: http://www.openprinting.org/printer_list.cgi?make=Brother следует, что с линуксом он должен бы более-менее дружить.

Далее --- в этих логах принтер не виден. Какая стоит прошивка? В 500gPv2 (и DIR-320) весьма кривой usb. Рекомендую попробовать 1.9.2.7-d, ибо в ней usb должен бы работать несколько лучше. Принтер подключен напрямую (без хаба)? Что говорит это: http://oleg.wl500g.info/hplj/usb_printerid

mxch
21-03-2009, 22:12
насчет brother hl2030 могу только обнадежить, здесь: http://wl500g.info/showthread.php?t=4374&highlight=2030 указано, что он работает ОК через RAW (вероятно речь о 500gPv1) Отсюда: http://www.openprinting.org/printer_list.cgi?make=Brother следует, что с линуксом он должен бы более-менее дружить.

Далее --- в этих логах принтер не виден. Какая стоит прошивка? В 500gPv2 (и DIR-320) весьма кривой usb. Рекомендую попробовать 1.9.2.7-d, ибо в ней usb должен бы работать несколько лучше. Принтер подключен напрямую (без хаба)? Что говорит это: http://oleg.wl500g.info/hplj/usb_printerid

прошивка 10. на usb висит хаб 4-х портовыый defenderактивный,в котором флэшка + YOTA!В третьем юсб принтер брозер 2030р. он кстати пару раз распечатал через lpr. а вот raw нее пробовал(какую очередь там ставить?)). статус принтера в меню status показываает и модель и активность.

p.s.спасиб за ссылку,сам не смекнул на англ ветках порыться!пойду англичан поспрашиваю параллельно - а вдруг помогут да глядиш получится!

bbsc
22-03-2009, 15:27
Насчет Brother HL-2030r подтверждаю, принтер работает отлично.
И через RAW и через LPR.
По-правде говоря, мне не удалось сделать так, чтобы он не работал :))

bbsc
15-08-2009, 08:18
Тоже искал.
Нормальный НР не нашел, 1005/1006 меня как-то не заводят.
Купил Brother HL-2030 и две банки порошка - успокоился на этом.
Новый принтер обошелся что-то около 120 долларов - имхо, вполне достойно.

Aleksei
01-03-2010, 16:45
Здравствуйте всем
есть два компьютера, мфу brother MFC-8860DN со встроеной сетевой картой, телефон самсунг office serv soho с IP каналом, HDD файловый сервер.
Нужна возможность использовать все функции файлового хранилища и МФУ с любого компьютера в домашней сети подключеных как по lan так и по wifi, а так же возможность доступа к настройкам IP телефона и бесперебойная работа в сипнет.
все эти устройства пытаюсь подключить через wl500gp
прошивку обновил
после настройки wl500gp с одного из компьютеров интернет работает только на этом компе и через wifi
после попытке подключить по lan другой компьютер инет на него не раздается в сети его не видно после манипуляций с настройками сетевой карты wl500gp уходит в зависание
отвисает только после перезагрузки
после перезагрузки начинает работать инет на втором компе но первый комп отпадывает
тоже самое происходит при подключении принтера, IP телефона или HDD файлового сервера
уже неделю бъюсь весь форум перечитал различные настройки перепробовал нифика не получается
ребята подскажите пожалуйста что и как нужно делать
я уже на винду грешу может она подглючивает (win XP SP3 pro лицензия)
заранее спасибо

Noobeum
01-03-2010, 17:52
"экстрасенсы в отпуску ввиду сильного переутомления"
настройки в студею

Aleksei
01-03-2010, 23:19
оценил ваш юмор про экстрасенсов
могу по вашему вопросу тоже сказать что я не экстрасенс:)
не могу знать что из настроек конкретно вас интересует
в данный момент все настройки стоят по умолчанию
соединение с инетом vpn настройки всем экстрасенсам известны только цыфры разные у всех
раз с инетом один комп работает думают тут все ок
в включена dhsp автоматическая раздача
в wifi тоже все по умолчанию
все настройки менял в различных комбинациях раз сто
в связи с этим и родился этот пост
как имея перечисленные вначале устройства правильно между собой соедить и настроить
предполагается что еще ничего не подключено и не настроено
с чего нужно в первую очередь начать?

Aleksei
01-03-2010, 23:37
возможно проблемы как то связаны с мак адресом
так как мак адрес WL500g определить не смогли
он транслируется с одного из компьютеров
который изначально был подключен к сети
мак адрес у провайдера привязывается к ip

smi
02-03-2010, 01:27
оценил ваш юмор про экстрасенсов
могу по вашему вопросу тоже сказать что я не экстрасенс:)
не могу знать что из настроек конкретно вас интересует Нас ваши настройки вообще не интересуют, это у вас проблемы, соотвественно это вы должны быть заинтересованы в их решении. Но вы конечно можете и дальше строить из себя девочку, которую упрашивают и удивляться, что ваша проблема никому не интересна :p

Aleksei
02-03-2010, 09:52
Всетаки остается у меня надежда что данный форум серъезный а не флудильня как многие другие
Если бы я был специалистом в сетях я бы наверно сам все настроил

Power
02-03-2010, 10:18
Для начала убедитесь, что на странице System Setup - Operation Mode выбрано Home Gateway и что провод от провайдера вставлен в разъём WAN.
Далее надо проверить, что в вашей сети нет совпадающих MAC-адресов. Узнать, какие адреса использует роутер, можно командой


ifconfig

(смотреть на HWaddr).
На компьютерах (если там винда)


ipconfig /all

Для интерфейса vlan1 допускается совпадение MAC с одним из компов домашней сети.

Ещё неплохо бы увидеть конфигурацию vlan (команда на роутере):


robocfg show

Вы, кстати, сбрасывали настройки после перепрошивки?

Aleksei
02-03-2010, 12:31
куда вводить эти команды
cmd ответил только на одну из них

настройки после перепрошивки не сбрасывал
они сами встают
нужно их сбросить и поновому поставить?

Power
02-03-2010, 12:43
куда вводить эти команды
cmd ответил только на одну из них

настройки после перепрошивки не сбрасывал
они сами встают
нужно их сбросить и поновому поставить?

После смены прошивки обязательно надо сбрасывать настройки и настраивать заново (если предыдущая прошивка не была из той же ветки).

Команды вводить в телнете/ssh либо на странице http://my.router/Main_AdmStatus_Content.asp.

Aleksei
02-03-2010, 12:50
После смены прошивки обязательно надо сбрасывать настройки и настраивать заново (если предыдущая прошивка не была из той же ветки).

полностью руками все набивать или можно сохраненые настройки загрузить?




Команды вводить в телнете/ssh либо на странице http://my.router/Main_AdmStatus_Content.asp.

а мак адреса и ipишники можно выкладывать или не стоит:)

Power
02-03-2010, 13:26
полностью руками все набивать или можно сохраненые настройки загрузить?

а мак адреса и ipишники можно выкладывать или не стоит:)

Насчёт сохранённых - не уверен. Руками надёжнее.

Адреса - если опасаетесь, замените последний байт (в MAC - 2 цифры, в IP - 3) на XX.

Aleksei
02-03-2010, 23:24
Для начала убедитесь, что на странице System Setup - Operation Mode выбрано Home Gateway и что провод от провайдера вставлен в разъём WAN.
Далее надо проверить, что в вашей сети нет совпадающих MAC-адресов. Узнать, какие адреса использует роутер, можно командой


ifconfig

(смотреть на HWaddr).


ответ на команду ifconfig


br0 Link encap:Ethernet HWaddr 00:22:15:01:XX:XX
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4700846 errors:0 dropped:0 overruns:0 frame:0
TX packets:3273939 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:683918714 (652.2 MiB) TX bytes:785797554 (749.3 MiB)

eth0 Link encap:Ethernet HWaddr 00:24:1D:2F:XX:XX
inet addr:10.0.XX.XX Bcast:10.0.XX.XX Mask:255.255.255.0
inet6 addr: fe80::224:1dff:fe2f:515/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13555332 errors:0 dropped:0 overruns:0 frame:0
TX packets:8009887 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2120453288 (1.9 GiB) TX bytes:1727994431 (1.6 GiB)
Interrupt:4 Base address:0x1000

eth1 Link encap:Ethernet HWaddr 00:22:15:01:XX:XX
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:46126
TX packets:0 errors:642 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:12 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MULTICAST MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:152 (152.0 B) TX bytes:152 (152.0 B)

ppp0 Link encap:Point-to-Point Protocol
inet addr:87.224.XXX.XXX P-t-P:172.XX.XX.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING MULTICAST MTU:1400 Metric:1
RX packets:3284627 errors:0 dropped:0 overruns:0 frame:0
TX packets:4721424 errors:0 dropped:17 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:738036943 (703.8 MiB) TX bytes:683017130 (651.3 MiB)

vlan0 Link encap:Ethernet HWaddr 00:22:15:01:XX:XX
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
RX packets:4700850 errors:0 dropped:0 overruns:0 frame:0
TX packets:3273947 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:702726890 (670.1 MiB) TX bytes:798893958 (761.8 MiB)

vlan1 Link encap:Ethernet HWaddr 00:22:15:01:XX:XX
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:398 (398.0 B)





На компьютерах (если там винда)


ipconfig /all

Для интерфейса vlan1 допускается совпадение MAC с одним из компов домашней сети.


ответ на команду ipconfig /all
http://wl500g.info/attachment.php?attachmentid=6062&stc=1&d=1267568367




Ещё неплохо бы увидеть конфигурацию vlan (команда на роутере):


robocfg show

Вы, кстати, сбрасывали настройки после перепрошивки?
в ответ на robocfg show


Switch: enabled
Port 0: 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 1: 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 2: DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 3: DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 4: DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 5: 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
VLANs: BCM5325/535x enabled mac_check mac_hash
0: vlan0: 1 2 3 4 5t
1: vlan1: 0 5u
2: vlan2:
3: vlan3:
4: vlan4:
5: vlan5:
6: vlan6:
7: vlan7:
8: vlan8:
9: vlan9:
10: vlan10:
11: vlan11:
12: vlan12:
13: vlan13:
14: vlan14:
15: vlan15:

настройки все сбросил и ввел вручную

Power
03-03-2010, 01:56
Скажите точную модель роутера (что на нём написано).
Команды на роутере выполнялись уже после сброса настроек и перенастройки?
Ещё зайдите на страницу http://my.router/Advanced_FirmwareUpgrade_Content.asp и скажите, что там в полях Product ID, Firmware Version, Firmware Release.

(К чему это я: либо у вас не wl500gp, как вы написали в первом посте, либо вы залили в него прошивку не от него.)

Aleksei
03-03-2010, 07:42
Скажите точную модель роутера (что на нём написано).
Команды на роутере выполнялись уже после сброса настроек и перенастройки?
Ещё зайдите на страницу http://my.router/Advanced_FirmwareUpgrade_Content.asp и скажите, что там в полях Product ID, Firmware Version, Firmware Release.

(К чему это я: либо у вас не wl500gp, как вы написали в первом посте, либо вы залили в него прошивку не от него.)
ну я уж не совсем идиот :)
наклейка на роутере гласит:
ASUS WL-500GP
90-19D002E02-3PAZ 3678
made in china may.2008

Product ID WL500gp
Firmware Version 1.9.2.7
Firmware Release 1.9.2.7-d-r1222

ps
если смотреть на устройство спереди антенна сзади слева :)

Power
03-03-2010, 12:17
ну я уж не совсем идиот :)
наклейка на роутере гласит:
ASUS WL-500GP
90-19D002E02-3PAZ 3678
made in china may.2008

Product ID WL500gp
Firmware Version 1.9.2.7
Firmware Release 1.9.2.7-d-r1222

ps
если смотреть на устройство спереди антенна сзади слева :)

Значит, проблема с настройками.
После того, как сбросили настройки, вы проверили, что они действительно сбросились?
Вы точно выполняли команды ifconfig и robocfg уже после сброса настроек?
После сброса не выполняли ли вы команд типа "nvram set wan_ifname=eth0" ?
Выполните такую команду и покажите результат


(nvram show | grep -i ifname ; nvram show | grep -i devs ; nvram show | grep -i vlan) 2>/dev/null | sort -u

Aleksei
03-03-2010, 14:43
снова сбросил все настройки и по новой вбил
получился следующий результат


>>>>>>ifconfig




br0 Link encap:Ethernet HWaddr 00:22:15:01:ХХ:ХХ
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1861934 errors:0 dropped:0 overruns:0 frame:0
TX packets:1261781 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1883949115 (1.7 GiB) TX bytes:265154737 (252.8 MiB)

eth0 Link encap:Ethernet HWaddr 00:22:15:01:ХХ:ХХ
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5580371 errors:0 dropped:0 overruns:0 frame:0
TX packets:3127837 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2435206409 (2.2 GiB) TX bytes:2256667841 (2.1 GiB)
Interrupt:4 Base address:0x1000

eth1 Link encap:Ethernet HWaddr 00:22:15:01:ХХ:ХХ
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:196 errors:0 dropped:0 overruns:0 frame:54564
TX packets:6319 errors:469 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:28652 (27.9 KiB) TX bytes:2364079 (2.2 MiB)
Interrupt:12 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MULTICAST MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

ppp0 Link encap:Point-to-Point Protocol
inet addr:87.224.ХХХ.ХХХ P-t-P:172.ХХ.ХХ.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING MULTICAST MTU:1400 Metric:1
RX packets:1254161 errors:0 dropped:0 overruns:0 frame:0
TX packets:1857968 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:243765842 (232.4 MiB) TX bytes:1882056356 (1.7 GiB)

vlan0 Link encap:Ethernet HWaddr 00:22:15:01:ХХ:ХХ
inet6 addr: fe80::222:15ff:fe01:1f6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1861710 errors:0 dropped:0 overruns:0 frame:0
TX packets:1261660 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1891367000 (1.7 GiB) TX bytes:270138417 (257.6 MiB)

vlan1 Link encap:Ethernet HWaddr 00:24:1D:2F:ХХ:ХХ
inet addr:10.0.ХХ.ХХ Bcast:10.0.ХХ.ХХ Mask:255.255.255.0
inet6 addr: fe80::224:1dff:fe2f:515/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3718658 errors:0 dropped:0 overruns:0 frame:0
TX packets:1866172 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:443392517 (422.8 MiB) TX bytes:1986529046 (1.8 GiB)



>>>>>robocfg




Broadcom BCM5325E/536x switch configuration utility
Copyright (C) 2005-2008 Oleg I. Vdovikin (oleg@cs.msu.su)
Copyright (C) 2005 Dmitry 'dimss' Ivanov of "Telecentrs" (Riga, Latvia)

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

Usage: robocfg <op> ... <op>
Operations are as below:
show -- show current config
showmacs -- show known MAC addresses
switch <enable|disable>
port <port_number> [state <enabled|rx_disabled|tx_disabled|disabled>]
[stp none|disable|block|listen|learn|forward] [tag <vlan_tag>]
[media auto|10HD|10FD|100HD|100FD] [mdi-x auto|on|off]
vlan <vlan_number> [ports <ports_list>]
vlans <enable|disable|reset>

ports_list should be one argument, space separated, quoted if needed,
port number could be followed by 't' to leave packet vlan tagged (CPU
port default) or by 'u' to untag packet (other ports default) before
bringing it to the port, '*' is ignored

Samples:
1) ASUS WL-500g Deluxe stock config (eth0 is WAN, eth0.1 is LAN):
robocfg switch disable vlans enable reset vlan 0 ports "0 5u" vlan 1 ports "1 2 3 4 5t" port 0 state enabled stp

none switch enable
2) WRT54g, WL-500g Deluxe OpenWRT config (vlan0 is LAN, vlan1 is WAN):
robocfg switch disable vlans enable reset vlan 0 ports "1 2 3 4 5t" vlan 1 ports "0 5t" port 0 state enabled stp

none switch enable




>>>>>>>>robocfg show


Switch: enabled
Port 0: 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 1: 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 2: DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 3: DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 4: DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 5: 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
VLANs: BCM5325/535x enabled mac_check mac_hash
0: vlan0: 1 2 3 4 5t
1: vlan1: 0 5t
2: vlan2:
3: vlan3:
4: vlan4:
5: vlan5:
6: vlan6:
7: vlan7:
8: vlan8:
9: vlan9:
10: vlan10:
11: vlan11:
12: vlan12:
13: vlan13:
14: vlan14:
15: vlan15:



>>>>>>(nvram show | grep -i ifname ; nvram show | grep -i devs ; nvram show | grep -i vlan) 2>/dev/null | sort -u


lan_ifname=br0
lan_ifnames=vlan0 eth1
lan_ifnames_t=vlan0 eth1
landevs=vlan0 wl0
primary_ifname=eth0
vlan0hwname=et0
vlan0ports=1 2 3 4 5*
vlan1hwname=et0
vlan1ports=0 5
vlan_enable=1
wan0_ifname=vlan1
wan0_ifnames=vlan1
wan0_pppoe_ifname=ppp0
wan_ifname=vlan1
wan_ifname_t=ppp0
wan_ifnames=vlan1
wan_pppoe_ifname=
wandevs=vlan1
wl0_ifname=eth1
wl_ifname=
wlan_ifname=eth1

Power
03-03-2010, 20:41
Вот теперь всё правильно, как и должно быть.
Теперь можете подключать к роутеру больше одного компа, должно работать.

Aleksei
03-03-2010, 22:10
какие настройки сети должны быть на компах
автоматические или нужно прописывать ip

Power
03-03-2010, 23:19
Должно хватить автоматических.

Aleksei
04-03-2010, 08:17
Power спасибо за помощь
еще пару вопросов
1)такой глюк не глюк
сегодня видимо у провайдера инет пропадал
второй комп ни в какую не хотел к роутеру подключаться
и даже роутер показывал что к ниму никто не подключен
потом опять все заработало
это так и должно быть или это глюк какой то
получается если у меня нет связи с ман то и лан не будет работать
2)я подключаю МФУ к сети по аналогии с компьютером ставлю автоматические настройки что нужно настроить чтобы это МФУ было доступно с других компутеров лан

MFMan
04-03-2010, 09:03
Вообще ввиду ваших ограниченных сетевых юнитов(мфу, ип тел, комп, комп) заводить dchp особо смысла нет. Просто ручками задаёте каждому ай пи, при желании привязку по маку, также можно отключить uPnP, т.к. за ненадобностью.


1)такой глюк не глюк
сегодня видимо у провайдера инет пропадал
второй комп ни в какую не хотел к роутеру подключаться
и даже роутер показывал что к ниму никто не подключен
потом опять все заработало
это так и должно быть или это глюк какой то
получается если у меня нет связи с ман то и лан не будет работать
Вот это неправильно. Ваша внутренняя сеть никоем образом с WAN не связана, если нет инета со стороны провайдера, ваша домашняя(внутренняя 192.168.1.х) сеть обязана функционировать.


2)я подключаю МФУ к сети по аналогии с компьютером ставлю автоматические настройки что нужно настроить чтобы это МФУ было доступно с других компутеров лан

Думается мне, что дрова и ПО, поставляемые с МФУ предусматривают возможность сетевого использования сего девайса, главное знать его IP.

Aleksei
04-03-2010, 09:58
попробую понятнее написать
есть два компа
№1 для игр для лазания по интеру для развлечений вообщем
№2 можно сказать рабочий там уменя первичка, переписка, служебные данные и тд вообщем рабочий комп
сегодня утром включил комп №2 чтобы письма собрать с ящиков он начал переподключаться к сети (в смысле к роутеру). Посмотрел на роутере лампочка не горит как будто никто не подключен к лан порту
пошел включил комп №1 этот вроде с роутером соединился но в инет тоже не выходит попробовал на сайт провайдера выйти вроде зашел в город тоже не смог выйти только по ресурсам провайдера
позвонил им говорят у нас все работает
примерно через час комп №1 подключился к инету через пару минут комп №2 тоже подключился
вот и думаю что за глюк есть подозрение что мамка на компе №2 глючит

по поводу мфу у меня brother MFC-8860DN встроеная сетевая карта
ставлю автомат вроде роутер его видит
а вот как сделать чтобы его могли видеть компы №1 и №2 ума не хватает сделать
посоветуйте кто знает:)

Power
04-03-2010, 13:29
сегодня утром включил комп №2 чтобы письма собрать с ящиков он начал переподключаться к сети (в смысле к роутеру). Посмотрел на роутере лампочка не горит как будто никто не подключен к лан порту


Если лампочка порта не горит - это точно проблема железа. Либо роутер (маловероятно, но возможно), либо кабель, либо сетевуха.



по поводу мфу у меня brother MFC-8860DN встроеная сетевая карта
ставлю автомат вроде роутер его видит
а вот как сделать чтобы его могли видеть компы №1 и №2 ума не хватает сделать


У него есть IP-адрес, значит, компы могут к нему подключаться. Кстати, лучше поставить ему статическую привязку по MAC на странице IP Config - DHCP Server (Manually Assigned IP List). А уж как компы должны с ним работать по сети - читайте его инструкцию.

MFMan
04-03-2010, 13:57
попробую понятнее написать
есть два компа
№1 для игр для лазания по интеру для развлечений вообщем
№2 можно сказать рабочий там уменя первичка, переписка, служебные данные и тд вообщем рабочий комп
сегодня утром включил комп №2 чтобы письма собрать с ящиков он начал переподключаться к сети (в смысле к роутеру). Посмотрел на роутере лампочка не горит как будто никто не подключен к лан порту
пошел включил комп №1 этот вроде с роутером соединился но в инет тоже не выходит попробовал на сайт провайдера выйти вроде зашел в город тоже не смог выйти только по ресурсам провайдера
позвонил им говорят у нас все работает
примерно через час комп №1 подключился к инету через пару минут комп №2 тоже подключился
вот и думаю что за глюк есть подозрение что мамка на компе №2 глючит

по поводу мфу у меня brother MFC-8860DN встроеная сетевая карта
ставлю автомат вроде роутер его видит
а вот как сделать чтобы его могли видеть компы №1 и №2 ума не хватает сделать
посоветуйте кто знает:)

Тааак. если комп не подключается по витой паре и сос тороны роутера всё норм, то это 100% проблема в сетевой карте компа, разбирайтесь с дровами, настройками.

Вы пробовали заходить на ваш мфу по его ip адресу? Может быть у него есть вёб интерфейс? Вообще следует изучить манул к мфу.

Aleksei
16-03-2010, 07:47
Спасибо за советы
вставил pci сетевуху проблемы остались
сейчас витую пару попробую другую
затем в магазин новую мамку покупать :(

1) Вообщем все перепробовал проблема с подключением второго компа №2 остались иногда может часами подключаться его роутер вообще не видит
Брал у товарища ноут та же хрень иногда сразу подключается иногда также как и комп №2 его не видит.

2) Также не могу настроить именно домашнюю сеть чтобы было видно все компьютеры и устройства подключенные к маршрутизатору
подскажите какие настройки ковырять

Может кто нибудь подсказать какие манипуляции настройки нужно сделать чтобы на базе роутера создать именно домашнюю сеть два компьютера и мфу (все устройства подключены по сети).
Задача возможность работать с мфу с любого компьютера и возможность обмениваться файлами между компами

Unlimited
16-03-2010, 08:48
Может кто нибудь подсказать какие манипуляции настройки нужно сделать чтобы на базе роутера создать именно домашнюю сеть два компьютера и мфу (все устройства подключены по сети).
Задача возможность работать с мфу с любого компьютера и возможность обмениваться файлами между компами
Убивают ваще такие вопросы.. МФУ то как у вас подключен, дорогой человек?
Вообще никаких манипуляций делать не надо чтоб работала домашняя сеть, дхцп по умолчанию включен на роутере, компьютеры автоматически получают адреса. ВООБЩЕ НИЧЕГО ДЕЛАТЬ НЕ НАДО.

Aleksei
16-03-2010, 10:09
to Unlimited
все устройства подключены по LAN
у всех устройств сетевые карты настроены
на автоматическое получение адресов
(впрочем при указании адресов тоже самое)
компутеры не видят ни друг друга ни мфу

Unlimited
16-03-2010, 10:14
to Unlimited
все устройства подключены по LAN
у всех устройств сетевые карты настроены
на автоматическое получение адресов
(впрочем при указании адресов тоже самое)
компутеры не видят ни друг друга ни мфу
Как вы определяете видимость друг друга?:) В коннектор смотрите? Вы настолько кратко все описываете что понять о чем идет речь вообще не возможно.
В сетевом окружении нет иконки соседнего компа? ох какая жалость. А рабочую группу сделали одинаковую в настройках компьютеров? Пинг проверяли?

Aleksei
16-03-2010, 10:23
что значит кратко?
есть два компа, мфу и роутер
нужно чтобы был доступ с обоих компов к мфу
чтобы был инет на обоих компах
и чтобы был доступ к файлам с одного комутера на другой
не знаю как подробнее еще :confused:

Unlimited
16-03-2010, 12:26
что значит кратко?
есть два компа, мфу и роутер
нужно чтобы был доступ с обоих компов к мфу
чтобы был инет на обоих компах
и чтобы был доступ к файлам с одного комутера на другой
не знаю как подробнее еще :confused:
Мфу-то каким кабелем и куда подключен? И как компы не видят друг друга, вы хотя бы свои действия опишите...

vectorm
16-03-2010, 13:30
что значит кратко?
есть два компа, мфу и роутер
нужно чтобы был доступ с обоих компов к мфу
чтобы был инет на обоих компах
и чтобы был доступ к файлам с одного комутера на другой
не знаю как подробнее еще :confused:
Тут (http://wl500g.info/showpost.php?p=159454&postcount=28) читали?
Продолжение считаю полным оффтопиком:
1. все устройства подключены по LAN, в том числе МФУ.
2. Роутеры по умолчанию LAN не маршрутизируют.
3. Разбирайтесь с компами - на профильных форумах.

Kartoshka
22-08-2010, 15:34
Добрый день.

Есть роутер - ASUS WL-500gP V2 (прошивка 1.9.2.7-10) и принтер Brother HL-5250DN.
Принтер с роутером подключен через usb. Первые полгода все работало прекрасно. Но в какой-то момент при печати принтер стал писать сообщение «Принтер занят или произошла ошибка» - иногда, кстати, помогает перезагрузка роутера, а иногда и нет. В общем, все это надоело, и появилась мысль подключить принтер к роутеру через патч-корд (RJ-45), благо у принтера сетевой интерфейс имеется. Но вот тут я столкнулся с другой проблемой. При подключении патч-корда к роутеру у того соответствующая лампочка не загорается и естественно компьютер принтер не находит. В связи с этим у меня вопрос: кто-нибудь с этим сталкивался? И вообще теоретически подключить принтер через сетевой интерфейс к роутеру можно? И если да, то как?

Буду благодарен за любые советы.
Спасибо!

Parkinstein
22-08-2010, 15:38
Добрый день.

Есть роутер - ASUS WL-500gP V2 (прошивка 1.9.2.7-10) и принтер Brother HL-5250DN.
Принтер с роутером подключен через usb. Первые полгода все работало прекрасно. Но в какой-то момент при печати принтер стал писать сообщение «Принтер занят или произошла ошибка» - иногда, кстати, помогает перезагрузка роутера, а иногда и нет. В общем, все это надоело, и появилась мысль подключить принтер к роутеру через патч-корд (RJ-45), благо у принтера сетевой интерфейс имеется. Но вот тут я столкнулся с другой проблемой. При подключении патч-корда к роутеру у того соответствующая лампочка не загорается и естественно компьютер принтер не находит. В связи с этим у меня вопрос: кто-нибудь с этим сталкивался? И вообще теоретически подключить принтер через сетевой интерфейс к роутеру можно? И если да, то как?

Буду благодарен за любые советы.
Спасибо!

можно, как - написано в инструкции (http://diplodocs.ru/414159.php?k=1642b07006dbeea5cc2d1c327d2777c8&ID=310884&q=BROTHER%20HL-5250DN)к принтеру...

Kartoshka
22-08-2010, 22:42
Parkinstein, в общем-то я и делал как сказано в инструкции, прилагаемой к принтеру. Только вот компьютер никакого принтера не находил, хотя по инструкции должен был. В-принципе на сайте brother (http://welcome.solutions.brother.com/bsc/public/eu/ru/ru/doc/manual_index.html?reg=eu&c=ru&lang=ru&prod=hl5250dn_all&dlid=&flang=%D0%A0%D1%83%D1%81%D1%81%D0%BA%D0%B8%D0%B9&type2=-1) я обнаружил дополнительное руководство пользователя по работе в сети - обязательно буду его изучать...Но меня все равно беспокоит тот факт, что на роутере не загорается лампочка при подключении к нему принтера. Может в этом вся проблема? Такое возможно, при условии, что патч-корд точно рабочий?

Parkinstein
23-08-2010, 03:15
Parkinstein, в общем-то я и делал как сказано в инструкции, прилагаемой к принтеру. Только вот компьютер никакого принтера не находил, хотя по инструкции должен был. В-принципе на сайте brother (http://welcome.solutions.brother.com/bsc/public/eu/ru/ru/doc/manual_index.html?reg=eu&c=ru&lang=ru&prod=hl5250dn_all&dlid=&flang=%D0%A0%D1%83%D1%81%D1%81%D0%BA%D0%B8%D0%B9&type2=-1) я обнаружил дополнительное руководство пользователя по работе в сети - обязательно буду его изучать...Но меня все равно беспокоит тот факт, что на роутере не загорается лампочка при подключении к нему принтера. Может в этом вся проблема? Такое возможно, при условии, что патч-корд точно рабочий?

Возможно, если сетевой интерфейс на принтере отключен\неисправен. Проверить порт подключением к нему заведомо рабочего устройства, проверить интерфейс на принтере подключением его к сетевой компа...

GUID
02-09-2010, 00:11
на роутере не загорается лампочка при подключении к нему принтера. Может в этом вся проблема? Такое возможно, при условии, что патч-корд точно рабочий?
я мучался с другим принтером brother'а (модель сейчас не помню). У меня было 3 варианта подключения: lan, wi-fi, usb.
Выводы:
1. Не все методы авторизации по wi-fi работают.
2. Можно отключать lan-порт. Программа для настройки (которая идет в комплекте) - г..о полное: лучше все делать через веб-интерфейс.
3. (главное!!!) в тех. поддержке - адекватные люди. я бы позвонил не задумываясь.
P.S. надеюсь, что хоть чуть-чуть помог.