Bekijk de volledige versie : sshd does not run on

24-08-2004, 00:43
Maybe Im totally stupid, but sshd does not run on my wl500g. I have done the following and a key was generated, but sshd does not start. Any help for me?

1. Connect to router using telnet
2. Generate the DSS key using


3. If generation was successfull you will need to add /init/rc.sshd to bootCmds using something like

nvram set bootCmdX=/init/rc.sshd

4. Commit the changes using

nvram commit

5. Reboot the router using


or run /init/rc.sshd manually

24-08-2004, 08:31
try to read output in telnet carefully.
DSS and RSS keys are no more stored in nvram, but in /usr/local/etc/dropbear

In there is flashfs command to save, commint, and enable for
flashfs save
flashfs commit
flashfs enable
an then run sshd from bootcmd or with post-boot commands
example sshd. BootCmds will by removed soon i think

24-08-2004, 09:22
Below is a link to the WIKI page on Dropbear SSH daemon, it should help you through....


24-08-2004, 14:38
Thanks very much. I saw this info, but I'm sorry, I do not know what all these things are, yet.

Is there any info about how linux is build in wl500 and a folder structure and maybe more info? Which space is where ...


24-08-2004, 14:58
The WIKI page clearly describes which files you should edit and in which directory they reside. At least to me that is. Following the instructions on the WIKI page EXACTLY should do the trick.

Please elaborate on what you don't understand. Tell me what you have done allready and where you're stuck.

28-08-2004, 21:10
Thanks for the help with ssh, not it is running. Wiki pages helped.
I'm surprised that I need to change bootcmds to flashboot first, I installed last version from Oleg I think.

How can I disable telnet now?
Can I just remove /init/rc.telnentd?
It is read only.

How can I change password of ssh, thats it is different to web interface?


28-08-2004, 23:17
How can I disable telnet now?
Can I just remove /init/rc.telnent?
It is read-only now.

It's a bit non-obvious, but adding something like

mount -o bind /dev/null /init/rc.telnetd

to your /usr/local/init/pre-boot script might do the trick.