Bekijk de volledige versie : How to block FTP access from WAN

03-01-2007, 11:10
I found out that anyone can access my shares through ftp from the internet if they know my IP adres.
How is this possible since I checked, Enable Web Access from WAN? as false in the configuration?
Also Enable the DDNS Client is set to false.
Can someone please help me on this since I really dont want this.

03-01-2007, 20:38
What you can do depends on how your home network is setup. If your asus router is also the front line to the internet, then probably the easiest thing to do is to enable user/password authentication on the router. Do this by going to advanced>share management>windows setup. Check the user based share access box and select your disk volume from the dropdown box. Click apply, then go to advanced>share management>user management and create a new user with a password. Apply the settings and reboot the router. This should now request a username and password from people logging into ftp.

If your asus router is behind another router, or something that can handle port forwarding, just block ports 21 and 20 in that router.

The third option gives you the most control but it involves installing custom firmware and having some linux knowledge.

Install a custom firmware (probably kfurge's would be best), then download vsftpd using ipkg. You can then configure this ftp server using the configuration file (rather than the asus web interface). You can then edit your rc.local to kill existing vsftpd services (ie the one run on startup by the ASUS firmware) then you can start your custom vsftpd service running using rc.local.

07-01-2007, 15:52
Thank you for the response.

I found out that first I have to uncheck ftp acces in the share managment at least make the shares unaccesible.
My router is the first line to internet.
ftp access is checked by default so more WL-700 users that don't have to much puter knowledge will have their files wide open for the rest of the world.
I think this is a bad thing by Asus.
I didn't look at it because I didn't think Asus would open all your files to the world by default, but they do...
I did check the user based share access but after that I wasn't able to access the ftp anymore. Now I see I had to activate the user based access also in the router, thanks for that.

I love the manual Asus gave us for this router, it's so usefull....NOT!

I wil try the user access part and else I wil have to try the custom firmware, but this is my last resort since I know how to use and configure a windows puter but I have almost no knowledge of Linux..
Thanx anyway, problem is solved for now.

07-01-2007, 18:33
The linux configuration isn't too bad - theres a tonne of documentation on vsftpd - the linux ftp daemon. It's just basically a textfile that you set options in like which directory you want to share, anonymous access on/off etc..

Glad to hear you have it secured for the time being though :)