Bekijk de volledige versie : How to get public ip address for my computer?

27-12-2006, 22:28

I bought this wlan box few weeks back and i have a following problem:

I installed ftp-server software to my computer. Software shows my ip address
as follows:

FTP Server listening on port number 21, IP

Ipconfig shows this:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :

How do i have to configure my wlan box so that my computer will get public ip address? So my ftp-server can be accessed outside??

27-12-2006, 22:56
You have to configure port forwarding on the router to make services on your PC accessible from the internet.

27-12-2006, 23:46
Okay, and now very stupid question...where do i do this port forwarding? Is it under nat settings very you can find port trigger?

I can see port forwardings in main configurations page when i login to wlan router. But i cant find a page where i could do actual port forwarding.

28-12-2006, 01:23
In Olegs Firmware for the WL-500gx it's in NAT Settings - Virtual Server

28-12-2006, 01:24
on the wl-700g

Advanced settings --> Internet Firewall --> Virtual Server

enable virtual server

and there you can chose ftp and but in the local ip and so on...


28-12-2006, 11:18
Thanks for your answers.

I found virtual server under nat settings. When i try to add local ip
port etc. nothing happens. Wlan will boot itself but my settings are not displayed anywhere (port forwarding or virtual server).

What should i enter in protocol no.? Maybe this is where i get wrong. I included
a screenshot for my virtual server.

28-12-2006, 17:38
I think you have to but in the local ip in the "local ip" field from your computer = and not 84....

i don't think that you have to but in something in the protocol number field.

but your computer must always get the ip from the router, otherwise it doesn't function. to do that you have to activate the dhcp-server (=Enable Manual Assignment).


28-12-2006, 19:12
Yeah, you are absolutely right :)

I added the wrong ip address. My wan address is 84....but my local ip address is

Now everything works fine. Thanks very much for everyones help.

30-12-2006, 20:01
Hi, I want to port forward certain appliacion so I follow the above instructions, but after I set it the rest of my net application like firefox, etc, don't work anymore, the question is if I enable and set port forwarding do I have to set every single application for each connected computer? Is there a way to specify port forwarding for a specific application but then have the rest of the apps like firefox and internet explorer working without port forwarding?

30-12-2006, 20:58
it's not possible to port forward a program, only the ports could be forwarded from the router. ie and firefox should always get forwarded, because port 80 and 8080 are open by the router.

I don't think that you can but nothing in the local ip field or 192.168.1.*, and so you have to forward it to every local pc.

i'm not at home (where the router is), to test it.