Bekijk de volledige versie : Samba OK but no write permission

19-12-2006, 21:25
I finally got samba working on my 500gP and OLEG I did all the stuff following http://wl500g.info/showthread.php?t=5909, but also had to change some things to get it actually work. If anyone needs some assistance with samba you're welcome to ask.

anyway, I got samba working and managed to assign my own shares from multi-partition USB HDD. I can access them in WinXP, however, I only get read access. No write access. I have no idea what I do wrong. In ssh session, I can change/delete/create files in the /tmp/harddisk share. My USB HDD is self-mounted by OLEG firmware so I do not mount it myself anymore. I only mount a ext3 share on /opt for all the required samba stuff (and ipkg etc).

my smb.conf file:

workgroup = nms22f
guest account = nobody
security = share
browseable = yes
guest ok = yes
guest only = no
log level = 1
max log size = 100
encrypt passwords = no
dns proxy = no

writeable = yes
browseable = yes

By the way, the log in 500gP webinterface says:

Dec 19 21:12:12 nmbd[142]: [2006/12/19 21:12:12, 0] lib/pidfile.c:pidfile_create(86)
Dec 19 21:12:12 nmbd[142]: ERROR: nmbd is already running. File /var/lock/nmbd.pid exists and process id 137 is running.
Dec 19 21:12:12 smbd[144]: [2006/12/19 21:12:12, 0] lib/pidfile.c:pidfile_create(86)
Dec 19 21:12:12 smbd[144]: ERROR: smbd is already running. File /var/lock/smbd.pid exists and process id 135 is running.

Using OLEG's firmware, i have the feeling that I have to enable sambe 'twice'. Once in the webinterface (demo mode and hidden share, no idea what they do) and once using linux code. What's OLEG's intention with samba?

19-12-2006, 21:34
I added
force user = admin
to the smb.conf and now I can write to the shares. Thank you AsusForum to put all these very usefull links underneath my own post ;) .

anyway I am still wondering why one part of samba needs to be set up in webinterface and other part using linux.