PDA

Bekijk de volledige versie : Проблема с WL500g и WiFi провайдером



Mike_S
19-11-2006, 16:06
Появилась возможность заменить два устройства на одно - WL500g.
На данный момент использую WiFi Ethernet Adapter SMC2870W и роутер SMC7004VBR эта связка работает без проблем.
А вот с WL500g возникли проблемы - не желает коннектится с точкой провайдера.

В WL500g стоит последняя версия программы - 1.9.2.7-7f.

WLAN:
В поле SSID указано имя AP провайдера.
каналы Auto
Без шифрования
В разделе Advanced: Station

WAN: Static IP
IP 10.3.X.X
Сетевая маска:255.255.255.224
Гейтвей: 10.3.X.X
ДНС - вручную
ДНС1: 10.0.0.1
ДНС2: 10.3.255.1
MAC: клонируется

LAN с DHCP 192.168.X.X
log Wireless пишет следующее:
Mode : Station
Channel : 1
Status : Connecting to P02M

================================================== ========

routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.3.X.X7 * 255.255.255.255 UH 0 0 0 WAN eth2
10.3.X.X6 * 255.255.255.224 U 0 0 0 WAN eth2
192.168.1.0 * 255.255.255.0 U 0 0 0 LAN br0
default 10.3.X.X7 0.0.0.0 UG 0 0 0 WAN eth2


Jan 1 03:00:02 syslogd started: BusyBox v1.1.3
Jan 1 03:00:02 dnsmasq[52]: started, version 2.22 cachesize 150
Jan 1 03:00:02 dnsmasq[52]: DHCP, IP range 192.168.1.100 -- 192.168.1.104, lease time 24h
Jan 1 03:00:02 dnsmasq[52]: DHCP, /tmp/dnsmasq.log will be written every 8h
Jan 1 03:00:02 dnsmasq[52]: read /etc/hosts - 4 addresses
Jan 1 03:00:02 dnsmasq[52]: reading /tmp/resolv.conf
Jan 1 03:00:02 dnsmasq[52]: using nameserver 10.3.255.1#53
Jan 1 03:00:02 dnsmasq[52]: using nameserver 10.0.0.2#53
Jan 1 03:00:02 kernel: 0x00040000-0x003f0000 : "linux"
Jan 1 03:00:02 kernel: 0x000ec4e4-0x003f0000 : "rootfs"
Jan 1 03:00:02 kernel: 0x003f0000-0x00400000 : "nvram"
Jan 1 03:00:02 kernel: 0x003e0000-0x003f0000 : "flashfs"
Jan 1 03:00:02 kernel: sflash: chipcommon not found
Jan 1 03:00:02 kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Jan 1 03:00:02 kernel: IP Protocols: ICMP, UDP, TCP
Jan 1 03:00:02 kernel: IP: routing cache hash table of 512 buckets, 4Kbytes
Jan 1 03:00:02 kernel: TCP: Hash tables configured (established 1024 bind 2048)
Jan 1 03:00:02 kernel: ip_conntrack version 2.1 (128 buckets, 1024 max) - 344 bytes per conntrack
Jan 1 03:00:02 kernel: ip_conntrack_pptp version 1.9 loaded
Jan 1 03:00:02 kernel: ip_nat_pptp version 1.5 loaded
Jan 1 03:00:02 kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jan 1 03:00:02 kernel: ipt_time loading
Jan 1 03:00:02 kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Jan 1 03:00:02 kernel: IPv6 v0.8 for NET4.0
Jan 1 03:00:02 kernel: IPv6 over IPv4 tunneling driver
Jan 1 03:00:02 kernel: NET4: Ethernet Bridge 008 for NET4.0
Jan 1 03:00:02 kernel: 802.1Q VLAN Support v1.7 Ben Greear <greearb@candelatech.com>
Jan 1 03:00:02 kernel: All bugs added by David S. Miller <davem@redhat.com>
Jan 1 03:00:02 kernel: FAT: bogus logical sector size 56832
Jan 1 03:00:02 kernel: FAT: bogus logical sector size 56832
Jan 1 03:00:02 kernel: NTFS: Unable to set blocksize 512.
Jan 1 03:00:02 kernel: VFS: Mounted root (squashfs filesystem) readonly.
Jan 1 03:00:02 kernel: Mounted devfs on /dev
Jan 1 03:00:02 kernel: Freeing unused kernel memory: 72k freed
Jan 1 03:00:02 kernel: Warning: unable to open an initial console.
Jan 1 03:00:02 kernel: Algorithmics/MIPS FPU Emulator v1.5
Jan 1 03:00:02 kernel: eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.37.0
Jan 1 03:00:02 kernel: eth1: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.37.0
Jan 1 03:00:02 kernel: PCI: Enabling device 01:02.0 (0004 -> 0006)
Jan 1 03:00:02 kernel: eth2: Broadcom BCM4320 802.11 Wireless Controller 3.90.37.0
Jan 1 03:00:02 kernel: device eth1 entered promiscuous mode
Jan 1 03:00:02 kernel: device eth0 entered promiscuous mode
Jan 1 03:00:02 kernel: br0: port 2(eth0) entering listening state
Jan 1 03:00:02 kernel: br0: port 1(eth1) entering listening state
Jan 1 03:00:02 kernel: br0: port 2(eth0) entering learning state
Jan 1 03:00:02 kernel: ng state
Jan 1 03:00:02 kernel: br0: port 2(eth0) entering forwarding state
Jan 1 03:00:02 kernel: br0: topology change detected, propagating
Jan 1 03:00:02 kernel: br0: port 1(eth1) entering forwarding state
Jan 1 03:00:02 kernel: br0: topology change detected, propagating
Jan 1 03:00:03 kernel: usb.c: registered new driver usbdevfs
Jan 1 03:00:03 kernel: usb.c: registered new driver hub
Jan 1 03:00:03 kernel: usb-ohci.c: USB OHCI at membase 0xb8004000, IRQ 2
Jan 1 03:00:03 kernel: usb-ohci.c: usb-00:04.0, PCI device 14e4:4715
Jan 1 03:00:03 kernel: usb.c: new USB bus registered, assigned bus number 1
Jan 1 03:00:03 kernel: hub.c: USB hub found
Jan 1 03:00:03 kernel: hub.c: 2 ports detected
Jan 1 03:00:04 kernel: lp0: using parport0 (polling).
Jan 1 03:00:04 kernel: usb.c: registered new driver usblp
Jan 1 03:00:04 kernel: printer.c: v0.13: USB Printer Device Class driver
Jan 1 03:00:05 kernel: Linux video capture interface: v1.00
Jan 1 03:00:05 kernel: SCSI subsystem driver Revision: 1.00
Jan 1 03:00:06 kernel: Initializing USB Mass Storage driver...
Jan 1 03:00:06 kernel: usb.c: registered new driver usb-storage
Jan 1 03:00:06 kernel: USB Mass Storage support registered.
Jan 1 03:00:13 kernel: lp driver: get device ID
Jan 1 03:00:13 kernel: neg fail
Jan 1 03:00:13 kernel: neg fail

Связь так и не устанавливается. Изменение мощности передатчика от 15 до 84 результатов не дала. Подключена усиленная антенна +5 db.
Для проверки правильности настройки WAN порта отключал радио, и на WAN вешал WL330 в режиме адаптера. Связь с провайдером устанавливалась без проблем, хотя и с потерей пакетов из-за слабой антенны у WL330.
Интересно, что WL500g нормально коннектится с WL330 (режим AP) в пределах помещения, а вот с провайдером никак.

Так и не понял значение команд:
wl scan
wl scanresults
команды съедаются без отображения информации (в окне telnet).
Я так и не понял, как посмотреть что видит радиоблок WL500g?!

Одна голова хорошо, а форум лучше, надеюсь на вашу помощь.

Oleg
19-11-2006, 16:53
Режим лучше поставить Ethernet Bridge.
Если scanresults возвращает пустоту, то значит он не видит провайдера Вашего...

Mike_S
19-11-2006, 17:15
Олег, спасибо за ответ.
А почему Ethernet Bridge, ведь у меня WLAN должен заменять WAN, сам WAN порт не используется. То есть интернет я получаю именно с WLAN? И Вы до этого в форуме указывали именно на Station.
И вот еще. Этот роутер уже использовался с этим провайдером но с другой его AP, где качество приема было не лучше. Да и моя WL330 без особых проблем с ней связывается, а тут и антенна усиленная не помогает. Причем в моём районе наблюдается около 7 таких точек. Даже мой PocketPC видит точку моего провайдера...
По совету хозяина WL500g я выполнял clear-nvram (wl500g-clear-nvram.trx). После чего приходилось менять регион с Китая на Европу.
Кстати, обязателно ли нужно после очистки nvram прошиватся файлом wl500g-recover.trx?

Oleg
19-11-2006, 17:57
Вам clear-nvram и recover не нужно пользоваться. Где Вы регион меняете?

Mike_S
19-11-2006, 18:30
Брал рекомендации из FAQ
nvram set regulation_domain=0X30DE
nvram commit
По поводу сброса nvram. Поскольку я уже делал clear-nvram, то нужно ли какие то дополнительные действия выполнить, как в случае изменения региона WiFi с Китая на Европу?


P.S. И что всё-таки верно - Ethernet Bridge или Station?

Oleg
19-11-2006, 18:50
Ethernet Bridge. Официально поставляемые Wl500g (не Делюксы) все должны быть со страной "Германия". В Делюксе может быть заменён загрузчик и он будет указывать Тайвань.

Mike_S
19-11-2006, 19:11
У меня точно не Делюкс.
Таки бридж.
А Тайвань вылезает именно после прошивки wl500g-clear-nvram.trx.
Сейчас попробую, переключусь на wl500g.


ЗЫ. Мда, похоже у нее проблема с чувствительностью. scan сразу нашел мою wl330. Но это странно, как я писал ранее, даже мой КПК находит провайдеровскую точку. А нет ли у wl500g регулировок по чувствительноси, или у нее порг заложен, мол сигнал слабее некоторой величины игнорировать? Точка провайдера работает в 802.11b только.

И последний вопрос. Данная проблема с чувствительностью это частный случай или вся линейка такая. И что можете посоветовать из этой серии wl500 - wl550?