PDA

Bekijk de volledige versie : WL-320gE/550gE - подключение USB портов



Kirill
16-11-2006, 09:37
Добрый день!
Извините если уже где-то обсуждалось, ткните тогда туда...Кто подключал к 550 usb? Там припаивать нужно? Квадратный контакт это земля или +5v ? Оба контакта на 5v рабочие?
Спасибо.

Alex Kud
17-11-2006, 20:07
Меня, вообще, тоже эта тема интересует. :)
Пока что нашел вот это: http://wl500g.info/showthread.php?t=5743

Kirill
17-11-2006, 23:39
Я это тоже нашел, с этого собственно и начал исследование...Сегодня разбирал сабж, место под USB разглядел...Как я понял там для двух портов...Землю тоже нашел и неработающую площадку на +5v - видимо придется брать питание на оба порта с одного контакта...

Alex Kud
20-11-2006, 20:01
Если возьметесь припаивать, отпишите о результатах, пожалуйста. От фоток процесса я бы тоже не отказался. :)

Kirill
21-11-2006, 07:45
Исходные фотки ( плата) есть на этом сайте...
А тема эта наверно невыгодна производителю, а заодно и его support`u, поэтому никто на нее не обращает внимания...Паять буду обязательно, но не сам, отдам кому-нить...Времени только сейчас мало.

Oleg
21-11-2006, 08:22
Ржу... :D А на этом форуме нет ни саппорта, ни производителя. :)
Просто те, кому нужен ЮСБ, изначально платят на 10 баксов больше и получают ЮСБ 2.0.

http://www.heimpold.de/mhei/images/pin_header.png

Но для Вас я могу произвести бесчеловечный эксперимент над своим Wl550ge и попробовать подключить флешку. Хотите?

Kirill
21-11-2006, 09:40
Просто на момент покупки не задумывался о Usb, а почитав тему на форуме понравилась идея...Если Вам это самому неинтересно, то не пробуйте...Сам когда попробую отпишусь.

Oleg
21-11-2006, 11:12
Если Вам это самому неинтересно, то не пробуйте...
Если бы я так рассуждал, то ничего бы путного не получилось. Мне многие вещи не нужны, но я их делаю. :)
Хотя в данном случае всё довольно просто - про распаять разъём на плате и бросить перемычку с 5 вольт.
Меня вот удивляет, зачем китайцы распаяли разъём для GPIO, если он вообще никому не нужен... хотя есть мод (http://voidmain.is-a-geek.net/wrt/wrt_sd_card.html)

http://wiki.openwrt.org/_media/toh/asus/wl320ge.jpg?cache=

http://wiki.openwrt.org/toh/asus/wl320g :rolleyes:

Alex Kud
21-11-2006, 16:53
Просто те, кому нужен ЮСБ, изначально платят на 10 баксов больше и получают ЮСБ 2.0.
К сожалению, когда покупал, WL-500g Delux было уже не достать (я по крайней мере не нашел, да и времени искать не было особо), а Premium еще не поступил в продажу. А роутер нужен был срочно... :(

Duke
21-11-2006, 19:25
Если бы я так рассуждал, то ничего бы путного не получилось. Мне многие вещи не нужны, но я их делаю. :) Хотя в данном случае всё довольно просто - про распаять разъём на плате и бросить перемычку с 5 вольт.
Меня вот удивляет, зачем китайцы распаяли разъём для GPIO, если он вообще никому не нужен...

Если звезды зажигают - знаичт это кому-нибудь нужно. Если китайцы развели и распаяли разъем - знаичт он стопудов нужен - даешь Ы2С ;)

Oleg
21-11-2006, 21:15
Значит так, докладываю. Разъём распаял, перемычку сделал соплёй. :)
Подключил разъёмы с внешней ЮСБ планки, остались со времён появления ЮСБ в ПК. Итог - работает, но не со всеми устройствами.
Т.е. флешка у меня не заработала (в логе мат, что не может разрешить порт), а вот кард-ридер - пожалуйста.
Причина более менее понятна - на плате отсутствует обвязка портов (это резисторы в 15к).

9590

Для порта номер 2 (d2) я их идентифицировал - это r70/r134 - они находятся рядом с меньшей Delta. Для первого порта - не нашёл.
Впаять их туда проблематично, т.к. они очень мелкого размера, вместо этого можно припаять их непосредственно к разъёму или
на кабель - нужно 4 резистора номиналом 15 ком, которые одной ногой цепляются на d2+/d2-/d1+/d1-, а другой на землю.
Можно пробовать без резисторов, но результат зависит от того, что будет в том, что Вы подключаете.

Kirill
22-11-2006, 08:45
Огромное спасибо, Oleg!
Весьма интересные результат. Как я понял, перемычка нужна между +5V контактами?

Oleg
22-11-2006, 09:00
Именно так. Без неё будет работать только порт, который ближе к процесссору.

barada
11-01-2008, 09:08
Добрый день, Олег

Являюсь обладателем модели WL320gP. Вопрос в следующем, с недавних пор появилась необходимость вытащить его внутренние USB и подключить к ним CDMA модем (skylink) и HDD. Конечно можно поменять девайс и прошить его прошивкой от поляков (koppel.cz), но что то такой способ меня не привлекает :).

Соотвественно меня интересуют две вещи:
1) поддержка CDMA в ваших прошивках
2) распайка USB (но это я думаю гдето есть просто надо поискать)

С уважением, Яков

Oleg
11-01-2008, 12:02
Они не поляки, а чехи. :)

ЮСБ порты там есть внутри, как и в WL550gE. Как добавить в 550gE я уже писал. Собственно нужен разъём и резисторами подтянуть сигнальные линии. Заработать может и без резисторов, зависит от ЮСБ девайса. В общем - поиск в руки. Вроде кто-то тоже добавлял ЮСБ 550gE.

Поддержки CDMA у меня нет. Чехи вроде для 550gE прошивку не собирают. :(

web55
31-07-2008, 19:56
Подскажите, есть ли возможность установки в Asus WL-550gE (R 1.17) одного (…или лучше два) порта USB 1.1, как у 500gP или распаять COM, что менее желательно? А также хотел уточнить соответствие конфигурации (процессор, память) для работы с MPCS. Постов по данному upgrade не нашёл… Это фото той части платы WL-550gE где думается находятся места для подключения USB и распайки COMа.
http://ipicture.ru/uploads/080731/thumbs/7ZB2GQ7ZS9.jpg (http://ipicture.ru/Gallery/Viewfull/4404863.html)

vectorm
01-08-2008, 20:21
Судя по картинке - распаянные 8 штырьков - это СОМ, только ему надо добавлять разводку до уровня 5V.
Нераспаянные 8 штырьков - 2 USB разъема. Вроде в англоязычной ветке были картинки с распайкой.

http://wl500g.info/attachment.php?attachmentid=2309&stc=1&d=1201002763

web55
01-08-2008, 20:44
...пасиб vectorm действительно нашёл http://wl500g.info/showthread.php?t=5743 ...c картинками :rolleyes:

divan
26-11-2008, 00:42
Рашил распаять USB на wl-320gE. для начала скачал и поставил последнюю прошивку от Олега WL320gE-1.9.2.7-10.trx. Нашёл на плате места распайки, посмотрел, как это делают в ветке про 550ge. мне нужен всего один порт. взял разъём usb-a f, и припаял напрямую проводами к контактам на плате из одного ряда (слева - надпись на плате, потом цвет usb провода и в скобках номер usb-pin на разъеме):

+5V - красный (1)
USB_1N - белый (2)
USB_1P - зелёный (3)
GND - чёрный (4)

экран усб-провода просто обрезал. в такой схеме вообще устройства не заводятся.
выпаял, и припаял точно так же ко второй линейке контактов:

+5V - красный (1)
USB_2N - белый (2)
USB_2P - зелёный (3)
GND - чёрный (4)

теперь то, что втыкаю в usb, мигает сигналом наличия питания, а сам роутер никаких данных о том, что кто-то воткнул в него устройство, не выдаёт. в dmesg и /tmp/syslog.log не появляется никаких новых сообщений. что я делаю не так?

bemmer
03-01-2009, 14:28
Все сделал как написано. Флешки нормально работают, принтер тоже. А вот при подключении внешнего USB винчестера (со своим внешним питанием) Asus его не видит.
Что самое забавное, даже если воткнуть удлинитель USB, но роутер уже ругается, что кабель может быть плохой. Кабели менял - не помогает. Пробовал принтерный кабель в HDD подключать - не работает.
Это связано с отсутствием обвязки в виде 15кОМ резисторов?

ss-18
12-01-2009, 17:22
При использовании Enable multicast routing повисает роутер
прошивка Download 1.9.2.7-10 (2008-03-30) на Asus WL-550gE (R 1.17)

работает только один УСБ
вернее полу работает ....
на флешке загораеться диод, но флешку в системе не видно :(
подскажите чего делать ?

GeoDen
01-03-2009, 17:02
Можно пожалуйста схему распайки УСБ... просто хото заюзать УСБ-принтер и Винт... и есть ли кто запустил сие чудо...

http://www.heimpold.de/mhei/images/pin_header.png

http://www.heimpold.de/mhei/images/asus_inside.png

http://www.nieklinnenbank.nl/wl320ge_usb_storage_howto.html

GeoDen
06-03-2009, 08:38
Нашел как заставить работать... https://www.hunix.nl/articles/06012009wl320ge_usb_storage_howto
далее чего не хватает в прошивке Олега ...

# ipkg install kmod-usb-ohci --- ! Именно этого модуля не хватает
# ipkg install kmod-usb-storage - хотя это присутствует


все они лежат в /lib/modules/2.4.20/ и вот тут не хватает ohci модуля...
Как можно закинуть его туда и проинсталить???

Hohmach
06-03-2009, 09:02
Как можно закинуть его туда и проинсталить???http://code.google.com/p/firmware-mod-kit/

GeoDen
06-03-2009, 09:15
Спс за ссылку уще есть этот набор.. только я в Никсах не Шарю особо.. только начинаю разбираться если кто может закиньте и выложите заранее Благодарю...

theMIROn
06-03-2009, 10:34
Спс за ссылку уще есть этот набор.. только я в Никсах не Шарю особо.. только начинаю разбираться если кто может закиньте и выложите заранее Благодарю...

http://wl500g.info/showpost.php?p=135241&postcount=730

GeoDen
06-03-2009, 13:58
http://wl500g.info/showpost.php?p=135241&postcount=730

не обясните Где этот мэйк найти и как его поменять я только учусь линуксу...

Пробывал Залить OpenWrt..
1) залилось нормально ( даже ВЕБ интерфейс есть )
2) настроил выход в нет через АДСЛ.. скачал пакеты...
3) в логе появилось хоть что то...
usb-ohci.c: USB OHCI at membase 0xb8003000, IRQ 6
usb-ohci.c: usb-00:03.0, PCI device 14e4:4716
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
uhci.c: USB Universal Host Controller Interface driver v1.1
usb-uhci.c: $Revision: 1.275 $ time 06:14:26 Jan 11 2009
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: registered new driver usblp
printer.c: v0.13: USB Printer Device Class driver
usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
device wl0 entered promiscuous mode
wl0: attempt to add interface with same source address.
br-lan: port 2(wl0) entering learning state
br-lan: port 2(wl0) entering forwarding state
br-lan: topology change detected, propagating
hub.c: Cannot enable port 2 of hub 1, disabling port.
hub.c: Maybe the USB cable is bad?
hub.c: new USB device 00:03.0-1, assigned address 2
usb.c: USB device not accepting new address=2 (error=-145)
hub.c: Cannot enable port 1 of hub 1, disabling port.
hub.c: Maybe the USB cable is bad?
hub.c: new USB device 00:03.0-1, assigned address 3
usb.c: USB device not accepting new address=3 (error=-145)
hub.c: new USB device 00:03.0-1, assigned address 4
usb.c: USB device not accepting new address=4 (error=-145)

больше ничего добиться не смог...

GeoDen
07-03-2009, 22:10
Вычитал что вроде нужен шнур USB 1.1 а если 2.0 то ошибки проверить не могу так как не имею 1.1 шнура и купить негде(((


Вычитал что вроде нужен шнур USB 1.1 а если 2.0 то ошибки проверить не могу так как не имею 1.1 шнура и купить негде(((
После некоторого танца с бубном... у меня обнаружился принтер...
HP 1018... Отобразился он в /dev/usb/lp0 но я не смог так настроить что бы он появился в сети... все остальное тикже не отображаеться...
Флэшка, Картридер, ХДД выдают -
hub.c: new USB device 00:03.0-1, assigned address 2
usb.c: USB device not accepting new address=2 (error=-145)
hub.c: new USB device 00:03.0-1, assigned address 3
usb.c: USB device not accepting new address=3 (error=-145)

После долгих мучений и экспериментов подключил ХДД, Кардридер и флэшку... только странно как то с портом где припаял 15кОМ не пашет ничего... если без резисторов работает но когда ему вздумаеться... в основном ошибка -145 либо что кабель поврежден... Кто нибудь отзавитесь...
Народные умельцы прошу вашей помощи...

GeoDen
23-07-2009, 09:28
Разобрался с поддержкой УСБ на этой тиочке но не доконца..
1) В прошивке необходим этот пакет kmod_usb_ohci
2) Нужно пропатчить ядро. Руки у меня кривые Линукс не знаю.. так что нужны шарящие люди.

http://www.heimpold.de/mhei/howto-asus-wl-320ge-usb.htm
А вот тут про патч
https://dev.openwrt.org/changeset/15807/trunk

YAG
21-09-2010, 14:52
С самых первых прошивок для WL-320gE невозможно изменить Operation Mode (Access Point по умолчанию не изменяется). Home Gateway работает только если прошицца прошивкой от Олега, там выбрать и потом накатить от энтузиастов и не сбрасывать в дефолт.
Второй момент это USB. Использую зверька как 3G-роутер. Для этого выпаял USB-порт, в который вставил HUAWEI E156G. USB удается запустить только подбрасыванием usb-ohci.o из пакета kmod-usb-ohci проекта openwrt. При этом модем удается завести. Но любая с ним манипуляция (выдергивание из порта, кнопка DISCONNECT, перевод в режим модема usb_switchmode, и т.д.) вызывает

Sep 21 16:49:19 kernel: Unable to handle kernel paging request at virtual address 00000008, epc == c01af3d4, ra == c01af3d4
Sep 21 16:49:19 kernel: Oops in fault.c::do_page_fault, line 206:
Sep 21 16:49:19 kernel: $0 : 00000000 1000dc00 00000000 00000002 80842840 c01b0000 806bddf4 fffffffe
Sep 21 16:49:19 kernel: $8 : 806bdfe0 0000dc00 00000000 80206000 00000000 00000000 00000000 00000000
Sep 21 16:49:19 kernel: $16: 00000000 80745080 80c5a000 80745000 807734a0 c01b0000 00000000 807734a0
Sep 21 16:49:19 kernel: $24: 00000000 80010374 806bc000 806bde10 00453a68 c01af3d4
Sep 21 16:49:19 kernel: Hi : 00000000
Sep 21 16:49:19 kernel: Lo : 00000024
Sep 21 16:49:19 kernel: epc : c01af3d4 Tainted: P
Sep 21 16:49:19 kernel: Status: 1000dc03
Sep 21 16:49:19 kernel: Cause : 00000008
С прошивкой openwrt так не происходит. Правда там есть свои существенные нюансы и неудобства.

lly
21-09-2010, 15:02
С самых первых прошивок для WL-320gE невозможно изменить Operation Mode (Access Point по умолчанию не изменяется). Home Gateway работает только если прошицца прошивкой от Олега, там выбрать и потом накатить от энтузиастов и не сбрасывать в дефолт.
Такой модели никто не тестировал, посмотрим. Можно уточнить - не сохраняется выбор или не даёт выбрать "Home Gateway"?


Второй момент это USB. Использую зверька как 3G-роутер. Для этого выпаял USB-порт, в который вставил HUAWEI E156G. USB удается запустить только подбрасыванием usb-ohci.o из пакета kmod-usb-ohci проекта openwrt.
В Олеговской 10.7 USB работает? usb-ohci в списке загруженных модулей есть? syslog или вывод dmesg где?

P.S. С модулем от чужого ядра и должны происходить чудеса.

YAG
21-09-2010, 15:13
1. Не сохраняется выбор.
2. В Олеговской USB тоже не работает.
usb-ohci в прошивке нет в принципе. Ни у Олега, ни у Вас.

[admin@WL-320gE root]$ ls /lib/modules/2.4.37.9
acm.o ipt_TOS.o option.o
audio.o ipt_TTL.o ov511_decomp.o
et.o ipt_ULOG.o ov518_decomp.o
ftdi_sio.o ipt_condition.o ov51x.o
imq.o ipt_length.o pl2303.o
ip6_conntrack.o ipt_multiport.o printer.o
ip6t_IMQ.o ipt_nth.o pwc.o
ip6t_TCPMSS.o ipt_psd.o pwcx.o
ip6t_condition.o ipt_quota.o scsi_mod.o
ip6t_length.o ipt_random.o sd_mod.o
ip6t_multiport.o ipt_recent.o soundcore.o
ip6t_state.o ipt_string.o sunrpc.o
ip_conntrack_ftp.o ipt_tos.o tun.o
ip_nat_ftp.o ipt_ttl.o usb-storage.o
ipt_CLASSIFY.o ipt_webstr.o usbcore.o
ipt_IMQ.o lockd.o usbserial.o
ipt_MIRROR.o nfs.o videodev.o
ipt_NETMAP.o nfsd.o wl.o
ipt_TARPIT.o nls_cp950.o


Jan 1 03:00:01 syslogd started: BusyBox v1.16.2
Jan 1 03:00:01 kernel: klogd started: BusyBox v1.16.2 (2010-07-23 17:30:33 MSD)
Jan 1 03:00:01 kernel: CPU revision is: 00029008
Jan 1 03:00:01 kernel: Primary instruction cache 16kB, physically tagged, 2-way, linesize 16 bytes.
Jan 1 03:00:01 kernel: Primary data cache 8kB, 2-way, linesize 16 bytes.
Jan 1 03:00:01 kernel: Linux version 2.4.37.9 (root@localhost) (gcc version 3.4.6) #1 2010-07-23 17:34:26 MSD
Jan 1 03:00:01 kernel: Setting the PFC to its default value
Jan 1 03:00:01 kernel: Determined physical RAM map:
Jan 1 03:00:01 kernel: memory: 01000000 @ 00000000 (usable)
Jan 1 03:00:01 kernel: On node 0 totalpages: 4096
Jan 1 03:00:01 kernel: zone(0): 4096 pages.
Jan 1 03:00:01 kernel: zone(1): 0 pages.
Jan 1 03:00:01 kernel: Amd/Fujitsu Extended Query Table v1.1 at 0x0040
Jan 1 03:00:01 kernel: Flash Id: Vendor: 0x00c2 Device: 0x00a8
Jan 1 03:00:01 kernel: number of CFI chips: 1
Jan 1 03:00:01 kernel: cfi_cmdset_0002: Disabling fast programming due to code brokenness.
Jan 1 03:00:01 kernel: Flash device: 0x400000 at 0x1c000000
Jan 1 03:00:01 kernel: Physically mapped flash: squashfs filesystem found at block 789
Jan 1 03:00:01 kernel: Creating 5 MTD partitions on "Physically mapped flash":
Jan 1 03:00:01 kernel: 0x00000000-0x00020000 : "boot"
Jan 1 03:00:01 kernel: 0x00020000-0x003f0000 : "linux"
Jan 1 03:00:02 dropbear[41]: Running in background
Jan 1 03:00:02 dnsmasq[52]: started, version 2.55 cachesize 512
Jan 1 03:00:02 dnsmasq[52]: compile time options: IPv6 GNU-getopt no-RTC no-DBus no-I18N DHCP no-scripts no-TFTP
Jan 1 03:00:02 dnsmasq-dhcp[52]: DHCP, IP range 192.168.1.2 -- 192.168.1.254, lease time 1d
Jan 1 03:00:02 dnsmasq[52]: read /etc/hosts - 3 addresses
Jan 1 03:00:02 dnsmasq-dhcp[52]: read /etc/ethers - 1 addresses
Jan 1 03:00:02 kernel: usb.c: registered new driver usbdevfs
Jan 1 03:00:02 kernel: usb.c: registered new driver hub
Jan 1 03:00:02 kernel: usb.c: registered new driver usblp
Jan 1 03:00:02 kernel: printer.c: v0.13: USB Printer Device Class driver
Jan 1 03:00:03 kernel: usb.c: registered new driver audio
Jan 1 03:00:03 kernel: audio.c: v1.0.1:USB Audio Class driver
А так лог продолжается после подсовывания usb-ohci.o из openwrt

Jan 1 03:00:03 kernel: usb-ohci.c: USB OHCI at membase 0xb8003000, IRQ 6
Jan 1 03:00:03 kernel: usb-ohci.c: usb-00:03.0, PCI device 14e4:4716
Jan 1 03:00:03 kernel: usb.c: new USB bus registered, assigned bus number 1
Jan 1 03:00:04 kernel: hub.c: USB hub found
Jan 1 03:00:04 kernel: hub.c: 2 ports detected
Jan 1 03:00:04 kernel: hub.c: new USB device 00:03.0-2, assigned address 2
Jan 1 03:00:04 kernel: usb.c: USB device 2 (vend/prod 0x12d1/0x1001) is not claimed by any active driver.
Jan 1 03:00:14 kernel: usb.c: registered new driver acm
Jan 1 03:00:14 kernel: acm.c: v0.23:USB Abstract Control Model driver for USB modems and ISDN adapters (patched)
Jan 1 03:00:14 kernel: usb.c: registered new driver serial
Jan 1 03:00:14 kernel: usbserial.c: USB Serial support registered for Generic
Jan 1 03:00:14 kernel: usbserial.c: Generic converter detected
Jan 1 03:00:14 kernel: usbserial.c: Generic converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
Jan 1 03:00:14 kernel: usbserial.c: Generic converter detected
Jan 1 03:00:14 kernel: usbserial.c: Generic converter now attached to ttyUSB1 (or usb/tts/1 for devfs)
Jan 1 03:00:14 kernel: usbserial.c: Generic converter detected
Jan 1 03:00:14 kernel: usbserial.c: Generic converter now attached to ttyUSB2 (or usb/tts/2 for devfs)
Jan 1 03:00:14 kernel: usbserial.c: USB Serial Driver core v1.4

YAG
21-09-2010, 15:38
Упс... Только щас почему-то обратил внимание на modules-1.9.2.7-d-r1825.tgz на Вашем сайте. Подбросил оттуда usb-ohci.o и все конечно же заработало нормально. Может воткнуть его в прошивку для WL-320gE?
Еще один маленький нюанс. Если WAN - 3G-модем, то при DISCONNECT все равно происходит port 3(eth0) entering disabled state. Т.е. ethernet-порт отрубается. В общем-то не критично (легко лечится), но тем не менее не целесообразно. Да и если уж в веб-морде нет multiWAN, то считаю целесообразным в режиме WAN - 3G Modem brctl addif br0 eth0.

lly
21-09-2010, 19:04
Упс... Только щас почему-то обратил внимание на modules-1.9.2.7-d-r1825.tgz на Вашем сайте. Подбросил оттуда usb-ohci.o и все конечно же заработало нормально. Может воткнуть его в прошивку для WL-320gE?
В WL-320gE usb нет штатно, соответственно для основной массы народа будет болтаться лишний модуль. А кто сумел допаять, сумеет и модуль подкинуть :)

GeoDen
29-01-2012, 17:43
Упс... Только щас почему-то обратил внимание на modules-1.9.2.7-d-r1825.tgz на Вашем сайте. Подбросил оттуда usb-ohci.o и все конечно же заработало нормально. Может воткнуть его в прошивку для WL-320gE?
Еще один маленький нюанс. Если WAN - 3G-модем, то при DISCONNECT все равно происходит port 3(eth0) entering disabled state. Т.е. ethernet-порт отрубается. В общем-то не критично (легко лечится), но тем не менее не целесообразно. Да и если уж в веб-морде нет multiWAN, то считаю целесообразным в режиме WAN - 3G Modem brctl addif br0 eth0.

не подскажите как вы подкинули модуль? ведь файловая система доступна только для чтения((

1) закинул usb-ohci.o в /tmp/local/root/lib/modules
2)
flashfs save && flashfs commit && flashfs enable && reboot
insmod usb-ohci.o
3) после перезагрузке нужно опять вручную подгружать модуль.
как сделать что бы грузился сам?

Модифицировал прошивку WL320gE-1.9.2.7-d-r2624.trx
теперь все работает и не нужно ничего выдумывать просто шьемся и все... Вложить сюда не смог. кому надо пишите пришлю.

gennady86
21-06-2013, 19:06
Доброго времени суток. Есть старый добрый роутер Wl-320ge. Хорошо он работает и жаль его просто выкинуть. Т.к много мотаюсь по работе он был бы очень полезен умев раздавать WiFi с 3G. Как оказалось есть у него USB порты, нужно просто правильно распаять концы. С этим проблем не возникло. А вот сделать прошивку с поддержкой данной связки - возникли сложности. В прошивке WL320gE-1.9.2.7-d-r2624.trx как оказалось есть доступ к настройкам с web морды. Но после прочтения темы http://wl500g.info/showthread.php?7110-WL-320gE-550gE-%EF%EE%E4%EA%EB%FE%F7%E5%ED%E8%E5-USB-%EF%EE%F0%F2%EE%E2/page3&, выснилось что в данной прошивке нет модулей usb-ohci.o и usb-uhci.o. Поэтому модем и HDD не работают.
Огромная просьба - встроить в данную прошивку указанные модули.

С уважением!!

MercuryV
21-06-2013, 21:09
В прошивке WL320gE-1.9.2.7-d-r2624.trx ... нет модулей usb-ohci.o и usb-uhci.o
Скомилированные модули для этой прошивки можете взять отсюда (https://code.google.com/p/wl500g/downloads/detail?name=modules-1.9.2.7-d-r2624.tgz&can=2&q=) и подложить на устройство.
А насчет "встроить в прошивку" - я бы не рассчитывал на помощь. Развитие ветки -d приостановлено свыше двух лет назад. Правда всегда есть вариант заняться самосбором (https://code.google.com/p/wl500g/wiki/CompilingCustomFirmware24).

gennady86
21-06-2013, 21:24
Скомилированные модули для этой прошивки можете взять отсюда (https://code.google.com/p/wl500g/downloads/detail?name=modules-1.9.2.7-d-r2624.tgz&can=2&q=) и подложить на устройство.
А насчет "встроить в прошивку" - я бы не рассчитывал на помощь. Развитие ветки -d приостановлено свыше двух лет назад. Правда всегда есть вариант заняться самосбором (https://code.google.com/p/wl500g/wiki/CompilingCustomFirmware24).


Так если бы смог собрать прошивку, вопросов бы не задавал тут. Не я один буду благодарен за встроенный модуль в эту прошивку.

ConstAntz
22-06-2013, 17:21
Так если бы смог собрать прошивку, вопросов бы не задавал тут. Не я один буду благодарен за встроенный модуль в эту прошивку.

Информацию о том, как прибить свой роутер, можно собрать по крупицам из моей подписи. всё самое необходимое: тут (http://gfile.ru/a1fIb) и здесь (http://gfile.ru/aXwL). Получиться почти n-16, тока без 5МГц вайфая.
Всё-же, сперва, лучше воспользоваться советами MercuryV. Это поможет воздержаться от создания новых тем типа: как восстановить его работоспособность.

GeoDen
15-02-2014, 09:20
Давно не заглядывал сюда.
Могу попробовать выложить сюда прошивку на основе Олега с модулями USB.

Думаю модератор не расстроится и поймет меня. Т.к. распаять USB дело не тяжелое,
а вот разгребать настройки линукса это АД. я потратил около 2х недель пока смог
собрать рабочую прошивку. а тут раз и про шились и все работает. ну вообщем ВОТ:

9783
9784
9785
9786