PDA

Bekijk de volledige versie : wl500g no longer wants to mount usb stick



Control
14-11-2006, 19:41
I've run into a major problem. This afternoon, I could suddenly no longer log into my wl500g with the normal user account, only admin login still worked. Mount showed me that apparently the usb-stick with the additional system files wasn't mounted.
I rebooted the wl500g several times, whihc usually brings it up as it should be, with
mount /dev/discs/disc0/part1 /opt/
and the like. No joy. I tried manually mounting the drive, and it claims /dev/discs doesn't exist.

Apparently, the driver isn't being loaded. dmesg returns this after removing and inserting the stick:

usb.c: USB disconnect on device 01:02.2-1 address 2
hub.c: new USB device 01:02.2-1, assigned address 3
usb.c: USB device 3 (vend/prod 0x13fe/0x1a00) is not claimed by any active driver.

Looking through the system logfile after reboot turned up this

Jan 1 01:00:05 kernel: FAT: bogus logical sector size 22528
Jan 1 01:00:05 kernel: FAT: bogus logical sector size 22528

Does that mean that maybe my usb stick is corrupted? Maybe a reformat would help.

Has anyone seen this behaviour before?

Tamadite
15-11-2006, 18:51
Have you tried what I have already tried to see if it helps?

http://www.wl500g.info/showthread.php?t=6563

Control
15-11-2006, 19:51
I think so, I've rebooted numerous times, I've power cycled the router. I have also reformatted the USB stick after backing up the filesystem on it, just in case. Makes no difference. I've also copied the entire contents of the stick to another usb drive, and it makes no difference.

The router simply doesn't seem to be loading the usb drivers. This leads to no driver claiming the stick (which is being identified correctly), and thus no /dev/drives/. That means no mounting.

Do you have any other suggestions? Have you solved your problem meanwhile?

I'm currently thinking of resetting the wl500g to factory defaults, formatting the stick and starting over from scratch. But I'd rather spend my weekend on more pleasant pasttimes if at all possible.

Control
15-11-2006, 21:24
Stop the presses, I'm an idiot!

Somehow I managed to turn off the 'FTP Server' Option in the USB-Application Menu in the web config manager. Stupid stupid stupid me. /dev/discs/ is only used when stupid-ftp is enabled.

Now everything works again.

Thanks for the help everyone.