Bekijk de volledige versie : VSFTPD is not working ! need help

11-11-2006, 11:59
have done all the guide said, here and madcast , but get error :
I get this error when i try connect ::

Connected to
500 OOPS: vsftpd: cannot locate user specified in 'ftp_username':ftp
Connection closed by remote host.

I have add users , admin works , share works via ssl but no ftp
I now that from http://www.nslu2-linux.org/wiki/Unslung/Vsftpdthat

* Problem: When trying to ftp into the slug, it gives a message 500 OOPS: vsftpd: cannot locate user specified in 'ftp_username':ftp""

Solution: Change the echo line in /unslung/rc.xinetd to: echo "ftp stream tcp nowait root /opt/sbin/vsftpd /opt/etc/vsftpd.conf" >>/etc/inetd.conf
But how we do in a WL500GP ?! there is no /unslung/rc.xinetd ... help please
:confused: :confused:

12-11-2006, 08:24
add user ftp to /etc/passwd. For example with:
echo "ftp:x:99:99:nobody:/:/sbin/nologin" >> /etc/passwd

13-11-2006, 23:28
add user ftp to /etc/passwd. For example with:
echo "ftp:x:99:99:nobody:/:/sbin/nologin" > /etc/passwd

Thanks Oleg
I got problems now, I cant login because user admin dose not accept passwrod admin anymore .

login as: admin
admin@'s password:
Access denied
admin@'s password:

My Samba share dosnt work and ... not the ftp .. i got thi in web iterface

Dec 31 13:00:09 xinetd[146]: Unknown user: admin [file=/opt/etc/xinetd.d/vsftp] [line=7]
Dec 31 13:00:09 xinetd[146]: Error parsing attribute user - DISABLING SERVICE [file=/opt/etc/xinetd.d/vsftp] [line=7]
Dec 31 13:00:09 xinetd[146]: 146 {init_services} no services. Exiting...
Dec 31 13:00:11 kernel: HTB: quantum of class 10117 is big. Consider r2q change.
Dec 31 13:00:12 kernel: HTB init, kernel part version 3.16


14-11-2006, 19:10
I reflashed router and installed all programs again
now vsftpd works i steel dont have ftp as user but i will maybe

more editing
I have ftp as user now
i hade enabled the (user_local=yes ) then i didnt need to have ftp , but to have anonymous access i needed the ftp (standard ) or another that will bo in 'ftp_username' as anonymous user ...

Yes MMCM it vas problem whith > ;)
but i am a new linux user, all i can i learnd by Wl-500gp :eek:

15-11-2006, 11:12
add user ftp to /etc/passwd. For example with:
echo "ftp:x:99:99:nobody:/:/sbin/nologin" > /etc/passwd


No wonder sivan_ms could not login with admin anymore, since he did overwrite the original passwd file with your command :-(

Use ">>" instead of ">" to append text!

18-11-2006, 13:11
Hi again
VSFTPD works in LAN i have enabled anonymous access because i need to stream video ( i use VLC media player) it works fine inside LAN
- I have anonymous access to my ftp from LAN whit IS , Firefox , CMD , Smartftp , VLC mm
- I have anonymous access just via CMD and Smartftp from WAN !no access by IE , Firefox , VLC mm
- when i use www.web2ftp.com/ it has access too

i can a lot now about vsftpd.conf and other stuffs in VSFTPD but steel cant understand why ?
Am i missing something .... ??

Is there any good media server who can stream my files to a PC outside LAN also the WAN ?