PDA

Bekijk de volledige versie : Need help! Azureus - lost connection to service



ki_cz
05-11-2006, 11:07
I've seen this problem on the forums before, but none of the solutions have actually fixed my problem.

If I leave azureus on overnight, I come back to it with the message "UPNP: Lost connection to service" appearing about 100 times. This seems to have affected my download speeds, as well as being extremely annoying.

I have tried opening some ports in the Virtual Server, with it being no help whatsoever.

I am using firmware 1.9.2.7-7e ...

Is there a firmware that I should rollback to in order to solve this problem? In order to rollback to a firmware, are there any specific steps I should take?

Thanks for any help!!!

ki_cz
06-11-2006, 18:12
Ok, I have disabled upnp in azureus and the message has now gone away. I also opened up the ports that I was using in azureus.

Unfortunately my downloads are definitely going far slower through the router than through the modem by itself ... can anybody please let me know how to speed them up back to normal???

I have followed the instructions at the portforward website but am still not getting beyond 30kb/s of speed, which is really annoying.

I'm getting the Firewall/NAT (TCP) reachability problem red button at the bottom of Azureus as well ...

help ... please??? I'm on port 49725 as well ...

Tamadite
06-11-2006, 19:18
Most probably you can find the reason here...

"...no peer-to-peer connections can be established if firewall is detected." More info at: http://www.wl500g.info/showthread.php?p=7393&mode=threaded#post7393

PS: It does not apply to MSN Messenger only

ki_cz
07-11-2006, 12:42
Most probably you can find the reason here...

"...no peer-to-peer connections can be established if firewall is detected." More info at: http://www.wl500g.info/showthread.php?p=7393&mode=threaded#post7393

PS: It does not apply to MSN Messenger only

I unfortunately can't really decipher your post over there ... sorry, is there any way you could make it a bit more clear for me?

Tamadite
07-11-2006, 17:45
Many Internet services like MSN establish a peer-to-peer connection with remote hosts in order to exchange information (messages, files, etc). Nowadays and due to the proliferation of home routers, this sort of applications have adopted a new way of exchanging information with remote hosts. This comes from the fact that peer-to-peer doesn't work by default if firewalls are found in remote hosts (routers need to be configured to accept peer-to-peer traffic; this configuration is per application basis). When you activate UPnP, your application negotiates with your router which ports should be opened to proceed with a peer-to-peer connection. For some reason, it seems this option generates problems at your side; reasons could be many.

When you close UPnP and since no ports have been opened to establish peer-to-peer connections, your application may use of a third server somewhere in the Internet to send over the information to the intended final host. The presence of this 3rd partner in the picture is what makes you communication slower. Packets are firstly sent to the middle host and then resent to the intended recipient, most probably via port 80.

ki_cz
08-11-2006, 12:24
So then would you suggest opening port 80 on my router manually and leaving uPnp disabled? I'm just really disappointed in the speeds that I am getting for my azureus downloads. Soulseek is working fine though!

zerocrash
09-11-2006, 19:48
Hi there. (First of all - sorry my english really stinks but i hope you get the point... ;) )

At first - do you have Windows' XP firewall-feature turned ON?! If you do - turn it OFF!

Second - forward your Azureus listening port - 49725 UDP and TCP to your computer's IP-adress.

DO NOT SET THE PROTOCOL TO "BOTH" THEN YOU DO THIS! Quite important here! Make 2 forwards - one forward for 49725 TCP and so on for 49725 UDP also to your PC.

Your setup "Virtual Server" should look something like this then you've done that:
-----------------------------------------------
PORT- RANGE | LOCAL-IP | LOCAL-PORT | PROTOCOL | PROTOCOL no. | Description
49725 | IP-adress | 49725 | TCP | | Azureus
49725 | IP-adress | 49725 | UDP | | AzureusDHT
------------------------------------------------
Remember to set it up in azureus also ;)

And at last - Check these pages for more info on good speed and settings.
Increase Download Speed - http://www.azureuswiki.com/index.php/Increase_download_speed

Good Settings - http://www.azureuswiki.com/index.php/Good_settings

How to avoid traffic shaping - http://www.azureuswiki.com/index.php/Avoid_traffic_shaping

And tips and tricks for further questions - http://www.azureuswiki.com/index.php/Tips_and_tricks

Furthermore...

Have a NAT-problem? http://www.azureuswiki.com/index.php/NAT_problem

ki_cz
10-11-2006, 22:38
Thank you, I don't have the xp firewall enabled, but I do have the settings for the router set to "both" so I will change this and hopefully the speeds will improve!!

ki_cz
11-11-2006, 12:26
Tried the above settings, still getting the "firewalled" in Azureus.

The message states "Firewall/NAT (TCP) reachability problem" ... I'm not sure where to go from here, but am going to keep fooling around with it I guess ...

Also, I'm using the IP 192.168.1.102 ... is this the right one for setting up the virtual server?