Bekijk de volledige versie : Printer on Windows 98

25-09-2006, 23:58
Searched the forum, but didn't find anything, so I'm sry if this questions has been ask before...
How do I get my printer working on windows 98? It's connected to the usb port of my wl-500 premium... On xp it's the tcp thing, but how does it work on 98? Read something about remote printer, but I don't understand what that means :(

26-09-2006, 21:19
On win98? the TCP thing thru Remote POrt...

27-09-2006, 22:11
But how? :(
Whats the remote port?
Can u give me a step by step explanation how to do this? Would be really nice :)

Gerry Boland
30-09-2006, 00:00
I don't think this process is easy on Windows 98, since it does not have IP printing (aka Remote Port, aka TCP/IP) built in like 2000 or XP. But it's do-able!

The idea is this: your computer communicates with the printer through a 'Port', usually USB or Parallel or via your network (IP). Unfortunately Windows 98 was made before network printing was that common, so it doesn't give you this last option - the one you want!

At that time, to get around this problem, network printers came with special drivers that installed IP printing support in Windows. If any one driver added this feature, then all other printers could benefit from it too!

A utility that does this is available courtesy of HP, here:
It's called a "Standard Port Monitor" utility.

So first you need to run this installer. Just click through it, the defaults are fine.

If you don't have the Printer installed yet, do it now. Just install it as a normal USB printer as per usual. Now once you've done that, we're going to change its settings so that it uses a network port, not the USB. The procedure:

Start->Settings->Printers. Right-click on your printer, select 'Properties', click the 'Details' tab, click 'Add Port', select 'Other' and select 'HP TCP/IP network port'.

A Wizard will pop-up to guide you through this last bit, give the IP address of the router & call the Port Name some thing logical like TCP/IP. If your printer is on it should be happy. If it asks you for a "Device Type" just select Custom & click 'Settings'. In this window, click "LPR" as the Protocol & give the queue a name. Click ok & finish. Try & print!

That last bit was guessed at, so any problems get back to us!

02-10-2006, 18:15
Hey THANKS man!
That's it, it's working! :D :D :D
Thank you very much!