Bekijk de volledige versie : What's up with auto mount USB and stupid-ftpd ???

19-09-2006, 21:58
When I plug in a USB drive into my WL-500gP, it is automatically mounted to /tmp/harddrive and stupid-ftpd starts up. I'm sure that's desirable behavior for some people, but it's annoying to me.

How can I stop this behavior? I've read other posts of people trying to figure out how to disable stupid-ftpd. Killing the process is obviously one way of doing it, but I'd like a better solution. For one, even if I kill stupid-ftpd, if I unplug the USB drive and plug it back in, the drive is again automatically mounted and stupid-ftpd starts up again.

There must be some other process that's monitoring for USB devices and spawning stupid-ftpd - any idea which one?

/ # ps
PID Uid VmSize Stat Command
1 admin 660 S /sbin/init
2 admin SW [keventd]
3 admin SWN [ksoftirqd_CPU0]
4 admin SW [kswapd]
5 admin SW [bdflush]
6 admin SW [kupdated]
7 admin SW [mtdblockd]
90 admin 308 S telnetd
95 admin 388 S httpd vlan1
98 admin 396 S syslogd -m 0 -O /tmp/syslog.log -S -l 7
103 admin 364 S klogd
104 nobody 404 S dnsmasq
108 admin SW [khubd]
116 admin 276 S lpd
118 admin 260 S p9100d -f /dev/usb/lp0 0
121 admin 340 S waveservermain
123 admin 344 S rcamdmain
129 admin 424 S udhcpc -i vlan1 -p /var/run/udhcpc0.pid -s /tmp/udhcp
131 admin 320 S infosvr br0
132 admin 488 S watchdog
134 admin 340 S ntp
148 admin 436 S dropbear
149 admin 560 S /bin/sh
161 admin 448 S upnp -D -L br0 -W vlan1
163 admin SW [usb-storage-0]
164 admin SW [scsi_eh_0]
209 admin 404 S stupid-ftpd
213 admin 408 R ps

Don't suggest any of the processes that are surrounded by square brackets - none of those are killable.

BTW, my drives weren't auto mounted and I had never heard of stupid-ftpd before upgrading to the latest WL500gP firmware (ie.

07-10-2006, 14:30
Not sure about this but have you tried turning off ftp in the web options page.
Or alternatively kill the process, and save it using the below

flashfs save && flashfs commit && flashfs enable && reboot

It worked for me as I have ftpd-topfield running inplace of stupid-ftp.

Very new at this but this should work as far as I know,if not one of the experts might be able to give a more positive answer.


13-10-2006, 22:44
Thanks for the reply maniac_au.

I haven't tried disabling ftp in the web options page, but that probably would have worked.

Killing the stupid-ftpd process works, but like I said it would restart and automount my usb drive when I inserted it and I was looking for the process that was responsible for that. I ended up making a script that would kill a bunch of processes that seemed to be unnecessary for my setup, including "watchdog", which I think was the one that I found to be responsible for the automounting.

Killing the process and saving with flashfs save && flashfs commit, etc wouldn't work since the flashfs commands are just for saving things in the flash file system - it doesn't look at your list of running processes and do anything with that.