PDA

Bekijk de volledige versie : FTP problem, please help



vistac
04-09-2006, 18:57
Hello Sir,
I use the official Firmware(1.9.6.0), I disable Lan to Wan packet filter, and Enable Wan to Lan packet filter, only accept 443 inbound traffice, all other drop.
Now, my computer in the lan(172.17.2.99) when I ftp to the internet FTP(ftp.isu.edu.tw etc), I have alerady set my client to PASV mode, but I always hang at LIST, I tried ms ftp and FileZilla and lftp in linux, please kindly help me to solve this problem.
bleow is the log from FileZilla, and if u need sniffer to debug, I have already capture it, I can put it later.

Status: Connecting to ftp.redhat.com ...
Status: Connected with ftp.redhat.com. Waiting for welcome message...
Response: 220 Red Hat FTP server ready. All transfers are logged. (FTP) [no EPSV]
Command: USER anonymous
Response: 331 Please specify the password.
Command: PASS *****
Response: 230 Login successful.
Command: FEAT
Response: 211-Features:
Response: EPRT
Response: EPSV
Response: MDTM
Response: PASV
Response: REST STREAM
Response: SIZE
Response: TVFS
Response: 211 End
Command: SYST
Response: 215 UNIX Type: L8
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/"
Command: TYPE A
Response: 200 Switching to ASCII mode.
Command: PASV
Response: 227 Entering Passive Mode (66,187,224,30,50,23)
Command: LIST
Error: Transfer channel can't be opened.
Error: Could not retrieve directory listing

Oleg Bel
28-12-2007, 23:54
Change MTU size on your Ethernet interface at 1372 (decimal value).

Or read this Russian theme (http://wl500g.info/showthread.php?t=7212).

boardtc
23-06-2008, 23:46
I have a similar problem (same firmware) with my connecting to my host ftp but the LIST command timing out. I have read
http://www.ncftp.com/ncftpd/doc/misc/ftp_and_firewalls.html#FirewallTimeouts
and am using passive. I have not been able to find the MTU setting mentioned on my WL-500g deluxe.

I would really appreciate any help as I have been unable to connect now for a coulple of month, ever since I started using this router again, when my other one died.