PDA

Bekijk de volledige versie : torrent & ports



ros
16-07-2006, 00:55
Could someone please help...
I installed torrent, but there's no transfer.
current_error.log says:

Failed to transfer URL: could not connect (7)
Failed to transfer URL for reason 7 (see curl.h)

I opened incoming ports and defined a virtual server, but no luck...

oleo
16-07-2006, 19:35
look into /opt/etc/torrent.conf for TCP port range to open.

ros
16-07-2006, 20:51
this is the relevant part of torrent.conf:

# btget port range environment
BTLIB_MINPORT=56881
export BTLIB_MINPORT
BTLIB_MAXPORT=56889
export BTLIB_MAXPORT
#time between logs
LOG_TIME=59

this is my post-firewall:
#!/bin/sh
iptables -A INPUT -p tcp --syn --dport 22 -j ACCEPT
iptables -A INPUT -p tcp --syn --dport 56881:56889 -j ACCEPT

and virtual server setting is:
port range 56881:56889
local ip <LAN ip of the router>
protocol TCP
other fields are empty.

what could be wrong?

oleo
16-07-2006, 22:54
You do not need post-firewall script to forward ports.

I suggest that you try to enable stupid-ftpd server and try accessing ftp server from inernet. If this work, continue with torrent ports.

ros
17-07-2006, 16:54
I tryed it with port 22, ssh. It works fine.
And port 56881 is scanned as open from outside.
But I get those error messages again and again.

oleo
17-07-2006, 21:26
Try netstat -ln to see
tcp 0 0 0.0.0.0:56881 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:56882 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:56883 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:56884 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:56885 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:56886 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:56887 0.0.0.0:* LISTEN
when 7 torrent commands are issued.

Or enter ". /opt/etc/torrent.conf" (dot, space, /opt/etc/torrent.conf) and then issue btget something.torrent to see whats up.

ros
18-07-2006, 07:43
It works now.
I removed --syn parameter from iptables and added entry for open ports towards LAN interface.
Thanks.