PDA

Bekijk de volledige versie : Can't delete files running SAMBA on FAT32 USB2.0 HD



Tigerroad
15-07-2006, 23:40
I'm running firmware 1.9.2.7-7e on my Asus WL-500g deluxe which has a 250 GB maxtor USB2.0 drive connected to it. The drive is divided into two partitions both FAT32. One at 43 GB and the other around 190 GB all done using partion magic 8.
The samba settings in the firmware is set to:
Enable Samba Demo mode? Yes
Enable hidden read-write share? Yes

I have done the following using telnet (got it from this (http://wl500g.info/showthread.php?t=1984) post)

mkdir -p /usr/local/etc/dropbear
dropbearkey -t dss -f /usr/local/etc/dropbear/dropbear_dss_host_key
dropbearkey -t rsa -f /usr/local/etc/dropbear/dropbear_rsa_host_key
mkdir -p /usr/local/sbin/
echo "#!/bin/sh" >> /usr/local/sbin/post-boot
chmod +x /usr/local/sbin/post-boot
echo "dropbear" >> /usr/local/sbin/post-boot
dropbear

Then I'm using Putty to edit the /etc/smb.conf file and have the following written

[global]
interfaces = br0
bind interfaces only = yes
workgroup = ARBEJDSGRUPPE
guest account = nobody
security = share
browseable = yes
guest ok = yes
guest only = yes
log level = 1
max log size = 100
encrypt passwords = no
preserve case = yes
short preserve case = yes

[Share]
path = /tmp/harddisk
writeable = yes
force user = admin
browseable = yes

After editing the smb.conf file I run the following commands (not quite sure why think I'm saving the settings and of course rebooting the router)

echo /etc/smb.conf >> /usr/local/.files

echo "/usr/sbin/smbd -D" >> /usr/local/sbin/post-boot
echo "/usr/sbin/nmbd -D" >> /usr/local/sbin/post-boot

flashfs save
flashfs commit
flashfs enable
reboot

The Samba is working. I can acces files on the HD and I can even copy files to it. But I can't seem to delete files. Well I can delete a file go to the parent folder a back and the file will reappear in the folder. Any explanation to this problem ?

ros
18-07-2006, 12:14
I'm not sure, but it seem's a problem with fat32. I'm not sure it's officialy supporting such big partitions.
Try using NTFS or EXT3.