PDA

Bekijk de volledige versie : Unable to enter IP into WL-500g settings



bojansporar
01-06-2006, 18:36
Hi,

I have a huge problem with the WL-500g (Premium) WAN IP settings.

I have a broadband connection with a static IP of 84.255.XXX.XXX, subnet mask 255.255.XXX.XXX and default gateway 84.255.XXX.XXX. I cannot enter the static IP numerals into the WAN settings of the Asus router as the web browser settings open a window saying the IP is not valid. The IP-check algorithm (obviously embeded into the browser settings mechanism) does not allow for a 255 to be one of the four numbers that make up the whole IP (x.y.z.n). E.g., the router accepts a static ip entry of 254.254.xxx.xxx but does not accept a 84.255.xxx.xxx because of the 255. I found out that the problem lies in the 255 after having tried a few different IP numbers.

Does anyone have any ideas how to make my router properly connect to my VDSL static IP WAN connection? I already asked the ISP's technical help to change my IP, but their designated IP range lies in its entirety within the 84.255.xxx.xxx so they cannot do anything. Is there any possibilty to enter the settings of the router by logging (telnet) to it manualy and doing it via the command line?

Any ideas are appreciated, as otherwise the router is simply useless for me.

Many thanks,
Bojan

bojansporar
04-06-2006, 19:44
Ok, figured out how to get around this one on my own.

I entered an IP of 84.254.XXX.XXX into the settings. Save the settings (exported them) via the web interface into a .cfg file. Edited the .cfg file with a hex editor and changed the 254 into a 255 and my internet connection is working fine!

oleo
05-06-2006, 08:00
Even simpler. Disable javascript processing in browser.

bojansporar
23-09-2006, 19:26
A very good solution indeed, many thanks :D