PDA

Bekijk de volledige versie : let samba start on boot



MHz
23-05-2006, 08:02
hello,

I followed this (http://wl500g.info/showthread.php?t=1984) tutorial, but when I try to make sure samba is started whenever the router boots I get this error:


[admin@WareHouse root]$ echo "/usr/sbin/smbd -D" >> /usr/local/sbin/post-boot
-sh: cannot create /usr/local/sbin/post-boot: Directory nonexistent
[admin@WareHouse root]$ echo "/usr/sbin/nmbd -D" >> /usr/local/sbin/post-boot
-sh: cannot create /usr/local/sbin/post-boot: Directory nonexistent
[admin@WareHouse root]$



What's wrong?

Thanks,

PcExpert


By The Way, I had samba running, but I have resetted my router and from then on it didn't work anymore.

TheEagle
23-05-2006, 09:08
Isn't Samba run automatically if you enable it in Olegs firmware?

However, the answer to your question is in the error message

cannot create /usr/local/sbin/post-boot: Directory nonexistent


mkdir -p /usr/local/sbin

should help

MHz
23-05-2006, 15:30
Ít worked, the directories are now created, but samba still doesn't work.

Please help

Styno
24-05-2006, 09:44
Put all harddisk related commands in post-mount script.

MHz
24-05-2006, 20:34
Thanks, but how to do that?

MHz
29-05-2006, 09:47
please someone