PDA

Bekijk de volledige versie : Can someone have a look at my samba settings?



Control
30-04-2006, 16:48
I've reached the point where I simply don't know why this isn't working.

I have a wl-500gx, with Olegs 1.9.2.7-7c Firmware. Further, there's a 250GB iomega USB 2.0 HDD attached to one of the two USB ports with a 30GB FAT partition on it, currently mounted as /tmp/harddisk/ on the wl-500gx.
A SuSE Linux Laptop and a WinXP laptop complete the setup. I can access the HD from the Linux Laptop via NFS, no problems. But from the Windows laptop: I tried entering \\192.168.1.254 in the explorer adress bar, which results in a 'network path not found' message. The same when I try to mount it as a network drive, even when supplying the admin login and password.

My /etc/smb.conf file looks like this:

[global]
workgroup = MOLPHNET
guest account = nobody
security = share
browseable = yes
guest ok = yes
guest only = no
log level = 1
max log size = 100
encrypt passwords = no
dns proxy = no
[fat32]
path=/tmp/harddisk
writeable = yes
browseable = yes
force user = admin

with MOLPHNET (all caps) being the workgroup name the WinXP laptop belongs to.

In my /usr/local/sbin/post-boot, I have the following lines:

/usr/sbin/smbd -D
/usr/sbin/nmbd -D

The web interface of the wl500gx for USB --> samba is set to

Samba Demo Mode: No
Hiden read/write: Yes
Workgroup name: MOLPHNET


What else is there that I could be doing wrong?

Btw: when I do 'ps -a | grep smb' there's no smb-daemon showing up, same applies for nmb. This might be important.

Control
30-04-2006, 18:50
I found it.
samba needs a hostname to be defined in the LAN IP settings page. Listing an alternative hostname for the localhost in /etc/hosts isn't enough.

Now it works!