PDA

Bekijk de volledige versie : Samba config won't save



MHz
26-04-2006, 19:40
Hello, I followed this (http://wl500g.info/showthread.php?t=1984) tutorial (Only the samba instructions), but if I save my config by first pressing the ESC button and then type :w it won't save This is what I have also tried:




ESC button and then type :w
flashfs save
flashfs commit
flashfs enable

(If I reboot the changes are lost)

By the way, I'm using Oleg Firmware: 1.9.2.7-7c

Ade
27-04-2006, 20:31
You need to use the following command :-

echo /etc/smb.conf >> /usr/local/.files

before flashfs save. This adds the samba config file to the list of files that are saved. This is given as part of the set up instructions you were using but it's not explained very well.

MHz
28-04-2006, 11:48
Thanks Ade, for your help

MHz
28-04-2006, 15:53
Hello,

Now the config saved successful, but how can I access a share? I haven't created a share yet. (that I know) Samba is NOT anymore in demo mode. Tried it just a minute ago, but when I type in: \\192.168.1.1 there's a message saying that it couldn't find the server, whats wrong? Or do I have to shutdown the FTP Server? I have done this to make sure SAMBA is running:


echo "/usr/sbin/smbd -D" >> /usr/local/sbin/post-boot
echo "/usr/sbin/nmbd -D" >> /usr/local/sbin/post-boot

And then I did this:


flashfs save
flashfs commit
flashfs enable
reboot

And I have created a share:


[user1]
path=/tmp/harddisk
writeable = yes
browseable = yes
force user = admin

MHz
29-04-2006, 14:04
How to create a new share? Please read my previous post for more questions regarding SAMBA.