PDA

Bekijk de volledige versie : fdiks Problem: "writing inode tables - Terminating



colalight890
11-01-2006, 10:36
Hallo together,
I bought a new 250GB HD, but now I'm not able to format the partition. Partitions with size 80GB are working, bigger sizes getting "writing inodes tabels: Terminating"

[admin@Asus root]$ fdisk /dev/discs/disc0/disc

The number of cylinders for this disk is set to 30515.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
(e.g., DOS FDISK, OS/2 FDISK)

Command (m for help):
Command (m for help): d
No partition is defined yet!

Command (m for help): n
Command action
e extended
p primary partition (1-4)
p
Partition number (1-4): 1
First cylinder (1-30515, default 1):
Using default value 1
Last cylinder or +size or +sizeM or +sizeK (1-30515, default 30515): +240000M

Command (m for help):
Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.
Syncing disks.
[admin@Asus root]$
[admin@Asus root]$ mke2fs -j /dev/discs/disc0/part1
mke2fs 1.35 (28-Feb-2004)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
29310976 inodes, 58595071 blocks
2929753 blocks (5.00%) reserved for the super user
First data block=0
1789 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424, 20480000, 23887872

Writing inode tables: Terminated

[admin@Asus root]$
[admin@Asus root]$
[admin@Asus root]$ df -k
Filesystem 1k-blocks Used Available Use% Mounted on
/dev/root 3008 3008 0 100% /
[admin@Asus root]$
[admin@Asus root]$
[admin@Asus root]$ mount
/dev/root on / type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
ramfs on /tmp type ramfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
[admin@Asus root]$

Viele Gre / Franz

Oleg
11-01-2006, 10:52
You've to enable swap first, as writing an inode table requires much memory.

colalight890
11-01-2006, 11:00
I'm not able to mount the swap partition !


[admin@Asus root]$ swapon /dev/discs/disc0/part2
swapon: /dev/discs/disc0/part2: Invalid argument


[admin@Asus root]$
[admin@Asus root]$
[admin@Asus root]$ fdisk /dev/discs/disc0/disc

The number of cylinders for this disk is set to 30515.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
(e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/discs/disc0/disc: 251.0 GB, 251000193024 bytes
255 heads, 63 sectors/track, 30515 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/discs/disc0/part1 1 27964 224620798+ 83 Linux
/dev/discs/disc0/part2 27965 30515 20490907+ 82 Linux swap

Command (m for help):

colalight890
11-01-2006, 11:23
FIXED => Swap Partition was the winner !!!!! Many, many thanks