PDA

Bekijk de volledige versie : FTP Server & german "Umlaute"



nteichma
21-11-2005, 16:08
Hello,
i have a problem with the ftp server functionality.
i am a german and want to use WAN ftp server functionality
i use olegs firmware version 1.9.2.7-6b on asus WL-HDD --- thank you very much oleg for thatgreat working stuff ----
i read a lot of threads about codepages and samba server but i did not found the solution for me

here is my problem samba is working fine and all "umlaute - " are shown correct. but when i log in via internet explorer these umlaute are not shown correctly ... i tried several different settings but none of them worked ...
sometimes there are shown special signs as sometimes questionmarks, sometimes long names are shortened

i tried the following:

nvram set usb_vfat_options=codepage=850,iocharset=cpISO8859-1
nvram set usb_smbcpage_x=850
nvram set usb_smbcset_x=ISO8859-1
nvram commit
reboot

nvram set usb_vfat_options=codepage=950,iocharset=cpISO8859-1
nvram set usb_smbcpage_x=950
nvram set usb_smbcset_x=ISO8859-1
nvram commit
reboot

nvram set usb_vfat_options=codepage=850,iocharset=cp1251
nvram set usb_smbcpage_x=850
nvram set usb_smbcset_x=1251
nvram commit
reboot

nvram set usb_vfat_options=codepage=850,iocharset=cp850
nvram set usb_smbcpage_x=850
nvram set usb_smbcset_x=850
nvram commit
reboot

...

unfortunately none of my tries worked ... the access to the ftp server works fine but the problem is only with the shown umlaute-
i would be very thankfull for anyones help

thanks in advance

norbert

P.S. i am a linux dummy ...

rgerm
09-05-2006, 01:14
Hi,

does somebody found a solution for this in the meantime ?
I have the same issue, the Samba server is working fine with the German codepage () but if I want to connet my USB-HD as a FTP drive to my WL-HDD then Linux isn't able to handle this files with German 'Umlaute'.

I want to copy files from the FTP drive to the HD and this is not possible.:mad:

Thanks in advance.
Ricky