PDA

Bekijk de volledige versie : CDMA модем JOA Telecom LM-700R и WL-500gP



rollon
17-12-2010, 13:25
Удалось убрать запуск c CD у этого модема.

Вот usb_modeswitch.conf

DefaultVendor= 0x198a
DefaultProduct=0x0003

TargetVendor= 0x198a
TargetProduct= 0x0003

CheckSuccess=20

MessageContent="5553424312345678000000000000061b000000020000000000 000000000000"

rss
17-12-2010, 17:33
Удалось убрать запуск c CD у этого модема.

Вот usb_modeswitch.conf

DefaultVendor= 0x198a
DefaultProduct=0x0003

TargetVendor= 0x198a
TargetProduct= 0x0003

CheckSuccess=20

MessageContent="5553424312345678000000000000061b000000020000000000 000000000000"

Замечательно. На http://draisberghof.de/usb_modeswitch/bb/ сообщение размещено?

rollon
17-12-2010, 19:13
Замечательно. На http://draisberghof.de/usb_modeswitch/bb/ сообщение размещено?

Не размещал.

krasnoglazik
13-07-2012, 14:32
Пытаюсь подружить Asus wl500gpv2 и JOA Telecom LM-700r (skylink).
Ставил и прошивку от олега и чешскую прошивку (http://koppel.cz/cdmawifi/download/171/)
Вбивал различные настройки, прописывал вручную файл usb_modeswitch.conf, ничего не работает.
Нашел "настройки"
# LM-700r, JOA Telecom CO., LTD

DefaultVendor= 0x198a
DefaultProduct=0x0003

TargetVendor= 0x198a
TargetProduct=0x0002

MessageEndpoint = 0x08

MessageContent="55534243c889458a000000000000061b000000020000000000 000000000000"
их по разному вручную прописывал, всячески эксперементировал
прошивка от олега определяет модем как 198a:0002, но не хочет с ним работать
что делать как настраивать совершенно не понимаю, перерыл кучу информации, ничего не работает
Жду совета.

dlukanidin
13-07-2012, 23:37
Пытаюсь подружить Asus wl500gpv2 и JOA Telecom LM-700r (skylink).
Ставил и прошивку от олега и чешскую прошивку (http://koppel.cz/cdmawifi/download/171/)
Вбивал различные настройки, прописывал вручную файл usb_modeswitch.conf, ничего не работает.
Нашел "настройки"
# LM-700r, JOA Telecom CO., LTD

DefaultVendor= 0x198a
DefaultProduct=0x0003

TargetVendor= 0x198a
TargetProduct=0x0002

MessageEndpoint = 0x08

MessageContent="55534243c889458a000000000000061b000000020000000000 000000000000"
их по разному вручную прописывал, всячески эксперементировал
прошивка от олега определяет модем как 198a:0002, но не хочет с ним работать
что делать как настраивать совершенно не понимаю, перерыл кучу информации, ничего не работает
Жду совета.

для начала дайте полную инфо - syslog, diagnostic info , nvram show | grep modem

krasnoglazik
14-07-2012, 12:13
для начала дайте полную инфо - syslog, diagnostic info , nvram show | grep modem

syslog

jan 1 00:00:04 kernel: usb.c: registered new driver usbdevfs
Jan 1 00:00:04 kernel: usb.c: registered new driver hub
Jan 1 00:00:04 kernel: usb-ohci.c: USB OHCI at membase 0xb8003000, IRQ 6
Jan 1 00:00:04 kernel: usb-ohci.c: usb-00:03.0, PCI device 14e4:471a
Jan 1 00:00:05 kernel: usb.c: new USB bus registered, assigned bus number 1
Jan 1 00:00:05 kernel: Product: USB OHCI Root Hub
Jan 1 00:00:05 kernel: SerialNumber: b8003000
Jan 1 00:00:05 kernel: hub.c: USB hub found
Jan 1 00:00:05 kernel: hub.c: 2 ports detected
Jan 1 00:00:05 kernel: hub.c: new USB device 00:03.0-1, assigned address 2
Jan 1 00:00:05 kernel: hub.c: USB hub found
Jan 1 00:00:05 kernel: hub.c: 2 ports detected
Jan 1 00:00:06 kernel: hub.c: new USB device 00:03.0-1.1, assigned address 3
Jan 1 00:00:06 kernel: Manufacturer: Modmen Corporation
Jan 1 00:00:06 kernel: Product: MM450 MassStorage
Jan 1 00:00:06 kernel: SerialNumber: 000001640002
Jan 1 00:00:06 kernel: usb.c: USB device 3 (vend/prod 0x198a/0x3) is not claimed by any active driver.
Jan 1 00:00:06 kernel: Length = 18
Jan 1 00:00:06 kernel: DescriptorType = 01
Jan 1 00:00:06 kernel: USB version = 1.10
Jan 1 00:00:06 kernel: Vendor:Product = 198a:0003
Jan 1 00:00:06 kernel: MaxPacketSize0 = 64
Jan 1 00:00:06 kernel: NumConfigurations = 1
Jan 1 00:00:06 kernel: Device version = 0.00
Jan 1 00:00:06 kernel: Device Class:SubClass:Protocol = 00:00:00
Jan 1 00:00:06 kernel: Per-interface classes
Jan 1 00:00:06 kernel: Configuration:
Jan 1 00:00:06 kernel: bLength = 9
Jan 1 00:00:06 kernel: bDescriptorType = 02
Jan 1 00:00:06 kernel: wTotalLength = 0020
Jan 1 00:00:06 kernel: bNumInterfaces = 01
Jan 1 00:00:06 kernel: bConfigurationValue = 01
Jan 1 00:00:06 kernel: iConfiguration = 00
Jan 1 00:00:06 kernel: bmAttributes = 80
Jan 1 00:00:06 kernel: MaxPower = 100mA
Jan 1 00:00:06 kernel:
Jan 1 00:00:06 kernel: Interface: 0
Jan 1 00:00:06 kernel: Alternate Setting: 0
Jan 1 00:00:06 kernel: bLength = 9
Jan 1 00:00:06 kernel: bDescriptorType = 04
Jan 1 00:00:06 kernel: bInterfaceNumber = 00
Jan 1 00:00:06 kernel: bAlternateSetting = 00
Jan 1 00:00:06 kernel: bNumEndpoints = 02
Jan 1 00:00:06 kernel: bInterface Class:SubClass:Protocol = 08:06:50
Jan 1 00:00:06 kernel: iInterface = 00
Jan 1 00:00:06 kernel: Endpoint:
Jan 1 00:00:06 kernel: bLength = 7
Jan 1 00:00:06 kernel: bDescriptorType = 05
Jan 1 00:00:06 kernel: bEndpointAddress = 87 (in)
Jan 1 00:00:06 kernel: bmAttributes = 02 (Bulk)
Jan 1 00:00:06 kernel: wMaxPacketSize = 0040
Jan 1 00:00:06 kernel: bInterval = 00
Jan 1 00:00:06 kernel: Endpoint:
Jan 1 00:00:06 kernel: bLength = 7
Jan 1 00:00:06 kernel: bDescriptorType = 05
Jan 1 00:00:06 kernel: bEndpointAddress = 08 (out)
Jan 1 00:00:06 kernel: bmAttributes = 02 (Bulk)
Jan 1 00:00:06 kernel: wMaxPacketSize = 0040
Jan 1 00:00:06 kernel: bInterval = 00
Jan 1 00:00:07 kernel: usb.c: registered new driver usblp
Jan 1 00:00:07 kernel: printer.c: v0.13: USB Printer Device Class driver
Jan 1 00:00:08 kernel: usb.c: registered new driver acm
Jan 1 00:00:08 kernel: acm.c: v0.23:USB Abstract Control Model driver for USB modems and ISDN adapters (patched)
Jan 1 00:00:08 kernel: usb.c: registered new driver serial
Jan 1 00:00:08 kernel: usbserial.c: USB Serial support registered for Generic
Jan 1 00:00:08 kernel: usbserial.c: USB Serial Driver core v1.4
Jan 1 00:00:08 kernel: usbserial.c: USB Serial support registered for Modem
Jan 1 00:00:08 kernel: modem.c: GSM/CDMA modem driver v0.1
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for PL-2303
Jan 1 00:00:09 kernel: pl2303.c: Prolific PL2303 USB to serial adaptor driver
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for FTDI SIO
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for FTDI 8U232AM Compatible
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for FTDI FT232BM Compatible
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for FTDI FT2232C Compatible
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for FTDI FT232R Compatible
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for USB-UIRT Infrared Tranceiver
Jan 1 00:00:09 kernel: usbserial.c: USB Serial support registered for Home-Electronics TIRA-1 IR Transceiver
Jan 1 00:00:09 kernel: ftdi_sio.c: v1.3.5r1:USB FTDI Serial Converters Driver
Jan 1 00:00:15 pppd[142]: In file /tmp/ppp/peers/dialup: unrecognized option '/dev/usb/tts/0'
Jan 1 00:00:17 dnsmasq[74]: DHCPREQUEST(br0) 192.168.1.157 00:26:08:dc:16:b4
Jan 1 00:00:17 dnsmasq[74]: DHCPACK(br0) 192.168.1.157 00:26:08:dc:16:b4 Alexey-K
Jan 1 00:00:45 pppd[170]: In file /tmp/ppp/peers/dialup: unrecognized option '/dev/usb/tts/0'
Jan 1 00:01:16 pppd[231]: In file /tmp/ppp/peers/dialup: unrecognized option '/dev/usb/tts/0'

diagnostic info

USB Devices
T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 11/900 us ( 1%), #Int= 1, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=b8003000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=12 MxCh= 2
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0424 ProdID=2502 Rev= 0.01
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 2mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 1 Ivl=255ms
T: Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=198a ProdID=0003 Rev= 0.00
S: Manufacturer=Modmen Corporation
S: Product=MM450 MassStorage
S: SerialNumber=000001640002
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E: Ad=87(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=08(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms


nvram show | grep modem

[admin@WL-BCAEC5C4A7FC root]$ nvram show | grep modem
wan0_modem_portspeed=
wan_modem_vid=0x198a
wan0_modem_username=mobile
wan0_modem_mtu=1492
wan_modem_passwd=internet
wan_modem_pui=0
wan_modem_usbloc=1.1
wan0_modem_pdata=0
wan0_modem_dialup_init=
wan0_modem_ipaddr=
wan_modem_options=
wan0_modem_port_ui=/dev/ttyUSB0
wan_modem_pdata=0
wan0_modem_zerocd_mode=Auto
wan0_modem_vid=0x198a
wan0_modem_idle=60
wan_modem_demand=0
wan0_modem_passwd=internet
wan0_modem_pui=0
wan_modem_dialno=#777
wan0_modem_usbloc=1.1
wan_modem_apn=
wan0_modem_type=W
wan0_modem_maxfail=0
wan_modem_dialup_init=
wan_modem_mru=1492
wan0_modem_autodetect=0
wan_modem_pid=0x0002
wan0_modem_demand=0
size: 15280 bytes (17488 left)
wan_modem_idle=60
wan0_modem_dialno=#777
wan_modem_autodetect=0
wan_modem_zerocd_mode=UserDefined
wan_modem_portspeed=
wan0_modem_apn=
wan_modem_onfailure=
wan_modem_username=mobile
wan0_modem_gateway=
wan_modem_type=W
wan_modem_maxfail=0
wan_modem_mtu=1492
wan_modem_init_script=
wan0_modem_mru=1492
wan0_modem_options=
wan0_modem_pid=0x0002
[admin@WL-BCAEC5C4A7FC root]$ Connection closed by foreign host.
alexey-k:~ alexeykuzmin$ telnet 192.168.1.1
Trying 192.168.1.1...
Connected to wl-bcaec5c4a7fc.
Escape character is '^]'.
WL-BCAEC5C4A7FC login: admin
Password:
[admin@WL-BCAEC5C4A7FC root]$ nvram show | grep modem
wan0_modem_portspeed=
wan_modem_vid=0x198a
wan0_modem_username=mobile
wan0_modem_mtu=1492
wan_modem_passwd=internet
wan_modem_pui=0
wan_modem_usbloc=1.1
wan0_modem_pdata=0
wan0_modem_dialup_init=
wan0_modem_ipaddr=
wan_modem_options=
wan0_modem_port_ui=/dev/ttyUSB0
wan_modem_pdata=0
wan0_modem_zerocd_mode=Auto
wan0_modem_vid=0x198a
wan0_modem_idle=60
wan_modem_demand=0
wan0_modem_passwd=internet
wan0_modem_pui=0
wan_modem_dialno=#777
wan0_modem_usbloc=1.1
wan_modem_apn=
wan0_modem_type=W
wan0_modem_maxfail=0
wan_modem_dialup_init=
wan_modem_mru=1492
wan0_modem_autodetect=0
wan_modem_pid=0x0002
size: 15280 bytes (17488 left)
wan0_modem_demand=0
wan_modem_idle=60
wan0_modem_dialno=#777
wan_modem_autodetect=0
wan_modem_zerocd_mode=UserDefined
wan_modem_portspeed=
wan0_modem_apn=
wan_modem_onfailure=
wan_modem_username=mobile
wan0_modem_gateway=
wan_modem_type=W
wan_modem_maxfail=0
wan_modem_mtu=1492
wan_modem_init_script=
wan0_modem_mru=1492
wan0_modem_options=
wan0_modem_pid=0x0002

dlukanidin
16-07-2012, 10:18
syslog
diagnostic info
nvram show | grep modem


1. Неполный syslog
2. Это не Diagnoctic info

Вроде устройство переключилось правильно.
Рекомендация - прошейте последнюю версию прошивки "от Энтузиастов" и если будут проблемы выкладывайте полную инфрмацию (только п-жста в присоединенном архиве).

nataraj
02-01-2014, 20:44
Пытаюсь к Dir-320 с прошивкой от r5066 от vampik подключить CDMA модем LM-700r от JOA Telecom

Модем прекрасно проходит usb_modeswitch, но отказывается собственно говоря подсоединяться, сообщая в лог модема


Calling GPRS/UMTS/LTE
ATZ
OK
AT+CGDCONT=1,"IP",""
ERRORFailed (ERROR)
Script /tmp/ppp/peers/wan0_chat.sh finished (pid 625), status = 0x7
Connect script failed

Если зайти телнетом в /tmp/ppp/peers/ и посмотреть в wan0_chat то там видно

ABORT '~'
ABORT 'BUSY'
ABORT 'NO CARRIER'
ABORT 'ERROR'
REPORT 'CONNECT'
'' 'ATZ'
SAY 'Calling GPRS/UMTS/LTE'
'OK' ''
'' 'AT+CGDCONT=1,"IP",""'
'OK' 'ATD#777'
'CONNECT' ''


То есть чат скрипт от GPRS. Если отредатировать этот файл и убрать '' 'AT+CGDCONT=1,"IP",""' то коннект к интернету происходит успешно.

При этом (!) В веб интефейсе точно выбран CDMA
Так же (!!) Если с теми же настройками подключить CDMA модем C-motech CNU-680, то к интернету подключается c лету, а в /tmp/ppp/peers/wan0_chat оказывается подабающий CDMA чат-скрипт.

Как ему это удается -- я пока не понимаю. Чисто визуальная разница есть в том, что LM700-r создает устройство /dev/ttyACM0, а CNU-680 -- /dev/ttyUSB0 . Может это как-то влияет на внутреннюю логику /usr/ppp/dial которая как я понимаю /tmp/ppp/peers/* и заполняет. Как разберусь как малой кровью добавить в прошивку модифицированный /usr/ppp/dial, то возможно смогу за этой логикой проследить и выяснить где порылась собака.


ЗЫ. Я не очень хорошо понимаю как использовать форумы, все больше почтовыми рассылками пользуюсь, поэтому я не понимаю надо ли это сообщение доавлять в какую-то тему или как-то еще. Если я не прав -- перенесите куда следует. Сорри.

Update: Люди добрые! Кто знает, подскажите таки, как редактировать /usr/ppp/dial !!!


mkdir /usr/local/usr/
mkdir /usr/local/usr/ppp
cp /usr/ppp/dial /usr/local/usr/ppp
vi /usr/local/usr/ppp/dial
flashfs save && flashfs commit && flashfs enabled
reboot

Не помогает. Другого рецепта в сети не находится... :-(

Update2:
https://code.google.com/p/firmware-mod-kit/ -- тоже не помогает: если разобрать прошивку и потом собрать обратно -- не работает. :-(

nataraj
04-01-2014, 07:11
Есть серьезная потребность редактировать .sh скрипт из прошивки от энтузиастов (конкретно /usr/local/usr/ppp/dial, чтобы разобраться почему он не работает для меня (http://wl500g.info/showthread.php?33085-CDMA-%EC%EE%E4%E5%EC-JOA-Telecom-LM-700R-%E8-WL-500gP&p=264880#post264880))

Однако я так и не преуспел. Пробовал

mkdir /usr/local/usr/
mkdir /usr/local/usr/ppp
cp /usr/ppp/dial /usr/local/usr/ppp
vi /usr/local/usr/ppp/dial
flashfs save && flashfs commit && flashfs enabled
reboot

После перезагрузки модификации в нужный файл не попадают.

Пробовал
https://code.google.com/p/firmware-mod-kit/



./extract-firmware.sh DIR320-3.0.6-r5066M.bin
./build-firmware.sh -min fmk

После перепрошивки результатом (даже если ничего не модифицировать) роутер не взлетает.

Роутер Dir-320 с последней стабильной прошивкой от эньтузиастов в сборке от vampik

Что я делаю не так? Как сделать так? У кого-то вообще вышеперечисленные методы работали? Ради редактирования одного .sh скрипта всю прошивку из исходников собирать ой как не хочется...

nataraj
05-01-2014, 20:34
Я умудрился обойтись без модификации прошивки, mount -t tmpfs tmpfs /usr/ppp спас отца русской демократии...

Достаточно быстро выяснилось, что /usr/ppp/dial берет тип модема из wan0_modem_type который, что удивительно, когда втыкают LM-700R становиться 'W', а если воткнуть CNU-680, то становиться 'C'. Прямо на глазах у изумленной публики. То есть от того что выбранно в веб-интерфейсе вообще ничего не зависит, оно по какому-то алгоритму само пытается определить автоматом.

Я попытался поискать вхождения в искодном тектсе 'W' и "W" и нашел интересный файл: rc/usbmodem.h В нем перечисленны usb-id'ы разных модемов с указанием типа. Так вот CNU-680 в этом списке присутсвует. Судя по всему поэтому он и работает.

И видимо, если добавить туда


// JOA Telecom LM-700r
{ MODEM_DEVICE_AND_INTERFACE_NUMBER(0x198a, 0x0002, TYPE_CDMA, 0, 3) },

или что-то подобное (за последние две цифры я не ручаюсь) то данный конкретный модем начнет работать из коробки.

Правда обосновать это я не могу. Мне собрать модифицированную прошивку так и не удалось... И под Debian Jessie и под Wheezy оно умирает на этапе сборки iptables со словами "collect2: ld terminated with signal 11 [Segmentation fault]"

Завтра попробую на более древних дебианах пособирать...

Omega
06-01-2014, 02:51
http://code.google.com/p/wl500g/issues/detail?id=429 :rolleyes:

http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=680 ;)

nataraj
06-01-2014, 06:31
http://code.google.com/p/wl500g/issues/detail?id=429 :rolleyes:
Это я создал. Оно ровно про то же.



http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=680 ;)
Как написано ниже, usb_modeswitch успешно проходит... Но коннекта не происходит... А уазанная ссылка описывает проблемы с usb_modeswitch


Лучше помогите прошивку собрать :-)

dlukanidin
06-01-2014, 14:50
Это я создал. Оно ровно про то же.


Как написано ниже, usb_modeswitch успешно проходит... Но коннекта не происходит... А уазанная ссылка описывает проблемы с usb_modeswitch


Лучше помогите прошивку собрать :-)

Скорее всего у Вас стоит автодетект и из-за этого устанавливается переменная типа модема. Я на всякий случай просмотрел usbmodem.c, там всё правильно.

P.S. Нет необходимости пересобирать прошивку, хотя если хочется, то только приветствуется. Установите параметры модема в веб морде, отключите автодетект и всё должно заработать. Проверьте, что всё работает и укажите здесь строку которую надо внести в файл заголовка, её добавят в одну из ближайших сборок.

nataraj
06-01-2014, 17:28
Скорее всего у Вас стоит автодетект и из-за этого устанавливается переменная типа модема. Я на всякий случай просмотрел usbmodem.c, там всё правильно.

Да, в usbmodem.c -- все правильно. Просто результаты его работы используются неожиданным способом.

Получается что "Autodetect device" из "Custom USB device parameters" овверрайдит значение "Modem type" из совершенно другого раздела. Это честно говоря весьма неожиданно. На мой взгляд -- это баг.




P.S. Нет необходимости пересобирать прошивку, хотя если хочется, то только приветствуется.

Я был близок к победе :-) Только оно все равно не собралось... Там баг какой-то странный. Ему определения функций каких-то не хватало. Я к сожалению не записал, а теперь воспроизводить уже лень. Может быть пожалуюсь позже в соответствующую тему...



Установите параметры модема в веб морде, отключите автодетект и всё должно заработать. Проверьте, что всё работает и укажите здесь строку которую надо внести в файл заголовка, её добавят в одну из ближайших сборок.

Да, действительно, при отключении автодетекта все заработало.

Параметры, при которых заработало:

USB device location ID: 1
Data port: 0
User interface port: 0
USB device Vendor ID: 0x198a
USB device Product ID: 0x0002

Думаю в строку для usbmodem.h вы эти данные преобразуете лучше меня.

Спасибо за помощь, а то я бы еще два дня эту прошивку на разных дебианах пытался бы собрать...

dlukanidin
06-01-2014, 18:43
Да, в usbmodem.c -- все правильно. Просто результаты его работы используются неожиданным способом.

Получается что "Autodetect device" из "Custom USB device parameters" овверрайдит значение "Modem type" из совершенно другого раздела. Это честно говоря весьма неожиданно. На мой взгляд -- это баг.


Да, действительно, при отключении автодетекта все заработало.

Параметры, при которых заработало:

USB device location ID: 1
Data port: 0
User interface port: 0
USB device Vendor ID: 0x198a
USB device Product ID: 0x0002

Думаю в строку для usbmodem.h вы эти данные преобразуете лучше меня.

Спасибо за помощь, а то я бы еще два дня эту прошивку на разных дебианах пытался бы собрать...
Почему баг то, всё вроде логично, если автомат, то параметры берутся из базы. Если устройства нет в базе (в файле заголовка), то надо всё назначать ручками.

P.S. Кстати, ваш модем уже добавлен в базу, будет работать на автомате. ;)

http://wl500g.info/showthread.php?22275-quot-%CE%E1%E2%FF%E7%EA%E0-quot-3G-%E8-CDMA-%ED%E0-%EF%F0%EE%F8%E8%E2%EA%E5-%FD%ED%F2%F3%E7%E8%E0%F1%F2%EE%E2&p=264927#post264927