PDA

Bekijk de volledige versie : [IRC] WL500g crashes



Death
21-04-2004, 17:03
I had no problems since yesterday but since then everytime I connect to an IRC server (using Trillian) the WL500g system crashes (I tried different ports and exesive portscans to test the stablity). I'm using 1.7.5.6 (and since 5 minutes the customised version 2, which does the same :( )
Has anybody else had that problem before (can't find reference to it using the forum's search function)?
:confused:

Kronos
21-04-2004, 18:31
Well when i bought Asus, the first day i had many conections reset by peer, but then i

Ineternet Firewall

LAn & Wan Filter

Packets(LAN to WAN) not specified will be: Accept

Filtered ICMP(LAN to WAN) packet types:
0 8

Packets(WAN to LAN) not specified will be:
Accept

Filtered ICMP(WAN to LAN) packet types:
0 8

i don't understand if your problem is router reseting or conection reset by peer in IRC ...

Death
25-04-2004, 19:26
I tried one or two things and the results are nothing I like to see:
All IRC programs cause the router software to crash and reseting it and uploading a config file doesnt help. I'll try to reset it and use a very old config now. My last hope...

Death
25-04-2004, 19:32
Result: It took about 5 seconds longer to crash...

Antiloop
25-04-2004, 21:46
what about when connecting at this site:
http://chat.efnet.info it works fine at my router..
also using mIRC is going with no problems at all

Death
26-04-2004, 10:05
Appletts don't cause crashes. I used another one yesterday evening to let some friends know that I won't be on the IRC network untill I fixed the problem (and found out what caused it...).

Antiloop
26-04-2004, 10:20
and what if you connect using mIRC (very wide used irc client)..? does it crash too then?

Death
26-04-2004, 10:40
Yes.

Antiloop
26-04-2004, 10:52
ahh.. we'll come a little further..

is your websetup exposed to the internet?

e.g. port 80 or port 8080 ?

if yes ( or let someone else try ) then probably the irc server is scanning your for open proxies

when doing this, the wl500g doesn't like this and because of a bug in http daemon it stops http and restarts out of it own..

Death
26-04-2004, 11:00
The webinterface is open at port 8080. I will try closing it and start an IRC client.

Death
26-04-2004, 11:23
Disabling WAN administration worked! I'm back on IRC. Thank you very much!

Antiloop
26-04-2004, 11:57
you could open your webbased setup to WAN, but use another port than the standard proxy ports e.g. 8080, 80, 3128, 8192 etc..

we should update that http daemon thing soon, cuz it sucks when someone knows it.. and starts hitting you at your websetup-port :)

you can reproduce the problem yourself

e.g. in windows: telnet my.router 80
and press your enter key and quit the telnet client.

you'll see the wl500g will reboot in a few seconds..