PDA

Bekijk de volledige versie : WL-HDD USB Hub not working



r0ll3r
05-07-2005, 17:28
Hello there,
here is a small problem i am having with WL-HDD, firmware Oleg's 1.9.2.7-6b.
USB port on my WL-HDD seems to be unavailable. If i plug in a USB Pendrive (512 megs), small green led lights up for a little, but nothing else happens. I checked /tmp/syslog.log, but there are no traces of any error messages, no new message when i plug in.

I also tried to plug in a USB printer, nothing happens. If i send a test print page, syslog says "/dev/usb/lp0: No such device". And this is true, /dev/usb folder is empty.

Otherwise, telnet, ssh, samba works perfectly.

syslog.log (some parts cut):

Jan 1 01:00:10 syslogd started: BusyBox v1.00 (2005.05.11-18:29+0000)
...
Jan 1 01:00:10 kernel: !unable to setup serial console!
...
Jan 1 01:00:11 kernel: Checking for 'wait' instruction... unavailable.
...
Jan 1 01:00:11 kernel: Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
Jan 1 01:00:11 kernel: loop: loaded (max 8 devices)
Jan 1 01:00:11 kernel: PPP generic driver version 2.4.2
Jan 1 01:00:11 kernel: PPP Deflate Compression module registered
Jan 1 01:00:11 kernel: PPP BSD Compression module registered
Jan 1 01:00:11 kernel: MPPE/MPPC encryption/compression module registered
Jan 1 01:00:11 kernel: Amd/Fujitsu Extended Query Table v1.1 at 0x0040
Jan 1 01:00:11 kernel: Physically mapped flash: Swapping erase regions for broken CFI table.
Jan 1 01:00:11 kernel: number of CFI chips: 1
Jan 1 01:00:11 kernel: Flash device: 0x400000 at 0x1fc00000
Jan 1 01:00:11 kernel: Physically mapped flash: squashfs filesystem found at block 942
Jan 1 01:00:11 kernel: Creating 5 MTD partitions on "Physically mapped flash":
Jan 1 01:00:11 kernel: 0x00000000-0x00040000 : "pmon"
Jan 1 01:00:11 kernel: 0x00040000-0x003e0000 : "linux"
Jan 1 01:00:11 kernel: 0x000eba00-0x003e0000 : "rootfs"
Jan 1 01:00:11 kernel: 0x003f0000-0x00400000 : "nvram"
Jan 1 01:00:11 kernel: 0x003e0000-0x003f0000 : "config"
Jan 1 01:00:11 kernel: sflash: chipcommon not found
Jan 1 01:00:11 kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Jan 1 01:00:11 kernel: IP Protocols: ICMP, UDP, TCP
Jan 1 01:00:11 kernel: IP: routing cache hash table of 512 buckets, 4Kbytes
Jan 1 01:00:11 kernel: TCP: Hash tables configured (established 1024 bind 2048)
Jan 1 01:00:11 kernel: ip_conntrack version 2.1 (128 buckets, 1024 max) - 344 bytes per conntrack
Jan 1 01:00:11 kernel: ip_conntrack_pptp version 1.9 loaded
Jan 1 01:00:11 kernel: ip_nat_pptp version 1.5 loaded
Jan 1 01:00:11 kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jan 1 01:00:11 kernel: ipt_time loading
Jan 1 01:00:11 kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Jan 1 01:00:11 kernel: IPv6 v0.8 for NET4.0
Jan 1 01:00:11 kernel: IPv6 over IPv4 tunneling driver
Jan 1 01:00:11 kernel: NET4: Ethernet Bridge 008 for NET4.0
Jan 1 01:00:11 kernel: 802.1Q VLAN Support v1.7 Ben Greear <greearb@candelatech.com>
Jan 1 01:00:11 kernel: All bugs added by David S. Miller <davem@redhat.com>
Jan 1 01:00:11 kernel: FAT: bogus logical sector size 45056
Jan 1 01:00:11 kernel: FAT: bogus logical sector size 45056
Jan 1 01:00:11 kernel: NTFS: Unable to set blocksize 512.
Jan 1 01:00:11 kernel: VFS: Mounted root (squashfs filesystem) readonly.
Jan 1 01:00:11 kernel: Mounted devfs on /dev
Jan 1 01:00:11 kernel: Freeing unused kernel memory: 72k freed
Jan 1 01:00:11 kernel: Warning: unable to open an initial console.
Jan 1 01:00:11 kernel: Algorithmics/MIPS FPU Emulator v1.5
Jan 1 01:00:11 kernel: Uniform Multi-Platform E-IDE driver Revision: 6.31
Jan 1 01:00:11 kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Jan 1 01:00:11 kernel: PDC20265: IDE controller on PCI bus 01 dev 08
Jan 1 01:00:11 kernel: PCI: Enabling device 01:01.0 (0004 -> 0007)
Jan 1 01:00:11 kernel: PDC20265: chipset revision 2
Jan 1 01:00:11 kernel: PDC20265: not 100% native mode: will probe irqs later
Jan 1 01:00:11 kernel: PDC20265: ROM enabled at 0x000d0000
Jan 1 01:00:11 kernel: PDC20265: (U)DMA Burst Bit DISABLED Primary PCI Mode Secondary PCI Mode.
Jan 1 01:00:11 kernel: PDC20265: FORCING BURST BIT 0x00 -> 0x01 ACTIVE
Jan 1 01:00:11 kernel: ide0: BM-DMA at 0x0140-0x0147, BIOS settings: hda:DMA, hdb:pio
Jan 1 01:00:11 udhcpc[39]: Lease of 192.168.1.101 obtained, lease time 172800
Jan 1 01:00:11 kernel: settings: hdc:pio, hdd:pio
Jan 1 01:00:11 kernel: hda: IC25N030ATCS04-0, ATA DISK drive
Jan 1 01:00:11 kernel: ide2: ports already in use, skipping probe
Jan 1 01:00:11 kernel: ide3: ports already in use, skipping probe
Jan 1 01:00:11 kernel: ide4: ports already in use, skipping probe
Jan 1 01:00:11 kernel: ide5: ports already in use, skipping probe
Jan 1 01:00:11 kernel: ide0 at 0x100-0x107,0x10a on irq 6
Jan 1 01:00:11 kernel: blk: queue c00262c8, I/O limit 4095Mb (mask 0xffffffff)
Jan 1 01:00:11 kernel: hda: 58605120 sectors (30006 MB) w/1768KiB Cache, CHS=58140/16/63, UDMA(33)
Jan 1 01:00:11 kernel: Partition check:
Jan 1 01:00:11 kernel: /dev/ide/host0/bus0/target0/lun0: [PTBL] [3648/255/63] p1 p2 < p5 >
Jan 1 01:00:11 kernel: eth0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.7.0
Jan 1 01:00:11 kernel: eth1: Broadcom BCM47xx 10/100 Mbps Ethernet Controller 3.90.7.0
Jan 1 01:00:11 kernel: PCI: Enabling device 01:02.0 (0004 -> 0006)
Jan 1 01:00:11 kernel: eth2: Broadcom BCM4320 802.11 Wireless Controller 3.90.23.0
Jan 1 01:00:11 kernel: device eth0 entered promiscuous mode
Jan 1 01:00:11 kernel: device eth1 entered promiscuous mode
Jan 1 01:00:11 kernel: device eth2 entered promiscuous mode
Jan 1 01:00:11 kernel: br0: port 3(eth2) entering learning state
Jan 1 01:00:11 kernel: br0: port 2(eth1) entering learning state
Jan 1 01:00:11 kernel: br0: port 1(eth0) entering learning state
Jan 1 01:00:11 kernel: br0: port 3(eth2) entering forwarding state
Jan 1 01:00:11 kernel: br0: topology change detected, propagating
Jan 1 01:00:11 kernel: br0: port 2(eth1) entering forwarding state
Jan 1 01:00:11 kernel: br0: topology change detected, propagating
Jan 1 01:00:11 kernel: br0: port 1(eth0) entering forwarding state
Jan 1 01:00:11 kernel: br0: topology change detected, propagating
Jan 1 01:00:11 kernel: usb.c: registered new driver usbdevfs
Jan 1 01:00:11 kernel: usb.c: registered new driver hub
Jan 1 01:00:11 dhcp client: bound IP : 192.168.1.101 from 192.168.1.1
Jan 1 01:00:11 kernel: usb-ohci.c: USB OHCI at membase 0xb8004000, IRQ 2
Jan 1 01:00:11 kernel: usb-ohci.c: usb-00:04.0, PCI device 14e4:4715
Jan 1 01:00:11 kernel: usb.c: new USB bus registered, assigned bus number 1
Jan 1 01:00:12 kernel: hub.c: USB hub found
Jan 1 01:00:12 kernel: hub.c: 2 ports detected
Jan 1 01:00:12 kernel: usb.c: registered new driver usblp
Jan 1 01:00:12 kernel: printer.c: v0.13: USB Printer Device Class driver
Jan 1 01:00:14 kernel: usb.c: registered new driver audio
Jan 1 01:00:14 kernel: audio.c: v1.0.0:USB Audio Class driver
Jan 1 01:00:14 kernel: SCSI subsystem driver Revision: 1.00
Jan 1 01:00:15 kernel: Initializing USB Mass Storage driver...
Jan 1 01:00:15 kernel: usb.c: registered new driver usb-storage
Jan 1 01:00:15 kernel: USB Mass Storage support registered.
Jul 5 17:13:53 dropbear[86]: Running in background
Jul 5 17:14:01 ntp client: Synchronizing time with time.kfki.hu ...
Jul 5 17:14:02 kernel: VFS: Can't find ext3 filesystem on dev ide0(3,1).
Jul 5 17:14:02 kernel: MSDOS FS: Using codepage 950
Jul 5 17:14:02 kernel: MSDOS FS: IO charset cp950
Jul 5 17:14:02 kernel: FAT: bogus logical sector size 0
Jul 5 17:14:02 kernel: VFS: Can't find a valid FAT filesystem on dev 03:01.
Jul 5 17:14:02 kernel: FAT: freeing iocharset=cp950
Jul 5 17:14:02 kernel: FAT: bogus logical sector size 0
Jul 5 17:14:02 kernel: VFS: Can't find a valid FAT filesystem on dev 03:01.
Jul 5 17:14:02 kernel: attempt to access beyond end of device
Jul 5 17:14:02 kernel: 03:02: rw=0, want=2, limit=1
Jul 5 17:14:02 kernel: EXT3-fs: unable to read superblock
Jul 5 17:14:02 kernel: MSDOS FS: Using codepage 950
Jul 5 17:14:02 kernel: MSDOS FS: IO charset cp950
Jul 5 17:14:02 kernel: FAT: bogus logical sector size 0
Jul 5 17:14:02 kernel: VFS: Can't find a valid FAT filesystem on dev 03:02.
Jul 5 17:14:02 kernel: FAT: freeing iocharset=cp950
Jul 5 17:14:02 kernel: FAT: bogus logical sector size 0
Jul 5 17:14:02 kernel: VFS: Can't find a valid FAT filesystem on dev 03:02.
Jul 5 17:14:02 kernel: kjournald starting. Commit interval 5 seconds
Jul 5 17:14:02 kernel: EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,5), internal journal
Jul 5 17:14:02 kernel: EXT3-fs: recovery complete.
Jul 5 17:14:02 kernel: EXT3-fs: mounted filesystem with ordered data mode.
Jul 5 17:14:02 USB storage: ext3 fs mounted to /tmp/harddisk
Jul 5 17:14:02 FTP server: daemon is started
Jul 5 17:14:05 dropbear[101]: Child connection from ::ffff:192.168.1.100:2735
Jul 5 17:14:09 dropbear[101]: password auth succeeded for 'lofasz' from ::ffff:192.168.1.100:2735

cat /proc/bus/usb/devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB OHCI Root Hub
S: SerialNumber=b8004000
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

Awaiting ideas.

Oleg
06-07-2005, 10:41
Repair/replace your unit. Seems to be hw problem.

sdf
07-07-2005, 08:20
I am using firmware ver 1234 and have 2 usb pen drives the 128 meg one works fine but the 1 gig drive wont work at all the light does flash a few times but then nothing i guess its not compatible?

r0ll3r
07-07-2005, 10:20
My problem is solved. I rebooted my WL-HDD several times, and now it's ok. USB seem to recognise both usb mass storage and usb printer. My firmware is 1.9.2.7-6b. Usb mass storage is a 512mb pendrive.