PDA

Bekijk de volledige versie : wl500/wlhdd toolchain on gentoo



ray
09-05-2005, 20:47
Tryin to install toolchain on my gentoo box,
(2.6 kernel, fresh install)
followeb Oleg's instructions on
http://wiki.wl500g.info/index.php/compilingcustomfirmware
with only one exeption, I didn't Move entire /whatever/you/want/broadcom/opt to /opt,
but did ln -s ..... (as my / is only about 1 G)
so on the
# cd /whatever/you/want/broadcom/src/wl500g-1.9.2.7-4
# make kernel
went well, but next
# make
brings the following error:
""checking for C compiler default output file name... configure: error: C compiler cann ot create executables
See `config.log' for more details.
make: *** [/whatever/you/want/broadcom/src/gateway/dropbear/config.h] Error 77""
Any ideas on wat's the matter?

Oleg
09-05-2005, 21:02
Have you added your toolchain to the PATH? Does mipsel-uclibc-gcc works?

ray
09-05-2005, 21:10
Da!
Yes! i did,
thing is that it says : "error: C compiler cannot create executables"
sounds starange,
so i suppose it sees it, runs it, but......

ray
10-05-2005, 02:38
Got as far as
"# cp /path/to/wl500g-1.7.5.9-3/.config ."
but there is NO "/path/to/wl500g-1.7.5.9-3/"....
do I have to download it?, (i've got wl500g-kernel-1.7.5.9-3.patch.gz)
if it's a different file, create it, or it has to be created automatically,
or ....
so basically what do I do from here?
:confused:

freak
09-08-2005, 00:44
hi

I have the same error on my gentoo

try


#export PATH=$PATH:/opt/brcm/hndtools-mipsel-uclibc/bin:/opt/brcm/hndtools-mipsel-linux/bin