PDA

Bekijk de volledige versie : Home gateway disfunction or broken?



Leopoldo
02-04-2004, 00:05
Dear friends,
thanks for setting up this nice phorum.

Before posting this question, I have wasted several days trying to find out what happens in my new WL500g, without success.

Until now I have been using the venerable Apple Airport without problems.

I cannot discover why no ARP packets can be exchanged from my wireless Linux box (running a 2.4.20 kernel) to the WL500g (so no other ICMP or IP packets can be exchanged at all).

Wireless link layer is correctly set up. Indeed I can connect with other wired machines in the LAN interface of the WL500g without any trouble.

WL500g remains at factory defaults of the "Home Gateway" mode.

I have used many firmware packages with the same behaviour. Using telnet (1.6.5.3-5 firmware) I have found out the unique rare thing, "brctl show br0" does NOT display the list of its interfaces (supposely eth0 and eth2). Rare? All other commands seemingly are good (ifconfig, route, iptables)

Indeed I am stuck, is my WL500g broken?, is my brain damaged?

Please, any comments are welcome.

Technik
02-04-2004, 00:49
Try to check the wireless traffic using TCPDUMP : http://wl500g.info/showthread.php?s=&threadid=75&highlight=tcpdump

BTW I have not heard about any broken WL-500b/g so far. ;)

Leopoldo
02-04-2004, 09:54
Yes, I tried several statically linked version of tcpdump downloaded from Internet, though they do not work.

Now I am linked my own version from sources. The suggestion about --without-crypto is nice.

Regards

Leopoldo
02-04-2004, 11:32
As bramfm was in trouble building a statically linked version of tcpdump
http://wl500g.info/showthread.php?s=&threadid=75&highlight=tcpdump

my little contribution to the phorum is how do it:

From http://www.tcpdump.org, unpack libpcap and tcpdump packages into /usr/local

cd libpcap
env CFLAGS=-static ./configure --without-flex --without-bison
make (no install is required)

cd tcpdump
env CFLAGS=-static ./configure --without-crypto
make
strip tcpdump
make install (or rather ftp to WL500g)

Using gcc3 on tcpdump 0.8.3 and glibc 2.2.4 a 900KB executable should be generated

Technik
02-04-2004, 21:46
Originally posted by Leopoldo
As bramfm was in trouble building a statically linked version of tcpdump
http://wl500g.info/showthread.php?s=&threadid=75&highlight=tcpdump

Well, did not you read the the whole mentioned thread?
Bramfm worked it out so there's a link to WORKING tcpdump - I have used it many times without problem:
http://members.chello.nl/~m.kuystermans/tcpdump.zip

Leopoldo
17-04-2004, 18:07
Dear friends,
at last I found the misfunction. Trouble is the "wvlan_cs" wireless driver, I replaced it by "orinoco_cs" and trouble disappear.

Indeed, I cannot establish a logic relation between the wireless driver and the described "selective" ARP problem. However, I am sure of my former findings are correct.

Thanks for all your kindness