PDA

Bekijk de volledige versie : MTU problem



BlueScreen
19-04-2005, 16:14
Hi,
I formerly used a debian/linux router (iptables) to access the internet from my local lan. Then I recently bought the wl500g. The dsl-internet-connection seems to work fine, except for ftp uploads and the homepage hotmail.com. Trying this with two different WinXP pcs always causes connection-timeouts. Doing the ftp-uploads with the debian-pc (also using the internet connection of the wl500g), no errors occured.

With the help of some googleing, I found out that this has something to do with the MTU settings. I downloaded the program improveTCP (http://www.aidex.de/software/improve-tcp/) (sorry, homepage is in German, but program can be switched to English) and manually set the MTU of one XP machine to 1492. This solved the problem at that machine.

How does it come, that using the debian-router, everything works fine and using the wl500g-router, you manually have to asign the mtu to the winxp machines? Is there a setting on the router, that allows ftp-uploading from xp-machines without changing the mtu?

Thanks for your help, Blue

modnet25
21-04-2005, 21:14
hi,

i had the same problem.
is there a desktop firewall installed on the xp-machine?
in my case disabling the firewall (kerio personell blabla) was the key.
then i set the xp-machin mtu to a fixed value (like you did) and enable the firewall again - and it worked.

what i believe is that the firewall adds some information to the incoming traffic - then the tcp-stack (or anything else) recognizes that and packets get fragmented which means that ftp uploads and sometimes http does not work.

may be thats the thing - may be not :)

what do you think about that?
or may be oleg - wassup with you?

so far
modnet26

modnet25
21-04-2005, 21:16
you may want to read my how-to --> it explains the whole thing alot better :D

http://wl500g.info/showthread.php?t=1920

BlueScreen
22-04-2005, 08:51
Yes, I'm also running Kerio Personal Firewall on both xp-machines. But my point is not solving the issue in xp, but solving it on the router because as I mentioned, everything worked when I was using a debian-linux server as router. I didn't change anything on the xp machines so there ought to be a solution concerning the router configuration :confused:

I still have the debian-linux server so I was able to compare the iptables. As the following rule on the router obviously influences mtu/mss behaviour I deleted it and tried again, but there was no improvement on the unpatched(=mtu not assigned manually) xp-machine.
TCPMSS tcp -- anywhere anywhere tcp flags:SYN,RST/SYN tcpmss match 1453:65535TCPMSS set 1452

Blue

modnet25
13-03-2006, 14:49
yes - i would like to know the answer too :-)
same applies for me. i used a smc barricade before and everything went fine.
problems came up with the wl500g

modnet25
27-03-2006, 13:54
hi,

try to disable all the icmp filtering in the kerio pf and it should wokr without the static mtu setting in the registry
alex