PDA

Bekijk de volledige versie : Interesting print problem Works on USB but not LPT



TRIROG
15-04-2005, 15:34
Hi All!
I have a Xerox DocuPrint P8EX, and have come across a strange problem, until today printer was connected to a FreeSCO box through LPT that was acting as a PS for the LAN, but today i received WL500g and have decided to connect the Xerox to WL ...

Now what happens is ... Using FRW 1.8.2.4( after many other tried) And LPR mode set, Printing on USB works fine, but if i connect the printer to paralel port, not changing anything else, i get 4,5 sheets of "sheet"( :) ) Garbage printed.

How come?

I have also tried newer firmwares, but couldnt even get usb printing to work? just garbage on sheets ..., printer is responding and printing garbage ...

Have i missed something?

Best regards ...

Antiloop
15-04-2005, 15:44
perhaps you have missed something yes ;)

try the 1.9.2.7-CR4 firmware or newer at your option with RAW printing

TRIROG
15-04-2005, 16:00
Hmm ... have tried that ... but didnt work but still ... should i set any other options when using RAW mode? 've been reading on how i should set port to 9001 for lpt or sth ... is that the same in the new version? or is raw port the same for LPT and USB?

TIA

Fred
15-04-2005, 18:57
You must configure the printer ports like:

USB port 9100 RAW
LPT port 9101 RAW

Antiloop
16-04-2005, 01:44
well perhaps something is not totally compatible.. so perhaps your old machine was using another thing to share it's printer with.

TRIROG
16-04-2005, 10:38
Hmmm ... with the new ( custom) firmware, and raw mode, should i still set the port


USB port 9100 RAW
LPT port 9101 RAW

?

Whats up with official firmwares? RAW printing? not available?
TIA

TRIROG
17-04-2005, 10:54
Now i am totaly confused ...

i have succcsesfully installed the newest firmware ( 1.9.2.7.-4 i think) anyhow ... my printer now works with raw printing with no problem through USB

paralel port connection however prints garbage? i did set the raw port to 9101?
Any ideas?

@antiloop
well perhaps something is not totally compatible.. so perhaps your old machine was using another thing to share it's printer with.

A: the old machine was a linux router in a single diskette, using LPR and LPT port to print and i had no problems ...

One more thing ... the LPR support WAS removed in the newest firmwares?after the 1.8.1.7-3 ?


TIA

Oleg
17-04-2005, 12:48
Now i am totaly confused ...

i have succcsesfully installed the newest firmware ( 1.9.2.7.-4 i think) anyhow ... my printer now works with raw printing with no problem through USB

paralel port connection however prints garbage? i did set the raw port to 9101?
Any ideas?

Try replacing cable - use short cable.



One more thing ... the LPR support WAS removed in the newest firmwares?after the 1.8.1.7-3 ?

No, LPR is still included.

TRIROG
03-05-2005, 18:07
unfortunately I dont have time nor patinece to keep reseting printer afer sth goes worng and it prints garbage, i have simply connected it via USB port and it works fine now, + the cabe is thiner...


perhaps one day i will try to get the printer working with LPT, but until then i surrender ... :)

Best regards to all !

tlk
07-01-2006, 00:57
Hi Oleg


Try replacing cable - use short cable.

I have a Xerox DocuPrint P8e which seems to be identical to P8ex, except that it has no usb port.

When I connect the printer to my laptop and run
echo "hello world" > /dev/lp0 it prints out the message as expected. But when I do the same on the wl500g it prints a line of garbage. No matter what I try to print from the wl500g, all I get is a single line of garbage at the top of the page. I have used the same printer cable for both tests.

I'm not sure how to debug this problem any further. Do you have any suggestions?

Firmware release: 1.9.2.7-7 (oleg)


Btw, another printer works fine (HP Deskjet something, usb).. the wl500g sure is a cute piece of toy! :)

Thomas