PDA

Bekijk de volledige versie : Oops, I broke NAT



alexi
09-10-2009, 00:55
Hi folks,

I accidentally broke the configuration on my wl500gx and trying to figure out how to restore it. (more precisly, NAT)

After a restart (needed to change the wifi password), all hosts, wifi or ethernet, lost internet connectivity.
I logged in on the router and found out it's not doing NAT anymore.
iptables -t nat -L shows PRE/POSTROUTING and OUTPUT chains are empty.

so I manually type in the rules (iptables -t nat -A POSTROUTING [...] -j MASQUERADE) and everything works again. I've never had to do it before.

How can I restore the configuration so that it does this automatically on startup ? I found in "system setup" three choices, one of which shows "home gateway" which has NAT enabled. I've re-selected this but it still won't do NAT. I can't find the option anywhere else in the interface !

Beer in paris for whoever can help me figure it out :D

Cheers

Alex

al37919
09-10-2009, 06:00
reset to defaults either by button on the back or in web interface and start over

alexi
11-10-2009, 13:01
reset to defaults either by button on the back or in web interface and start over

Ok, I was a bit reluctant to do this, but that was quick and easy.. thanks, it's working just fine now !