PDA

Bekijk de volledige versie : wl500w - WiFi does not connect or is VERY slow



biocomp
26-09-2009, 17:21
Hi.

I've installed oleg's 1.9.2.7-10 firmware on my wl500w after buying it (and did not test wifi without it).
I also have rtorrent, openvpn and other stuff on it. But I don't think, it's a root of a problem.

When (most of the time) I try to access wl500g via notebook (eeepc 1000HE with atheros 5007EG adapter) or PC (with realteck rtl8187 adapter), connection is establishing very slowly.
If it finally succeeds, ping time is more than 3 sec, most of the packets are lost.

I've tried changing all available channels, tried WPA-PSK, WPA2-PSK, WEP, TKIP/AES, open system, bandwidth of 20 and 40mhz, nothing helps. I'm not sure, that i've tried all possible combinations, but most of them.
I see number of other wifi access points (from 0 to 5) available.

But there were few times, when with Auto channel and WPA2-PSK (in fact, I almost did not play with settings that time), when connection was excellent, Internet was working, so I assume, my hardware can (could) work.

And I could connect my PC and eeePC via wifi with no problems.

So, what could I try to check/play with?
Thanks for any help :)

wpte
26-09-2009, 17:49
did you reset the router to factory defaults after upgrading to oleg?
after that a manual set up would be the best.

anyway, there is one more important setting:
Wireless -> advanced > Regulatory Mode
some cards use d, some use h... it's a mess in draft N:p

AfterBurner and Frame Bursting can be turned on as well, they usually give a higher performance:)

I also have an eeepc (1000H) and worked great till the wificard burned:p
now it has a intel AGN card, which has a average ping of 1,3ms:)

biocomp
27-09-2009, 11:15
Thanks for suggestions :)

But i'm not using draft N, just 802.11b/g.
I did not do anything since my first post, but in the evening i could use internet via WiFi without any problems. And in the morning - could not even connect to router.
Will try to reset settings.

biocomp
02-10-2009, 06:52
Problem is fixed

After resetting and step-by-step reproducing of router settings, i've noticed, that WiFi stopped working after enabling "multicast routing".
Interesting thing is that i don't use IPTV via WiFi.

Ok, then after some more reading, i've found that manual setting of multicast transmission rate at Wireless->Advanced to (in my case) 36 Mbps works perfecly.

So, as you can see, little bit of magic, and everything is fine ;).